14 Replies Latest reply on Sep 11, 2012 4:26 PM by user558643

    rapidwiz won't start - Exception in thread "main" java.lang.UnsatisfiedLink

    user558643
      Hi ebs 12i Gurus:

      I am in the process of Migrating and upgrading EBS 11i to EBS 12.1.3 on a x86-64 bit ULN server using Note 1377213.1 (E-Business Suite Upgrades and Platform Migration), Export/import notes on Applications 11i Database 11g [Article ID 557738.1] and Oracle E-Business Suite Installation and Upgrade Notes Release 12 (12.1.1) for Linux x86-64 [ID 761566.1]. I have
      1) downloaded OracleLinux-R6-U3 x86_64, installed and patched as per Note 1377213.1
      2) Download RDBMS 11.2.0.3, installed, created DB and patched as per "Interoperability Notes Oracle EBS 11i with Oracle Database 11gR2 (11.2.0) [Article ID 881505.1]"
      3) downloaded the 64 bit ebs 12.1.1 software, Unzipped it (r ID 406138.1), ran checksum text for my o/s: md5sum_Linux64.txt & md5sum_startCD_121111.txt Note 802195.1 to make check the intergrity of files in staging area - o.k.
      4) Download and installed the latest patch for startCD which is p8639046_R12_GENERIC.zip
      5) Installed openmotif21-2.1.30-11.EL6.i686.rpm

      When I execute ./rapidwiz I get this error:

      [applfind@OFINDEV01 rapidwiz]$ ./rapidwiz

      Rapid Install Wizard is validating your file system......
      4 dvd labels found
      Rapid Install Wizard will now launch the Java Interface.....

      [applfind@OFINDEV01 rapidwiz]$ Exception in thread "main" java.lang.UnsatisfiedLinkError: /media/data1/software/StageR12/startCD/Disk1/rapidwiz/jre/Linux_x64/1.6.0/lib/i386/xawt/libmawt.so: libXi.so.6: cannot open shared object file: No such file or directory
      at java.lang.ClassLoader$NativeLibrary.load(Native Method)
      at java.lang.ClassLoader.loadLibrary0(Unknown Source)
      at java.lang.ClassLoader.loadLibrary(Unknown Source)
      at java.lang.Runtime.load0(Unknown Source)
      at java.lang.System.load(Unknown Source)
      at java.lang.ClassLoader$NativeLibrary.load(Native Method)
      at java.lang.ClassLoader.loadLibrary0(Unknown Source)
      at java.lang.ClassLoader.loadLibrary(Unknown Source)
      at java.lang.Runtime.loadLibrary0(Unknown Source)
      at java.lang.System.loadLibrary(Unknown Source)
      at sun.security.action.LoadLibraryAction.run(Unknown Source)
      at java.security.AccessController.doPrivileged(Native Method)
      at sun.awt.NativeLibLoader.loadLibraries(Unknown Source)
      at sun.awt.DebugHelper.<clinit>(Unknown Source)
      at java.awt.Component.<clinit>(Unknown Source

      I have just done:
      unlink /usr/lib/libXtst.so.6
      ln -s /usr/X11R6/lib/libXtst.so.6.1 /usr/lib/libXtst.so.6
      but to no avail !

      What am I missing?
        • 1. Re: rapidwiz won't start - Exception in thread "main" java.lang.UnsatisfiedLink
          Srini Chavali-Oracle
          This is likely because you have not completed all of the steps in MOS Doc 761566.1

          Have you completed all of the steps in Required Packages section for Linux 6 ? What is the output of this command ?
          $ ls -l /usr/X11R6/lib/libXtst.so.6.1 
          HTH
          Srini
          • 2. Re: rapidwiz won't start - Exception in thread "main" java.lang.UnsatisfiedLink
            Hussein Sawwan-Oracle
            Please see (Libxi.So.6: Cannot Open Shared Object File: No Such File When Rapidwiz is Started to Install 12.1.1 [ID 824249.1]).

            Thanks,
            Hussein
            • 3. Re: rapidwiz won't start - Exception in thread "main" java.lang.UnsatisfiedLink
              user558643
              I probably have the wrong version libXi:
              rpm -q --qf '%{NAME}-%{VERSION}-%{RELEASE} (%{ARCH})\n' libXi
              libXi-1.3-3.el6 (x86_64)

              From Note ID 824249.1, I see that I need to install libXi-1.0.1-3.1 (x86_64) & libXi-1.0.1-3.1 (i386) but yum cannot find them? Where can I manually download this files from?

              Thanks
              Mathias
              • 4. Re: rapidwiz won't start - Exception in thread "main" java.lang.UnsatisfiedLink
                Hussein Sawwan-Oracle
                From Note ID 824249.1, I see that I need to install libXi-1.0.1-3.1 (x86_64) & libXi-1.0.1-3.1 (i386) but yum cannot find them? Where can I manually download this files from?
                http://rpm.pbone.net/index.php3/stat/4/idpl/5543656/dir/startcom_5/com/libXi-1.0.1-3.1.i386.rpm.html
                http://rpm.pbone.net/index.php3/stat/4/idpl/8118337/dir/startcom_5/com/libXi-1.0.1-3.1.x86_64.rpm.html

                Thanks,
                Hussein
                • 5. Re: rapidwiz won't start - Exception in thread "main" java.lang.UnsatisfiedLink
                  user558643
                  Great. I got the files but I am unable to revove the libXi-1.3-3.el6.x86_64:
                  rpm -i libXi-1.0.1-3.1.i386.rpm
                  warning: libXi-1.0.1-3.1.i386.rpm: Header V3 DSA/SHA1 Signature, key ID 652e84dc: NOKEY
                  package libXi-1.3-3.el6.x86_64 (which is newer than libXi-1.0.1-3.1.i386) is already installed

                  rpm -e libXi-1.3-3.el6.x86_64
                  error: Failed dependencies:
                  libXi.so.6()(64bit) is needed by (installed) libXtst-1.0.99.2-3.el6.x86_64
                  libXi.so.6()(64bit) is needed by (installed) gtk2-2.18.9-10.el6.x86_64
                  libXi.so.6()(64bit) is needed by (installed) xorg-x11-server-utils-7.5-5.2.el6.x86_64
                  libXi.so.6()(64bit) is needed by (installed) libxklavier-4.0-9.el6.x86_64
                  libXi.so.6()(64bit) is needed by (installed) qt3-3.3.8b-30.el6.x86_64
                  libXi.so.6()(64bit) is needed by (installed) libXi-devel-1.3-3.el6.x86_64
                  libXi.so.6()(64bit) is needed by (installed) gtk2-devel-2.18.9-10.el6.x86_64
                  libXi.so.6()(64bit) is needed by (installed) xorg-x11-drv-wacom-0.13.0-6.el6.x86_64
                  libXi.so.6()(64bit) is needed by (installed) gnome-settings-daemon-2.28.2-20.el6.x86_64
                  libXi.so.6()(64bit) is needed by (installed) control-center-1:2.28.1-37.el6.x86_64
                  libXi.so.6()(64bit) is needed by (installed) xorg-x11-drv-synaptics-1.4.1-3.el6.x86_64
                  libXi.so.6()(64bit) is needed by (installed) qt-x11-1:4.6.2-24.el6.x86_64
                  libXi.so.6()(64bit) is needed by (installed) redhat-lsb-graphics-4.0-3.0.1.el6.x86_64
                  libXi.so.6()(64bit) is needed by (installed) wacomexpresskeys-0.4.2-3.el6.x86_64
                  libXi.so.6()(64bit) is needed by (installed) gok-2.28.1-5.el6.x86_64
                  libXi.so.6()(64bit) is needed by (installed) xorg-x11-utils-7.4-8.el6.x86_64
                  libXi.so.6()(64bit) is needed by (installed) java-1.6.0-openjdk-1:1.6.0.0-1.49.1.11.4.el6_3.x86_64
                  libXi = 1.3-3.el6 is needed by (installed) libXi-devel-1.3-3.el6.x86_64
                  libXi is needed by (installed) xorg-x11-drv-wacom-0.13.0-6.el6.x86_64
                  • 6. Re: rapidwiz won't start - Exception in thread "main" java.lang.UnsatisfiedLink
                    Hussein Sawwan-Oracle
                    rpm -e libXi-1.3-3.el6.x86_64
                    Can you try "rpm -Uvh <package name>" and see if you get the same error?
                    error: Failed dependencies:
                    libXi.so.6()(64bit) is needed by (installed) libXtst-1.0.99.2-3.el6.x86_64
                    libXi.so.6()(64bit) is needed by (installed) gtk2-2.18.9-10.el6.x86_64
                    libXi.so.6()(64bit) is needed by (installed) xorg-x11-server-utils-7.5-5.2.el6.x86_64
                    libXi.so.6()(64bit) is needed by (installed) libxklavier-4.0-9.el6.x86_64
                    libXi.so.6()(64bit) is needed by (installed) qt3-3.3.8b-30.el6.x86_64
                    libXi.so.6()(64bit) is needed by (installed) libXi-devel-1.3-3.el6.x86_64
                    libXi.so.6()(64bit) is needed by (installed) gtk2-devel-2.18.9-10.el6.x86_64
                    libXi.so.6()(64bit) is needed by (installed) xorg-x11-drv-wacom-0.13.0-6.el6.x86_64
                    libXi.so.6()(64bit) is needed by (installed) gnome-settings-daemon-2.28.2-20.el6.x86_64
                    libXi.so.6()(64bit) is needed by (installed) control-center-1:2.28.1-37.el6.x86_64
                    libXi.so.6()(64bit) is needed by (installed) xorg-x11-drv-synaptics-1.4.1-3.el6.x86_64
                    libXi.so.6()(64bit) is needed by (installed) qt-x11-1:4.6.2-24.el6.x86_64
                    libXi.so.6()(64bit) is needed by (installed) redhat-lsb-graphics-4.0-3.0.1.el6.x86_64
                    libXi.so.6()(64bit) is needed by (installed) wacomexpresskeys-0.4.2-3.el6.x86_64
                    libXi.so.6()(64bit) is needed by (installed) gok-2.28.1-5.el6.x86_64
                    libXi.so.6()(64bit) is needed by (installed) xorg-x11-utils-7.4-8.el6.x86_64
                    libXi.so.6()(64bit) is needed by (installed) java-1.6.0-openjdk-1:1.6.0.0-1.49.1.11.4.el6_3.x86_64
                    libXi = 1.3-3.el6 is needed by (installed) libXi-devel-1.3-3.el6.x86_64
                    libXi is needed by (installed) xorg-x11-drv-wacom-0.13.0-6.el6.x86_64
                    You need to install the above.

                    Why not using "yum install <package name>"? This will download all pre-req. packages in addition to the main one and all will be installed for you.

                    Thanks,
                    Hussein
                    • 7. Re: rapidwiz won't start - Exception in thread "main" java.lang.UnsatisfiedLink
                      user558643
                      [root@OFINDEV01 linux]# yum install libXi-1.0.1-3.1.i386.rpm
                      Loaded plugins: refresh-packagekit, rhnplugin, security
                      ol6_x86_64_UEK_latest | 1.2 kB 00:00
                      ol6_x86_64_latest | 1.4 kB 00:00
                      Setting up Install Process
                      Examining libXi-1.0.1-3.1.i386.rpm: libXi-1.0.1-3.1.i386
                      libXi-1.0.1-3.1.i386.rpm: does not update installed package.
                      Error: Nothing to do
                      [root@OFINDEV01 linux]#

                      Yum is not woking also:
                      [root@OFINDEV01 linux]# rpm -Uvh libXi-1.3-3.el6.x86_64
                      error: open of libXi-1.3-3.el6.x86_64 failed: No such file or directory

                      Thanks
                      Mathias
                      • 8. Re: rapidwiz won't start - Exception in thread "main" java.lang.UnsatisfiedLink
                        Hussein Sawwan-Oracle
                        Yum is not woking also:
                        [root@OFINDEV01 linux]# rpm -Uvh libXi-1.3-3.el6.x86_64
                        error: open of libXi-1.3-3.el6.x86_64 failed: No such file or directory
                        Run this command from the directory where you downloaded the rpm file to.

                        Thanks,
                        Hussein
                        • 9. Re: rapidwiz won't start - Exception in thread "main" java.lang.UnsatisfiedLink
                          user558643
                          You are up late just as I am here in MD trying to get this installation going:)))). Thanks for all the help.


                          [root@OFINDEV01 linux]# ls -la libXi-1.0.1*
                          -rw-r--r-- 1 orafind dba 25920 Sep 6 14:55 libXi-1.0.1-3.1.i386.rpm
                          -rw-r--r-- 1 orafind dba 26347 Sep 6 14:55 libXi-1.0.1-3.1.x86_64.rpm

                          [root@OFINDEV01 linux]# rpm -Uvh libXi-1.0.1-3.1.x86_64.rpm
                          warning: libXi-1.0.1-3.1.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 652e84dc: NOKEY
                          error: Failed dependencies:
                          libXi = 1.3-3.el6 is needed by (installed) libXi-devel-1.3-3.el6.x86_64

                          [root@OFINDEV01 linux]# rpm -Uvh libXi-1.0.1-3.1.i386.rpm
                          warning: libXi-1.0.1-3.1.i386.rpm: Header V3 DSA/SHA1 Signature, key ID 652e84dc: NOKEY
                          Preparing... ########################################### [100%]
                          package libXi-1.3-3.el6.x86_64 (which is newer than libXi-1.0.1-3.1.i386) is already installed

                          Question:
                          We are in the process of upgrading from 11i to 12i on ULN 6 64-bit and with all the problems we are now having, we thinking that we might be faster using a 32 bit o/s or even using ULN 5 that has been well tested. Our current apps 11i runs on ULN 4. What do you suggest or would you personally use?

                          Thanks
                          Mathias
                          • 10. Re: rapidwiz won't start - Exception in thread "main" java.lang.UnsatisfiedLink
                            Hussein Sawwan-Oracle
                            You are up late just as I am here in MD trying to get this installation going:)))). Thanks for all the help.
                            Sorry, I could not stay up longer ;)
                            [root@OFINDEV01 linux]# rpm -Uvh libXi-1.0.1-3.1.i386.rpm
                            warning: libXi-1.0.1-3.1.i386.rpm: Header V3 DSA/SHA1 Signature, key ID 652e84dc: NOKEY
                            Preparing... ########################################### [100%]
                            package libXi-1.3-3.el6.x86_64 (which is newer than libXi-1.0.1-3.1.i386) is already installed
                            This is because you already have a higher version installed, so you need to uninstall the higher package and install the required one.
                            Question:
                            We are in the process of upgrading from 11i to 12i on ULN 6 64-bit and with all the problems we are now having, we thinking that we might be faster using a 32 bit o/s or even using ULN 5 that has been well tested. Our current apps 11i runs on ULN 4. What do you suggest or would you personally use?
                            I would not recommend upgrading on 32-bit then migrating to 64-bit. We did a similar upgrade (from 11i running on 32-bit to R12 running on 64-bit) and we did not have any major issues.

                            Thanks,
                            Hussein
                            • 11. Re: rapidwiz won't start - Exception in thread "main" java.lang.UnsatisfiedLink
                              user558643
                              Hi Hussein,
                              Great help there. My Sys Admins used "yum remove ..." and we could finally install the two packages, after which rapidwiz got started.

                              Just to be little bit off here before closing this post, in this upgrade and migration I am doing, I have just finished importing the database and I in great doubt if it's time to lay out the apps with rapidwiz? You had in another post given the key docs to follow as I will list below. Do you have a concise list of steps to follow? Oracle docs are very voluminous and bouncing from one to the other making the process a nightmare for us?

                              This is the list of docs you gave:
                              Oracle E-Business Suite Installation Guide: Using Rapid Install
                              http://docs.oracle.com/cd/B53825_08/current/acrobat/121oaig.pdf

                              Oracle E-Business Suite Release 12.1.3 Now Available
                              https://blogs.oracle.com/stevenChan/entry/ebs_1213_available

                              11gR2 11.2.0.3 Database Certified with E-Business Suite
                              https://blogs.oracle.com/stevenChan/entry/11gr2_11_2_0_3

                              Thanks
                              • 12. Re: rapidwiz won't start - Exception in thread "main" java.lang.UnsatisfiedLink
                                Hussein Sawwan-Oracle
                                If the database and the database listener are up, you can proceed with laying down the R12 software and start the upgrade. The links referenced above should be helpful, and you may also refer to:

                                Oracle E-Business Suite Upgrade Guide, Release 11i to 12.1.3
                                http://docs.oracle.com/cd/B53825_08/current/acrobat/121upgrade.pdf

                                Oracle E-Business Suite Upgrade Guide Release 11i to 12.1.1 [ID 1082375.1]
                                Oracle E-Business Suite Installation and Upgrade Notes Release 12 (12.1.1) for Linux x86-64 [ID 761566.1]
                                Oracle Applications Release Notes, Release 12.1.1 [ID 798258.1]

                                Thanks,
                                Hussein
                                • 13. Re: rapidwiz won't start - Exception in thread "main" java.lang.UnsatisfiedLink
                                  user558643
                                  This problem of "rapidwiz won't start - Exception in thread "main" java.lang.UnsatisfiedLink ."
                                  was finally fixed just by installing libXi-1.3-3.el6 (i686) in addition to the existing libXi-1.3-3.el6 (x86_64) thereby not dealing with the older versions of this package.

                                  Thanks Hussein.
                                  Mathias
                                  • 14. Re: rapidwiz won't start - Exception in thread "main" java.lang.UnsatisfiedLink
                                    user558643
                                    Thank you so much Hussein. You are by far the most knowledgeable Master in EBS. Oracle should reward you:))) for always saving time and making the use of this great application easier. It's always a pleasure working with you in the Cloud.
                                    God bless
                                    Mathias