4 Replies Latest reply: Sep 10, 2012 7:54 AM by Apsalom G RSS

    AIA Installing and Deploying Demo Application failed:Build.xml not found

    Apsalom G

      i am trying to install demo application using following steps

      Extract Foundation Pack Demo under <AIA_HOME>.
      If not already done so, set environment variables:
      For Linux (bash shell)
      source <AIA_HOME>/aia_instances/<aia_instance>/bin/aiaenv.sh
      For Windows
      Navigate to aiaenv.bat located in <AIA_HOME>\aia_instances\<aia_instance>\bin
      Run aiaenv.bat
      You may have to assign higher memory values in your JVM parameter settings for demo to deploy if you have not set the maximum possible value already. Use the following three steps as guidance to configure JVM parameters:

      Navigate to <Middleware home>\user_projects\domains\<domain_name>\bin
      Update the following parameter in the setSOADomainEnv.sh (for Linux) and setSOADomainEnv.cmd (for Windows) file:
      USER_MEM_ARGS=""-Xms2048M -Xmx2048M -XX:PermSize=256M -XX:MaxPermSize=512M -Xmn1228M -XX:SurvivorRatio=10""

      Note: These are recommended values while using Sun JVM. Actual values that you set depend on your system configurations. When running on dedicated hosts, you can set the JVM heap size as high as possible. Higher value results in better performance. However this number is constrained by the operating system's addressable memory space.
      Restart SOA server
      Run the deployment script:

      At the command line prompt, run the following command for your platform:
      For Linux:
      cd $AIA_HOME/samples/AIADemo/config
      ant -f deployDemo.xml

      For Windows:
      cd %AIA_HOME%\samples\AIADemo\config
      ant –f deployDemo.xml

      while runiing the deployment script it showing build.xml not exist..

      Error Details
      fig>ant -f deployDemo.xml
      Buildfile: build.xml does not exist!
      Build failed

      Any suggestions

      Thanks in advance