9 Replies Latest reply: Sep 13, 2012 11:02 AM by Dude! RSS

    Request to the network interface

    952774
      Hi.
      The situation did not clear for me.
      The blade has 2 network cards. Blade is connected to a SAN with storage system. . LUN on the storage system is built. On LUN hosting OS.

      When I install Oracle Linux 5.8 , I configured and activated one interface et0 with static IP.
      Configuration is performed using systems-tsonfig-Network.
      Everything seems to work well.
      Recently OS in /var/log/messages has formed a number of reports and warnings regarding the restructuring of network interfaces.
      Was launched dnsmask.
      Sep  7 16:16:52 ******** dnsmasq[2503]: started, version 2.45 cachesize 150

      Read information from /etc/resolv.conf .
      Next, the system reported that the link is not ready for eth1:using MSIX.
      The system then lifted eth1 interface, as reported in the log.
      Sep  7 16:16:53 ****** kernel: bnx2 0000:10:00.1: eth1: NIC SerDes Link is Up, 1000 Mbps full duplex, receive & transmit flow control ON

      After that, was launched NetworkManager. NetworkManager tried to run all known network interfaces (eth0, eth1, usb0) twice in a row.
      The second time, it translates each subsequent interface from one state to another. Then deactivate them (reason 2)

      after all this is the OS Registering new address record for ***.***.***.*** on eth0, but in the log with Periodicity of 4 minutes were recorded the following messages:

      Sep  7 16:30:35 ****** dhclient: DHCPREQUEST on usb0 to 169.254.95.118 port 67 (xid=0x1006a443)
      Sep  7 16:30:35 ****** dhclient: DHCPACK from 169.254.95.118 (xid=0x1006a443)

      Then I stopped the usb0 interface command: ifconfig usb0 down success
      When you try to stop et1 interface rises again

      Sep 11 08:29:31 ****** kernel: bnx2 0000:10:00.1: eth1: NIC SerDes Link is Down
      Sep 11 08:29:31 ****** kernel: bnx2 0000:10:00.1: eth1: NIC SerDes Link is Up, 1000 Mbps full duplex, receive & transmit flow control ON
      Sep 11 08:29:32****** avahi-daemon[4546]: New relevant interface eth1.IPv6 for mDNS.
      Sep 11 08:29:32 ****** avahi-daemon[4546]: Joining mDNS multicast group on interface eth1.IPv6 with address fe80::5ef3:fcff:fe96:6cae.
      Sep 11 08:29:32 ****** avahi-daemon[4546]: Registering new address record for fe80::5ef3:fcff:fe96:6cae on eth1.

      In this case, NetworkManager rewrite /etc/resolv.conf the following content:
      # Generated by NetworkManager
      # No nameservers found; try putting DNS servers into your
      # ifcfg files in /etc/sysconfig/network-scripts like so:
      #
      # DNS1=xxx.xxx.xxx.xxx
      # DNS2=xxx.xxx.xxx.xxx
      # DOMAIN=lab.foo.com bar.foo.com

      Although I make to the file information on DNS servers.

      Now ifconfig issues that I have 3 interfaces:

      eth0 Link encap:Ethernet HWaddr 5C:F3:FC:96:6C:AC
      inet addr:**.***.**.** Bcast:10.130.35.255 Mask:255.255.255.0
      inet6 addr: fe80::5ef3:fcff:fe96:6cac/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
      RX packets:18761290 errors:0 dropped:0 overruns:0 frame:0
      TX packets:14428785 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:2491926632 (2.3 GiB) TX bytes:12944829478 (12.0 GiB)
      Interrupt:30 Memory:fa000000-fa012800

      eth1 Link encap:Ethernet HWaddr 5C:F3:FC:96:6C:AE
      inet6 addr: fe80::5ef3:fcff:fe96:6cae/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
      RX packets:15008 errors:0 dropped:0 overruns:0 frame:0
      TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:1011908 (988.1 KiB) TX bytes:3572 (3.4 KiB)
      Interrupt:37 Memory:92000000-92012800

      lo Link encap:Local Loopback
      inet addr:127.0.0.1 Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING MTU:16436 Metric:1
      RX packets:7956773 errors:0 dropped:0 overruns:0 frame:0
      TX packets:7956773 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0
      RX bytes:1642338782 (1.5 GiB) TX bytes:1642338782 (1.5 GiB)

      Dear forum members tell me:
      1. Why is it so strange to the system behaves?
      2. why this behavior NetworkManager?
      3. How to stop the network interface eth1?
      4. How to set up binding?


      Thanks in advance for your answers
        • 1. Re: Request to the network interface
          Tommyreynolds-Oracle
          Alexev,

          Please show us the +/etc/sysconfig/network-scripts/ifcfg-<N>+ scripts, that is where the definitions are. The NetworkManager keeps its own copies in +/etc/sysconfig/networking/+ but copies them to the place I asked about.

          Be sure to add one line before each file listing:
          And add the same line after each file. This will make your files legible.
          • 2. Re: Request to the network interface
            952774
            Hi TommyReynolds.

            Overwriting a file resolv.conf NetWorkManager was eliminate stop service dnsmasq.

            But the problem with the network interface remains.

            Yesterday our network administrators reconfigure routers SAN, so at 17.00 has been deactivated eth0 and eth1 activated.

            Switch Network Interface spends with utility system-config-network. The utility works a little incorrectly. She did not want to deactivate eth0 and eth1 activated. She offered to restart the network service.
            Which was done at the command line. The file resolv.conf was again overwritten without DNS servers.

            ifconfig output that eth0 active, although the interface is disabled and the file /etc/sysconfig/network-scripts/ifcfg-eth0 is missing.

            The result of the output ifconfig:

            eth0 Link encap:Ethernet HWaddr 5C:F3:FC:96:6C:AC
            inet6 addr: fe80::5ef3:fcff:fe96:6cac/64 Scope:Link
            UP BROADCAST MULTICAST MTU:1500 Metric:1
            RX packets:27561 errors:0 dropped:0 overruns:0 frame:0
            TX packets:22493 errors:0 dropped:0 overruns:0 carrier:0
            collisions:0 txqueuelen:1000
            RX bytes:2425866 (2.3 MiB) TX bytes:4336664 (4.1 MiB)
            Interrupt:30 Memory:fa000000-fa012800

            eth1 Link encap:Ethernet HWaddr 5C:F3:FC:96:6C:AE
            inet addr:10.130.35.76 Bcast:10.130.35.255 Mask:255.255.255.0
            inet6 addr: fe80::5ef3:fcff:fe96:6cae/64 Scope:Link
            UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
            RX packets:1358048 errors:0 dropped:0 overruns:0 frame:0
            TX packets:1034389 errors:0 dropped:0 overruns:0 carrier:0
            collisions:0 txqueuelen:1000
            RX bytes:173874462 (165.8 MiB) TX bytes:927217861 (884.2 MiB)
            Interrupt:37 Memory:92000000-92012800

            lo Link encap:Local Loopback
            inet addr:127.0.0.1 Mask:255.0.0.0
            inet6 addr: ::1/128 Scope:Host
            UP LOOPBACK RUNNING MTU:16436 Metric:1
            RX packets:8066075 errors:0 dropped:0 overruns:0 frame:0
            TX packets:8066075 errors:0 dropped:0 overruns:0 carrier:0
            collisions:0 txqueuelen:0
            RX bytes:1662883259 (1.5 GiB) TX bytes:1662883259 (1.5 GiB)


            Output /etc/sysconfig/network-scripts/ifcfg-eth1:+
            # Broadcom Corporation NetXtreme II BCM5709S Gigabit Ethernet
            DEVICE=eth1
            BOOTPROTO=none
            HWADDR=5C:F3:FC:96:6C:AE
            ONBOOT=yes
            HOTPLUG=no
            TYPE=Ethernet
            USERCTL=no
            IPV6INIT=no
            PEERDNS=yes
            NETMASK=255.255.255.0
            IPADDR=10.130.35.76
            GATEWAY=10.130.35.1


            Output /etc/sysconfig/network-scripts/ifcfg-lo:+
            DEVICE=lo
            IPADDR=127.0.0.1
            NETMASK=255.0.0.0
            NETWORK=127.0.0.0
            # If you're having problems with gated making 127.0.0.0/8 a martian,
            # you can change this to something else (255.255.255.255, for example)
            BROADCAST=127.255.255.255
            ONBOOT=yes
            NAME=loopback


            service network status+
            Configured devices:
            lo eth1
            Currently active devices:
            lo eth0_ eth1

            Edited by: Alexey_S on 13.09.2012 4:12
            • 3. Re: Request to the network interface
              Dude!
              The NetworkManager attempts to keep an active network connection available at all times. If using DHCP, it will replace default routes, obtain IP addresses from a DHCP server, and change nameservers whenever it sees fit. It is typically used in combination with wireless networking and other non-standard networking devices, because it will automatically activate and configure the last known working networking configuration.

              The NetworkManager daemon is off by default.

              <pre>
              chkconfig --list NetworkManager
              NetworkManager      0:off     1:off     2:off     3:off     4:off     5:off     6:off
              </pre>


              You can stop and disable the NetworkManager
              <pre>
              service NetworkManager stop
              chkconfig NetworkManager off
              </pre>

              Your initial problem with the NetworkManager might stem from existing network configurations that are not or no longer useable, or devices that have been removed (usb), and therefore the daemon automatically attempts to configure the network until if finds a usable setting.
              • 4. Re: Request to the network interface
                952774
                Dude thanks for the reply.
                I stopped him yesterday. The problem with resolv.tsonf decided.
                I'm more concerned why iftsonfig displays three network interfaces, instead of 2.
                The description above.
                • 5. Re: Request to the network interface
                  Dude!
                  Please be more precise. What network interface bothers you?
                  • 6. Re: Request to the network interface
                    952774
                    At the moment, eth0.

                    He not configured, but currently active devices
                    which confirms output ifconfig.

                    execution ifconfig eth0 down does nothing.
                    • 7. Re: Request to the network interface
                      Dude!
                      If you want to disable and remove eth0 device from the system, try the following:

                      <pre>
                      cp /etc/modprobe.conf /etc/modprobe.conf_backup
                      sed -i "s/alias eth0.*/alias eth0 off/g" /etc/modprobe.conf
                      </pre>

                      then restart the system and check it.
                      • 8. Re: Request to the network interface
                        952774
                        All right.
                        But I would like to know why information ifconfig is displayed differently in two identical blades.
                        OS installed in one day and modprobe.tsonf same.

                        Server 1_
                        cat /etc/modprobe.conf
                        alias scsi_hostadapter shpchp
                        alias eth0 bnx2
                        alias eth1 bnx2
                        alias scsi_hostadapter1 mptbase
                        alias scsi_hostadapter2 mptsas
                        alias scsi_hostadapter3 lpfc
                        alias scsi_hostadapter4 usb-storage
                        alias usb0 cdc_ether


                        Server 2_
                        [root@esstest ~]# cat /etc/modprobe.conf
                        alias scsi_hostadapter shpchp
                        alias eth0 bnx2
                        alias eth1 bnx2
                        alias scsi_hostadapter1 mptbase
                        alias scsi_hostadapter2 mptsas
                        alias scsi_hostadapter3 lpfc
                        alias scsi_hostadapter4 usb-storage
                        alias usb0 cdc_ether
                        • 9. Re: Request to the network interface
                          Dude!
                          I'm afraid it won't do any good if you start to figure out all kinds of problems in one and the same thread. When posting a thread, I suggest to keep in mind how your post is possibly going to help anyone else and what information might be required for anyone else to understand your issue.

                          I have no idea what your are doing or installing on your end or how your systems are configured. If you need help to troubleshoot an issue please try to provide more specific information and details. It is also mentioned in the forum etiquette.