1 2 3 Previous Next 32 Replies Latest reply on Sep 28, 2012 9:07 PM by user558643 Go to original post
      • 15. Re: autoconfig Fails on DB and apps tiers ERROR InDbCtxFile uploadCtx
        Hussein Sawwan-Oracle
        user558643 wrote:
        Hello,

        I executed adautocfg.sh on the apps tier successfully and created the appsutil.zip and implemented on the db tier.
        I then executed $ORACLE_HOME/appsutil/scripts/OFD1_ofindev01/adautocfg.sh and
        AutoConfig completed with errors on the db tier:

        [AutoConfig Error Report]
        The following report lists errors AutoConfig encountered during each
        phase of its execution. Errors are grouped by directory and phase.
        The report format is:
        <filename> <phase> <return code where appropriate>

        [PROFILE PHASE]
        AutoConfig could not successfully execute the following scripts:
        Directory: /u01/app/oracle/product/11.2.0/db_1/appsutil/install/OFD1_ofindev01
        afdbprf.sh INSTE8_PRF 1

        [APPLY PHASE]
        AutoConfig could not successfully execute the following scripts:
        Directory: /u01/app/oracle/product/11.2.0/db_1/appsutil/install/OFD1_ofindev01
        adcrobj.sh INSTE8_APPLY 1

        I attempted applying patch 7651166 and had this errors:

        Current target release is 12.0.0
        AutoPatch error:
        A codeline or codelevel introducing patch cannot be applied in pre-install mode.

        Am I using the wrong patch? How can I resolve this problem.
        Please search AutoConfig log file for each of the files about for details about the error.

        Thanks,
        Hussein
        • 16. Re: autoconfig Fails on DB and apps tiers ERROR InDbCtxFile uploadCtx
          user558643
          Incredible, both files (afdbprf.sh & adcrobj.sh) have the same detail error:
          script returned:
          ****************************************************

          afdbprf.sh started at Wed Sep 19 17:11:17 EDT 2012


          The environment settings are as follows ...

          ORACLE_HOME : /u01/app/oracle/product/11.2.0/db_1
          ORACLE_SID : OFD1
          PATH : /data1/u01/app/oracle/product/11.2.0/db_1/perl/bin:.:/usr/local/java/bin:/usr/local/java/db/bin:/usr/lib64/qt-3.3/bin:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/orafind/bin:/u01/app/oracle/product/11.2.0/db_1/bin:/usr/bin:/bin:/usr/bin/X11:/usr/local/bin:/u01/app/oracle/dba_scripts/bin:.
          Library Path : /u01/app/oracle/product/11.2.0/db_1/lib:/usr/X11R6/lib:/usr/openwin/lib:/u01/app/oracle/product/11.2.0/db_1/lib:/usr/dt/lib:/u01/app/oracle/product/11.2.0/db_1/ctx/lib

          Executable : /u01/app/oracle/product/11.2.0/db_1/bin/sqlplus

          SP2-1503: Unable to initialize Oracle call interface
          SP2-0152: ORACLE may not be functioning properly
          ERRORCODE = 1 ERRORCODE_END
          .end std out.

          .end err out.
          ****************************************************

          In my .bash profile I have the following:

          ORACLE_SID=OFD1; export ORACLE_SID
          ORACLE_UNQNAME=OFD1; export ORACLE_UNQNAME
          ORACLE_BASE=/u01/app/oracle; export ORACLE_BASE
          ORACLE_HOME=$ORACLE_BASE/product/11.2.0/db_1; export ORACLE_HOME
          ORACLE_TERM=xterm; export ORACLE_TERM
          TNS_ADMIN=$ORACLE_HOME/network/admin/OFD1_ofindev01; export TNS_ADMIN
          umask 022
          export ORA_NLS10=$ORACLE_HOME/nls/data/9idata

          # ---------------------------------------------------
          # PATH
          # ---------------------------------------------------
          # Used by the shell to locate executable programs;
          # must include the $ORACLE_HOME/bin directory.
          # ---------------------------------------------------
          PATH=.:${JAVA_HOME}/bin:$JAVA_HOME/db/bin:${PATH}:$HOME/bin:$ORACLE_HOME/bin
          PATH=${PATH}:/usr/bin:/bin:/usr/bin/X11:/usr/local/bin
          PATH=${PATH}:/u01/app/oracle/dba_scripts/bin
          export PATH

          # ---------------------------------------------------
          # LD_LIBRARY_PATH
          # ---------------------------------------------------
          # Specifies the list of directories that the shared
          # library loader searches to locate shared object
          # libraries at runtime.
          # ---------------------------------------------------
          LD_LIBRARY_PATH=$ORACLE_HOME/lib
          LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:$ORACLE_HOME/oracm/lib
          LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:/lib:/usr/lib:/usr/local/lib
          export LD_LIBRARY_PATH

          # ---------------------------------------------------
          # CLASSPATH
          # ---------------------------------------------------
          # Specifies the directory or list of directories that
          # contain compiled Java classes.
          # ---------------------------------------------------
          CLASSPATH=$ORACLE_HOME/JRE
          CLASSPATH=${CLASSPATH}:$ORACLE_HOME/jlib
          CLASSPATH=${CLASSPATH}:$ORACLE_HOME/rdbms/jlib
          CLASSPATH=${CLASSPATH}:$ORACLE_HOME/oc4j/ant/lib/ant.jar
          CLASSPATH=${CLASSPATH}:$ORACLE_HOME/oc4j/ant/lib/ant-launcher.jar
          CLASSPATH=${CLASSPATH}:$JAVA_HOME/db/lib/derby.jar
          CLASSPATH=${CLASSPATH}:$ORACLE_HOME/network/jlib
          export CLASSPATH

          . /u01/app/oracle/product/11.2.0/db_1/OFD1_ofindev01.env
          # Temporary unset just for sqlplus to function without SP2-1503
          unset ORA_TZFILE

          Which of these lines should I get rid of or which should I add?
          • 17. Re: autoconfig Fails on DB and apps tiers ERROR InDbCtxFile uploadCtx
            Hussein Sawwan-Oracle
            Please see these docs.

            Autoconfig On Db Tier Fails With Error - SP2-1503: Unable to initialize Oracle call interface [ID 1187616.1]
            How To Get The Proper Environment Set To Run Adbldxml.pl When Upgrading To 11g/11gR2? [ID 1310854.1]
            EBS 12.1.1: Autoconfig Fails While Running Scripts "afdbprf.sh" and "adcrobj.sh" with 11GR2 Database [ID 1336807.1]

            Thanks,
            Hussein
            • 18. Re: autoconfig Fails on DB and apps tiers ERROR InDbCtxFile uploadCtx
              user558643
              The two Notes 1187616.1 (Autoconfig On Db Tier Fails With Error - SP2-1503: Unable to initialize Oracle call interface) and 1336807.1 (EBS 12.1.1: Autoconfig Fails While Running Scripts "afdbprf.sh" and "adcrobj.sh" with 11GR2 Database) both want installation of patch 7651166 which is failing with Error:
              Generating product JAR files in JAVA_TOP -
              /u02/applfind/apps/apps_st/comn/java/classes with command:

              adjava -mx512m -nojit oracle.apps.ad.jri.adjmx @/u02/applfind/apps/apps_st/appl/admin/OFD1/out/genjars.cmd

              Failed to generate product JAR files in JAVA_TOP -
              /u02/applfind/apps/apps_st/comn/java/classes.

              From other readings, I later accepted that the patch should continue as if successful so that I can relink later:

              adrelink.sh force=y "ad all"

              Gave this error:
              /usr/lib/gcc/x86_64-redhat-linux/4.4.6/32/libgcc_s.so: undefined reference to `__stack_chk_fail@GLIBC_2.4'
              collect2: ld returned 1 exit status
              make: *** [u02/applfind/apps/apps_st/appl/ad/12.0.0/bin/adaimgr] Error 1
              Done with link of all ad executables on Thu Sep 20 01:06:49 EDT 2012
              Relink of all modules failed.

              Now, executing adadmin or adpatch gives me:
              sh: /u02/applfind/apps/apps_st/appl/ad/12.0.0/bin/adadminnew: No such file or directory
              sh: /u02/applfind/apps/apps_st/appl/ad/12.0.0/bin/adpatchnew: No such file or directory

              We have followed "Multiple gcc / g++ Versions in Linux [ID 444084.1]", uninstalled the latest gcc and installed gcc-4.4.4-13.el6 (x86_64) & gcc-c++-4.4.4-13.el6 (x86_64) as you can see:
              ls -al /usr/bin | grep gcc
              lrwxrwxrwx. 1 root root 3 Sep 20 11:44 cc -> gcc
              -rwxr-xr-x. 2 root root 263816 Dec 1 2010 gcc
              -rwxr-xr-x. 2 root root 263816 Dec 1 2010 x86_64-redhat-linux-gcc

              [applfind@ofindev01 tmp]$ rpm -qf /usr/bin/x86_64-redhat-linux-gcc
              gcc-4.4.4-13.el6.x86_64

              How do I get over this error so as to get db tier autoconfig to execute correctly?

              Thanks
              Mathias

              Edited by: user558643 on Sep 19, 2012 11:05 PM

              Edited by: user558643 on Sep 20, 2012 9:35 AM
              • 19. Re: autoconfig Fails on DB and apps tiers ERROR InDbCtxFile uploadCtx
                Hussein Sawwan-Oracle
                Hi Mathias,
                /usr/lib/gcc/x86_64-redhat-linux/4.4.6/32/libgcc_s.so: undefined reference to `__stack_chk_fail@GLIBC_2.4'
                collect2: ld returned 1 exit status
                make: *** [u02/applfind/apps/apps_st/appl/ad/12.0.0/bin/adaimgr] Error 1
                Please see these docs.

                Oracle E-Business Suite Installation and Upgrade Notes Release 12 (12.1.1) for Linux x86 [ID 761564.1]
                Oracle E-Business Suite Installation and Upgrade Notes Release 12 (12.1.1) for Linux x86-64 [ID 761566.1]
                Concurrent Processing - Reports Using RWRUN Fail on Shared Library : libde.so.0 after Upgrade to Linux 5 [ID 1087151.1]
                Oracle Forms Upgrade to 10.1.2.3 fails with error /usr/lib/libXtst.so.6: undefined reference [ID 1120527.1]

                Thanks,
                Hussein
                • 20. Re: autoconfig Fails on DB and apps tiers ERROR InDbCtxFile uploadCtx
                  user558643
                  I did look at the docs and "[ID 1087151.1] - Concurrent Processing ... " leads me to
                  1) unlink /usr/lib/libXtst.so.6
                  ln -s /usr/X11R6/lib/libXtst.so.6.1 /usr/lib/libXtst.so.6
                  o.k.

                  2) cd $ORACLE_HOME/reports/lib
                  make -f ins_reports.mk install
                  This failed - /usr/lib/gcc/x86_64-redhat-linux/4.4.4/32/libgcc_s.so: undefined reference to `__stack_chk_fail@GLIBC_2.4

                  cd /usr/lib/gcc/x86_64-redhat-linux/4.4.4/32
                  ls -lart – show s three broken links:
                  libmudflapth.a -> ../../../i686-redhat-linux/4.4.4/libmudflapth.a
                  libmudflap.a -> ../../../i686-redhat-linux/4.4.4/libmudflap.a
                  libgomp.so -> ../../../../libgomp.so.1.0.0

                  Could this be an indication that gcc is not properly installed? And if so, how to I install it to such that this is fixed.?

                  thanks for you help
                  Mathias
                  • 21. Re: autoconfig Fails on DB and apps tiers ERROR InDbCtxFile uploadCtx
                    Hussein Sawwan-Oracle
                    Hi Mathias,

                    Your gcc version should match the one mentioned in the installation doc.

                    Oracle E-Business Suite Installation and Upgrade Notes Release 12 (12.1.1) for Linux x86 [ID 761564.1]
                    Oracle E-Business Suite Installation and Upgrade Notes Release 12 (12.1.1) for Linux x86-64 [ID 761566.1]

                    Thanks,
                    Hussein
                    • 22. Re: autoconfig Fails on DB and apps tiers ERROR InDbCtxFile uploadCtx
                      user558643
                      We had removed the new version of gcc that we had and have installed those recommended by "Operating Systems Requirements" in Note [ID 761566.1]:
                      gcc-4.4.4-13.el16.x86_64
                      gcc-c++-4.4.4-13.el16.x86_64

                      We are still unable to succesfully run adautocfg.sh on the db tier which errors out on afdbprf.sh & adcrobj.sh) ->SP2-1503: Unable to initialize Oracle call interface. This takes to
                      adrelink.sh force=y "ad all" that errors on
                      /usr/lib/gcc/x86_64-redhat-linux/4.4.6/32/libgcc_s.so: undefined reference to `__stack_chk_fail@GLIBC_2.4'.

                      This error took me to
                      [ID 1087151.1] - Concurrent Processing - Reports Using RWRUN Fail on Shared Library : libde.so.0 after Upgrade to Linux 5
                      Guide on this Note also failed with
                      this failed - /usr/lib/gcc/x86_64-redhat-linux/4.4.4/32/libgcc_s.so: undefined reference to `__stack_chk_fail@GLIBC_2.4
                      and then revealed three broken links in /usr/lib/gcc/x86_64-redhat-linux/4.4.4/32:
                      libmudflapth.a -> ../../../i686-redhat-linux/4.4.4/libmudflapth.a
                      libmudflap.a -> ../../../i686-redhat-linux/4.4.4/libmudflap.a
                      libgomp.so -> ../../../../libgomp.so.1.0.0
                      An SR has been unable to give me help this issue and we are all extremely frustrated and just wish to dump Oracle Financials as of today:)))) or we might have to start from scratch again with the promise to finish it all by Monday since our go live day has long past.

                      Any more ideas? Hussein, drop my line off the forum if possible.

                      Thanks for all the help so far - it doesn't go vain
                      God bless You
                      Mathias

                      Edited by: user558643 on Sep 21, 2012 9:33 AM
                      • 23. Re: autoconfig Fails on DB and apps tiers ERROR InDbCtxFile uploadCtx
                        Hussein Sawwan-Oracle
                        Hi Mathias,

                        What is your OS?

                        Please post the output of these commands:
                        $ rpm -q glibc
                        
                        $ gcc -v
                        Thanks,
                        Hussein
                        • 24. Re: autoconfig Fails on DB and apps tiers ERROR InDbCtxFile uploadCtx
                          user558643
                          OEL 6 update 3 - ol6_u3

                          uname -a
                          Linux ofindev01.healthydirections.com 2.6.39-200.24.1.el6uek.x86_64 #1 SMP Sat Jun 23 02:39:07 EDT 2012 x86_64 x86_64 x86_64 GNU/Linux

                          [applfind@ofindev01 ~]$ rpm -q glibc
                          glibc-2.12-1.80.el6_3.5.x86_64
                          glibc-2.12-1.80.el6_3.5.i686

                          [applfind@ofindev01 ~]$ gcc -v
                          Using built-in specs.
                          Target: x86_64-redhat-linux
                          Configured with: ../configure prefix=/usr mandir=/usr/share/man infodir=/usr/share/info with-bugurl=http://bugzilla.redhat.com/bugzilla enable-bootstrap enable-shared enable-threads=posix enable-checking=release with-system-zlib enable-__cxa_atexit disable-libunwind-exceptions enable-gnu-unique-object enable-languages=c,c++,objc,obj-c++,java,fortran,ada enable-java-awt=gtk disable-dssi with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre enable-libgcj-multifile enable-java-maintainer-mode with-ecj-jar=/usr/share/java/eclipse-ecj.jar disable-libjava-multilib with-ppl with-cloog with-tune=generic with-arch_32=i686 --build=x86_64-redhat-linux
                          Thread model: posix
                          gcc version 4.4.4 20100726 (Red Hat 4.4.4-13) (GCC)


                          g++ --version
                          -bash: g++: command not found


                          1) yum install gcc-c++-4.4.4-13.el6
                          Gave me these errors:

                          Error: Package: gcc-c++-4.4.4-13.el6.x86_64 (ol6_ga_base)
                          Requires: libstdc++ = 4.4.4-13.el6
                          Installed: libstdc++-4.4.6-4.el6.i686 (@ol6_latest)
                          libstdc++ = 4.4.4-15.el6
                          libstdc++ = 4.4.6-4.el6
                          Available: libstdc++-4.4.4-13.el6.i686 (ol6_ga_base)
                          libstdc++ = 4.4.4-13.el6
                          Error: Package: gcc-c++-4.4.4-13.el6.x86_64 (ol6_ga_base)
                          Requires: libstdc++-devel = 4.4.4-13.el6
                          Installed: libstdc++-devel-4.4.6-4.el6.i686 (@/libstdc++-devel-4.4.6-4.el6.i686)
                          libstdc++-devel = 4.4.4-15.el6
                          libstdc++-devel = 4.4.6-4.el6
                          Available: libstdc++-devel-4.4.4-13.el6.i686 (ol6_ga_base)
                          libstdc++-devel = 4.4.4-13.el6
                          You could try using --skip-broken to work around the problem
                          You could try running: rpm -Va --nofiles –nodigest

                          2) I decided to remove the libstdc++-4.4.6-4.el6.i686 accepting it's dependencies to be removed
                          yum remove libstdc++-4.4.6-4.el6.i686
                          yum remove libstdc++-devel-4.4.6-4.el6.i686

                          3) Install gcc-c++:
                          yum install gcc-c++-4.4.4-13.el6

                          It errors out:
                          Resolving Dependencies
                          --> Running transaction check
                          ---> Package gcc-c++.x86_64 0:4.4.4-13.el6 will be installed
                          --> Processing Dependency: libstdc++ = 4.4.4-13.el6 for package: gcc-c++-4.4.4-13.el6.x86_64
                          --> Processing Dependency: libstdc++-devel = 4.4.4-13.el6 for package: gcc-c++-4.4.4-13.el6.x86_64
                          --> Running transaction check
                          ---> Package libstdc++.i686 0:4.4.4-13.el6 will be installed
                          ---> Package libstdc++-devel.i686 0:4.4.4-13.el6 will be installed
                          --> Finished Dependency Resolution
                          Error: Protected multilib versions: libstdc++-4.4.4-13.el6.i686 != libstdc++-4.4.6-4.el6.x86_64
                          Error: Protected multilib versions: libstdc++-devel-4.4.4-13.el6.i686 != libstdc++-devel-4.4.6-4.el6.x86_64
                          You could try running: rpm -Va nofiles nodigest

                          It's apparent that gcc-c++-4.4.4-13.el6 is not installed as expected. How do I get this version installed?
                          • 25. Re: autoconfig Fails on DB and apps tiers ERROR InDbCtxFile uploadCtx
                            Dude!
                            You cannot simply downgrade core libraries in a system and there is no need to install older versions of compilers and development tools. What you can do is to install the appropriate compatibility libraries, e.g.:

                            compat-libstdc++-33
                            compat-libcap1
                            compat-gcc-34
                            compat-gcc-34-c++
                            compat-glibc
                            compat-glibc-headers

                            I also see you have the "ol6_ga_base" yum repository enabled, which is inappropriate for 6.3.
                            You only need to have the "ol6_latest" repository enabled.
                            • 26. Re: autoconfig Fails on DB and apps tiers ERROR InDbCtxFile uploadCtx
                              user558643
                              Hello,

                              I have installed as:
                              yum install compat-libstdc++-33 compat-libcap1 compat-gcc-34 compat-gcc-34-c++ compat-glibc compat-glibc-headers

                              Running Transaction
                              Installing : compat-gcc-34-3.4.6-19.el6.x86_64 1/2
                              Installing : compat-gcc-34-c++-3.4.6-19.el6.x86_64 2/2
                              Verifying : compat-gcc-34-c++-3.4.6-19.el6.x86_64 1/2
                              Verifying : compat-gcc-34-3.4.6-19.el6.x86_64 2/2

                              Installed:
                              compat-gcc-34.x86_64 0:3.4.6-19.el6 compat-gcc-34-c++.x86_64 0:3.4.6-19.el6


                              I then tried installing gcc-c again and it fails :

                              yum.repos.d]# yum install gcc-c++-4.4.4-13.el6

                              Loaded plugins: refresh-packagekit, security
                              Setting up Install Process
                              Resolving Dependencies
                              --> Running transaction check
                              ---> Package gcc-c++.x86_64 0:4.4.4-13.el6 will be installed
                              --> Processing Dependency: libstdc++ = 4.4.4-13.el6 for package: gcc-c++-4.4.4-13.el6.x86_64
                              --> Processing Dependency: libstdc++-devel = 4.4.4-13.el6 for package: gcc-c++-4.4.4-13.el6.x86_64
                              --> Running transaction check
                              ---> Package libstdc++.i686 0:4.4.4-13.el6 will be installed
                              ---> Package libstdc++-devel.i686 0:4.4.4-13.el6 will be installed
                              --> Finished Dependency Resolution
                              Error: Protected multilib versions: libstdc++-4.4.4-13.el6.i686 != libstdc++-4.4.6-4.el6.x86_64
                              Error: Protected multilib versions: libstdc++-devel-4.4.4-13.el6.i686 != libstdc++-devel-4.4.6-4.el6.x86_64
                              You could try using --skip-broken to work around the problem

                              I am a novice in unix/linux - help:))
                              Mac
                              • 27. Re: autoconfig Fails on DB and apps tiers ERROR InDbCtxFile uploadCtx
                                Dude!
                                Sorry I have not read the whole thread, because it seems to contain a lot of unnecessary information. Again, you cannot simply downgrade libraries without breaking the OS. Why would you want to install gcc-c++-4.4.4-13 anyway?

                                What are you actually trying to install? If I remember correctly, a similar error exists in Oracle 11g, when you try to install the 32-bit version under a x86_64 OS, which Oracle does not support according to the documentation.
                                • 28. Re: autoconfig Fails on DB and apps tiers ERROR InDbCtxFile uploadCtx
                                  user558643
                                  gcc-c++-4.4.4-13 is one of the requirements of installing ebs 12.1.1 on linux x86-64 (note 761566.1) and note 1441282.1.
                                  The relinking problems we are having and the broken links ledd us to inspecting gcc-c++ and
                                  found out that this required gcc-c++ was not installed. That's why we are trying to install it now.

                                  Thank you
                                  • 29. Re: autoconfig Fails on DB and apps tiers ERROR InDbCtxFile uploadCtx
                                    user558643
                                    Anymore suggestions on how I can handle this problem.
                                    Thanks
                                    Mathias