This discussion is archived
6 Replies Latest reply: Sep 27, 2012 8:38 PM by user8762483 RSS

VS 2012 does not finish starting after installing ODAC 11.2 Release 5

pa*415586*za Newbie
Currently Being Moderated
I installed the ODAC 11.2 Release 5 (11.2.0.3.20) with Oracle Developer Tools for Visual Studio. When VS 2012 restarts the splash page comes up with a message to wait while an operation completes but it never does. Does anyone have an idea as to what the problem may be?

Running Win 7 Pro with VS 2012 Ultimate.

Paul
  • 1. Re: VS 2012 does not finish starting after installing ODAC 11.2 Release 5
    962540 Newbie
    Currently Being Moderated
    I would like to add some additional information to the above post. I am receiving the same error using the new release. The beta release worked fine. I completely uninstalled the beta and then installed the new release. Once installed, VS2012 stopped working. The splash screen comes up and then the little box stating that it is waiting for a background process to complete is displayed. That is it. From what I can tell, it is in a userwait state.

    Unfortunately, when I uninstalled the component, it left some artifacts behind. When I now start VS2012, I get errors stating that Oracle ODT did not load correctly and then VS2012 stops working and exits. I am running VS2012 as administrator.

    This behavior is exhibited on both Windows 8 and Windows7 Home Ultimate (both 64bit) and VS2012 ultimate.

    The activity log shows what is giving the error, shows the following:

    <entry>
    <record>270</record>
    <time>2012/09/17 11:57:57.734</time>
    <type>Information</type>
    <source>VisualStudio</source>
    <description>Begin package load [Oracle Developer Tools for Visual Studio]</description>
    <guid>{D601BB95-E404-4A8E-9F24-5C1A462426CE}</guid>
    </entry>
    <entry>
    <record>271</record>
    <time>2012/09/17 11:57:57.738</time>
    <type>Error</type>
    <source>VisualStudio</source>
    <description>CreateInstance failed for package [Oracle Developer Tools for Visual Studio]</description>
    <guid>{D601BB95-E404-4A8E-9F24-5C1A462426CE}</guid>
    <hr>80070002</hr>
    <errorinfo>Could not load file or assembly 'Oracle.VsDevTools.11.0, Version=4.112.3.20, Culture=neutral, PublicKeyToken=89b483f429c47342' or one of its dependencies. The system cannot find the file specified.</errorinfo>
    </entry>
    <entry>
    <record>272</record>
    <time>2012/09/17 11:57:57.738</time>
    <type>Error</type>
    <source>VisualStudio</source>
    <description>End package load [Oracle Developer Tools for Visual Studio]</description>
    <guid>{D601BB95-E404-4A8E-9F24-5C1A462426CE}</guid>
    <hr>80004005 - E_FAIL</hr>
    <errorinfo>Could not load file or assembly 'Oracle.VsDevTools.11.0, Version=4.112.3.20, Culture=neutral, PublicKeyToken=89b483f429c47342' or one of its dependencies. The system cannot find the file specified.</errorinfo>
    </entry>

    The above entry was thrown when VSDevTools had been removed from the system.

    Unfortunately, I did not get any information about what exactly was causing the wait state when the Dev Tools for VS was installed. From Process Explorer, I could see that msenv.dll was chewing through cycles, waiting for multiple objects. I have stack prints for devenv.exe and msenv.exe as well as a thread screenshot if anyone is interested in seeing them.

    Hopefully this will shed some light on what needs to be fixed.

    Thanks,

    Craig D.
  • 2. Re: VS 2012 does not finish starting after installing ODAC 11.2 Release 5
    stzueger Newbie
    Currently Being Moderated
    Same issue here.

    The log file produced by the /log option ends with:

    <entry>
    <record>434</record>
    <time>2012/09/19 08:03:43.289</time>
    <type>Information</type>
    <source>VisualStudio</source>
    <description>Begin package load [Oracle Developer Tools for Visual Studio]</description>
    <guid>{D601BB95-E404-4A8E-9F24-5C1A462426CE}</guid>
    </entry>
    <entry>
    <record>435</record>
    <time>2012/09/19 08:03:43.306</time>
    <type>Information</type>
    <source>Oracle Developer Tools for Visual Studio</source>
    <description>OracleVSGPkg.SetSite - Begin Oracle Developer Tools VS Package SetSite</description>
    <guid>{D601BB95-E404-4A8E-9F24-5C1A462426CE}</guid>
    </entry>
    <entry>
    <record>436</record>
    <time>2012/09/19 08:03:43.306</time>
    <type>Information</type>
    <source>Oracle Developer Tools for Visual Studio</source>
    <description>OracleVSGPkg.SetSite - Initializing Oracle Developer Tools Resources</description>
    <guid>{D601BB95-E404-4A8E-9F24-5C1A462426CE}</guid>
    </entry>
    <entry>
    <record>437</record>
    <time>2012/09/19 08:03:43.351</time>
    <type>Information</type>
    <source>Oracle Developer Tools for Visual Studio</source>
    <description>OracleVSGPkg.InstallToolboxItems - Begin installing Oracle Data Provider Components in Toolbox under Data tab</description>
    <guid>{D601BB95-E404-4A8E-9F24-5C1A462426CE}</guid>
    </entry>
    <entry>
    <record>438</record>
    <time>2012/09/19 08:03:43.354</time>
    <type>Information</type>
    <source>Oracle Developer Tools for Visual Studio</source>
    <description>OracleVSGPkg.InstallToolboxItems - Removing all Oracle Data Provider Components from Toolbox</description>
    <guid>{D601BB95-E404-4A8E-9F24-5C1A462426CE}</guid>
    </entry>

    Edited by: stzueger on 19.09.2012 01:04
  • 3. Re: VS 2012 does not finish starting after installing ODAC 11.2 Release 5
    stzueger Newbie
    Currently Being Moderated
    A start of VS2012 from the command line with /resetsettings has solved the issue for me. Now VS2012 starts OK and the Oracle data provider seems to work.
  • 4. Re: VS 2012 does not finish starting after installing ODAC 11.2 Release 5
    963448 Newbie
    Currently Being Moderated
    Hi,

    I was having this very same issue (Windows 7 x64/ VS2012). I was able to resolved by using "Developer Command Prompt for VS2012" under Visual Studio Tools.

    Run at prompt: devenv /resetsettings


    C:\Program Files (x86)\Microsoft Visual Studio 11.0>devenv /resetsettings
  • 5. Re: VS 2012 does not finish starting after installing ODAC 11.2 Release 5
    962540 Newbie
    Currently Being Moderated
    Thank you jmooreweb, and stzueger! That worked for me also.

    Running it as administrrator popped up the application. I have not tested the ODT just yet, but I am just glad to have the IDE back!

    Thanks again for your solution!

    Have a great day!

    Craig D.
  • 6. Re: VS 2012 does not finish starting after installing ODAC 11.2 Release 5
    user8762483 Newbie
    Currently Being Moderated
    I second that as well... "Thank you jmooreweb, and stzueger!" Your solution addressed my issue as well. ~JZ

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points