1 Reply Latest reply: Sep 18, 2012 4:58 AM by Veeresh.S RSS

    An Error when running ./netca after oracle_home clone.

    User470870-OC
      Hello,

      Databas version : 11.1.0.7
      OS version : RHEL 5.5

      To clone oracle_home on the target system, followed the below steps.
      1. Not ran adpreclone.pl on the source as i am doing only database oracle_home clone.
      2. Sutdown database and listner of the source db, ziped oracle_home, moved it to target server.
      3. Unzip the folder and ran the script clone.pl in the target system, clonning is successfull.

      Now i need to configure connection using ./netca (not created database using dbca yet) getting below erros.

      [orarman@devtest bin]$ ./netca
      ****DISPLAY environment variable not set!
      Oracle Net Configuration Assistant is a GUI tool
      which requires that DISPLAY specify a location
      where GUI tools can display.
      Set and export DISPLAY, then re-run.

      So i have set display as
      [orarman@devtest bin]$ export DISPLAY=192.168.1.6:0.0

      If i run ./netca getting an below error
      [orarman@devtest bin]$ xhost +
      xhost: unable to open display "192.168.1.6:0.0"
      and
      xclock
      Error: Can't open display: 192.168.1.6:0.0

      [orarman@devtest bin]$ ./netca

      Oracle Net Services Configuration:
      java.lang.NullPointerException
      at oracle.ewt.lwAWT.BufferedApplet.<init>(Unknown Source)
      at oracle.net.ca.NetCA.<init>(Unknown Source)
      at oracle.net.ca.NetCA.main(Unknown Source)
      Oracle Net Services configuration failed. The exit code is -1


      Please suggest..
      Thanks ..