2 Replies Latest reply: Sep 21, 2012 11:45 AM by Srini Chavali-Oracle RSS

    error: Failed dependencies: during ASMLib Configuration: on linux 4

    user12194321
      Hi,

      [root@test asm]# lsb_release -a
      LSB Version: :core-3.0-ia32:core-3.0-noarch:graphics-3.0-ia32:graphics-3.0-noarch
      Distributor ID: RedHatEnterpriseAS
      Description: Red Hat Enterprise Linux AS release 4 (Nahant Update 5)
      Release: 4
      Codename: NahantUpdate5
      [root@test asm]# uname -r
      2.6.9-55.ELsmp

      i have downloaded the below libs from oracle site

      Drivers for kernel 2.6.9-55.EL
      oracleasm-2.6.9-55.ELxenU-2.0.3-1.i686.rpm
      oracleasm-2.6.9-55.ELsmp-2.0.3-1.i686.rpm
      oracleasm-2.6.9-55.ELhugemem-2.0.3-1.i686.rpm
      oracleasm-2.6.9-55.EL-2.0.3-1.i686.rpm

      but getting the below error

      [root@test asm]# rpm -Uvh \


      oracleasm-2.6.9-55.ELxenU-2.0.3-1.i686.rpm \
      oracleasm-2.6.9-55.EL-2.0.3-1.i686.rpm \
      oracleasm-2.6.9-55.ELhugemem-2.0.3-1.i686.rpm \
      oracleasm-2.6.9-55.ELsmp-2.0.3-1.i686.rpm
      error: Failed dependencies:
      kernel-xenU = 2.6.9-55.EL is needed by oracleasm-2.6.9-55.ELxenU-2.0.3-1.i686
      oracleasm-support >= 2.0.0 is needed by oracleasm-2.6.9-55.ELxenU-2.0.3-1.i686
      oracleasm-support >= 2.0.0 is needed by oracleasm-2.6.9-55.EL-2.0.3-1.i686
      kernel-hugemem = 2.6.9-55.EL is needed by oracleasm-2.6.9-55.ELhugemem-2.0.3-1.i686
      oracleasm-support >= 2.0.0 is needed by oracleasm-2.6.9-55.ELhugemem-2.0.3-1.i686
      oracleasm-support >= 2.0.0 is needed by oracleasm-2.6.9-55.ELsmp-2.0.3-1.i686
      Suggested resolutions:
      kernel-hugemem-2.6.9-55.EL.i686.rpm
      kernel-xenU-2.6.9-55.EL.i686.rpm

      appreciacted for the inputs

      Thanks