This discussion is archived
3 Replies Latest reply: Sep 24, 2012 8:32 AM by 963972 RSS

OCFS2 - I'm missing something

963972 Newbie
Currently Being Moderated
Hi all,

I've some problem with OCFS2.
I've set up 2 Vm (virtualbox) Debian 6.0.5 :
192.168.100.10 hostname: ArchiveCluster
2 disk: 1 of 60GB and 1 of 50GB. /dev/sdb and /dev/sda1

192.168.100.20 hostname: ArchiveCluster2
2 disk: 1 of 60GB and 1 of 50GB. /dev/sdb and /dev/sda1

And then I've installed the ocfs2 package with:

aptitude -t squeeze-backports install ocfs2-tools ocfs2console


In the /etc/default/o2cb i've changed the value to 'true':
     O2CB_ENABLED = true



MORE /etc/ocfs2/cluster.conf
node:
ip_port = 7777
ip_address = 192.168.100.10
number = 1
name = ArchiveCluster
cluster = ocfs2
node:
ip_port = 7777
ip_address = 192.168.100.20
number = 2
name = ArchiveCluster2
cluster = ocfs2
cluster:
node_count = 2
name = ocfs2

I've formatted and mounted the 2 disk on the 2 server:
lshw -C disk
teh disk is /dev/sdb
     
mkfs.ocfs2 -b 4k -C 32K -L "FSshared" -N 2 /dev/sdb
mkdir /archive
mount -t ocfs2 -o _netdev,defaults  /dev/sdb /archive

echo "/dev/sdb /archive ocfs2 _netdev 0 0" >> /etc/fstab


OUTPUT OF /etc/init.d/o2cb status
Driver for "configfs": Loaded
Filesystem "configfs": Mounted
Stack glue driver: Loaded
Stack plugin "o2cb": Loaded
Driver for "ocfs2_dlmfs": Loaded
Filesystem "ocfs2_dlmfs": Mounted
Checking O2CB cluster ocfs2: Online
Heartbeat dead threshold = 31
Network idle timeout: 30000
Network keepalive delay: 2000
Network reconnect delay: 2000
Checking O2CB heartbeat: Active



So, I've done all these command on both the 2 server.
BUT, if i create a file on /archive on server1 the server2 does not take the file automatically, and vice-versa.

What i'm missing ?


Thx.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points