This discussion is archived
3 Replies Latest reply: Jun 20, 2013 2:31 PM by Rudy Ising RSS

CM 14 - Custom Forms & Print Preview

947488 Newbie
Currently Being Moderated
When I print preview a custom form or report in CM 14, it seems to "stamp" the information shown in that print preview for 20-30 mins. Any information updated after the initial preview does not appear in subsequent previews for at least 20-30 mins. I've tried to close all windows, exit & log in again, re-import the forms/reports, and even reset the entire CM/BI Publisher servers but nothing works - it just needs time.

All forms in CM 13 (custom or not), work fine and do not have this issue, as with the standard/default forms in CM 14 - all changes take immediately and the most up to date information is shown in each print preview.

Has anyone had this problem? Any idea how to resolve it? Thanks in advance for your help.
  • 1. Re: CM 14 - Custom Forms & Print Preview
    user416359 Newbie
    Currently Being Moderated
    Do you have anything Checked off in the Caching Section of the Report Properties in BI?
  • 2. Re: CM 14 - Custom Forms & Print Preview
    BrianWebb Newbie
    Currently Being Moderated
    I see the same thing in PCM14 and BI Publisher

    I can create a document, print preview, immediately edit a value and that new edit will not show up in the report.form for ~15-30 minutes.

    Oracle addresses this here: A Custom Report/Form Is Either Not Displaying Updated Document Information or Displaying Information from the Wrong Document [ID 1414983.1]

    When creating a new form/report some defaults are applied that cause the caching issue. You need to follow these instructions from Oracle to remove all caching from individual reports/forms

    In this Document
         Symptoms
         Cause
         Solution

    Applies to:
    Primavera Contract Management - Version 14.0 and later
    Information in this document applies to any platform.
    Symptoms

    A report or form is run against a Contract Management document. Edits are then made to the Contract Management document. However, when running the report/form against that document again, the updated document information is not reflected in the report/form.

    The report/form may also display information for a document that the report/form was previously run against, instead of displaying the information for the document that it's currently being run against.
    Cause

    BI Publisher is caching the results from the first attempt to run that report/form. Each subsequent print attempt is returning the cached result set from memory.
    Solution

    Disable Data and Document Caching within the report or form. To do so, follow the below steps.

    Log into the BI Publisher user interface.
    Default URL: http://[BI Publisher server machine name or IP Address]:7001/xmlpserver

    Click the Catalog link in the upper right of the window and then navigate to the location of the problem report/form.

    Under the appropriate report/form layout object, click the Edit link.

    Click the Properties button in the upper right of the window. This is not to be confused with the Properties link below the report/form layout.

    Click the Caching tab.

    Un-mark the check boxes next to the Enable Data Caching and Document Caching settings and click the OK button.

    Click the Save Report button in the upper right of the window (says Save Report, when the mouse is hovered over it).

    Edited by: BrianWebb on May 22, 2013 1:29 PM
  • 3. Re: CM 14 - Custom Forms & Print Preview
    Rudy Ising Explorer
    Currently Being Moderated

    As mentioned in another post, the issue is the Caching settings for each report or form in BI design.

     

    If you do not uncheck the Caching options, you will continue to see the same data based on whatever Cache settings you have.

     

    Sorry, but this is found in every report, so you must change this in each report you create.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points