This discussion is archived
1 2 Previous Next 15 Replies Latest reply: May 7, 2004 10:52 AM by 419562 Go to original post RSS
  • 15. Re: database link error (ORA-02085) when querying "select"
    419562 Newbie
    Currently Being Moderated
    Joel: I did what you suggested, and commented the NAMES.DEFAULT_DOMAIN on my current server, so that both servers are the same. But I still got the same error.

    Then I tried to link to another remote database, and it worked. I do find that my current and remote database (the one that works) both have similar but maybe wrong global_name:
    select * From global_name;
    I got 'OOGF.US.ORACLE.COM' on current server,
    and 'OOHB.US.ORACLE.COM' on the remote server.

    while as said previously, I got 'OGRE' on the remote server that refuses to link.

    Any inputs? Is it right to have global_name with 'US.ORACLE.COM' as suffix, even though you are certainly not in that domain? Which config file should I check for this parameter? Thanks a lot. Changsong
1 2 Previous Next