4 Replies Latest reply on Oct 26, 2012 8:09 AM by mh*379860*ly

    Unable to reinstall Java

      HI Gentlemen,

      I have a serious Java installation problem. First I installed JDK7 several times, but I had to return to JDK6 because JDelevoper and the integrated Weblogic Server do not recognize JDK7 (a reported bug). To do so, unfortunately I went to regedit and deleted many entries concerning JDK7 and also JDK6. Now the system is unstable: I can not install JDK6 because it feels that it is already installed. All directories are removed, to say. Can anyone help me? Or must I perform a brand new Windows7 Pro Installation?

      Thank you very much, kind regards:

      Miklos HERBOLY
      Java(TM) Development Kit 6 Update 30
      This software has already been installed on your computer. Would you like to reinstall it?
      When I say Yes, I get the following:
      Error 1723. There is a problem with this Windows Installer package. A DLL required for this install to complete could not be run. Contact your support personnel or package vendor.
      Since I am alone in my company as a freelance, I can not contacet anyone.

      Edited by: mh**** on Oct 3, 2012 9:18 AM
        • 1. Re: Unable to reinstall Java
          Hello Miklos,

          Its a common problem which occurs if you are uninstalling Java from your PC other than the normal way (i.e through Control Panel --> Add/Remove Programs).

          Check the following points to fix this issue.

          1. Go to Control Panel -->Add/Remove Programs and look out for all the previous versions of JRE installations you have tried. If found, try to uninstall.
          2. Restart your PC
          3. Try fresh installation. If the error message appears again then
          4. Use the following link http://java.com/en/download/help/manual_regedit.xml to clean up the windows registry manually. Repeat step 2 & 3.
          5. Still showing same error, use any registry cleaning tool to find and clean up JDK. Repeat step 2 & 3.

          Let me know if the issue still persists.

          Thank you
          1 person found this helpful
          • 2. Re: Unable to reinstall Java
            The thread is already quite old, but people have had success using this:

            • 3. Re: Unable to reinstall Java

              Thank you for the link; I noticed it and will execute it if the problem recurs. Fortunately I could reset the system to an earlier checkpoint and it has been working since then again. I will never edit the registry manually.

              • 4. Re: Unable to reinstall Java
                HI Sirju,

                Thank you for the good advice. Meanwhile I returned to an earlier checkpoint where the registry was OK, now it is up and well again. Never will edit it manually.