2 Replies Latest reply: Oct 8, 2012 3:34 PM by 966931 RSS

    JRE 6U35 and JRE7U7 improperly install (via MSI in GPO) on top of existing

    966241
      Hello,

      Within my environment, we occasionally have to push out software updates (MSI based installers) via group policy. We also install the latest JRE as a part of our base install when systems are built. In the past, this has worked without issue. The previous behavior of the MSI installer when used within a GPO was to NOT install if the current (or newer) version of the JRE was already installed. I've confirmed that with both JRE 6U35 and JRE7U7, if a system already had say JRE6U35 installed (silently via msiexec /i "jre1.6.0_35.msi" /qn) as part of the base install, it would work just fine, until the system was restarted, at which point, if it was within an OU that had our GPO to apply the latest JRE (in this case, the EXACT same installer, same version etc) the Software installation policy would actually run (which it shouldn't and didn't with previous JRE installers) and would mess up the JRE on the system. In add/remove programs, the expected JRE version would be listed, and the control panel applet icon would be present, but the browers (any browser) would act as though the JRE was not installed and clicking on the Java control panel applet would generate a message that says something to the effect of "Application not found". Also, trying to remove the JRE via add/remove programs also seems to cause an "Application not found" error message. I've found that I had to remove a registry key (though I can't remember it right at this moment) to get rid of the "Application not found" error messages before I can manually uninstall the JRE and reinstall properly.

      I think there's something wrong with the MSI installer, namely that it doesn't seem to check properly for existing versions of the JRE when processed via a Software Installation GPO.

      My current work around is to exclude JRE from the base install, allowing our GPO to perform the installation, (which works, even after several restarts) but that's not ideal and it's not how these installers used to work.

      OS - Win7 Enterprise 32bit AND 64bit
      JRE versions - 6U35 and 7U7.


      Please advise.