1 Reply Latest reply: Oct 5, 2012 4:42 AM by Joan Puig-Oracle RSS

    cube population

      My relational table initially had data from 02-aug-2012 to 16-aug-2012.So in awm,i gave maintain and the cube got populated with that datas. then i truncated the datas (02-aug-2012 to 16-aug-2012) from my relational table and populated relational table with next set of data from 17-aug-2012 to 30-sep-2012. now when i gave maintain cube and viewed it, i should be able to see all the datas from 02-aug to 30-sep.(since i have used load and aggregate script). but the issue am facing is as below:

      A part of datas from 02-aug-2012 is displaying under 17-aug-2012 and 18-sep, and part of datas from 28-aug gets displayed under 18 sep. i cant understand why is this happening?? can anyone pls help???????

      i have the below hierarchy in my time dimension: year->quarter->month->week->day->hour->min->sec
        • 1. Re: cube population
          Joan Puig-Oracle

          I'm not an expert in OLAP, but I've had some problems in the past with time dimensions that have levels lower than Day.

          At first glance I have two hypotheses about what's causing the problem:

          1.- First/Last week of every month usually has days in both months, so (if you're not using a 4-4-5 calendar) weeks, days and below do not have a single "parent" month, which is required for Time Series Analysis.

          2.- The Time dimension table from which you loaded data into the dimension has incorrect values. Check especially the END_DATE and TIME_SPAN columns.

          I hope it helps.


          P.S.: http://en.wikipedia.org/wiki/4-4-5_calendar