14 Replies Latest reply on Feb 17, 2013 8:52 AM by 991538

    Connection Open but no tables, views or procedures


      Going through my first attempt ever to connect to a Oracle database with a .Net application.
      Using Visual Studio 2012, I have downloaded and installed the latest version of odp.net, actually both the 32 and 64bit versions.

      Application is targeting the 4.5 Framework, Latest version of Entity Framework installed (but not important I think at this point)
      Added a reference in my project to the Oracle Data Provider ( tried with both 2.0 and 4.0 )

      Created a connection string with EZ Connect, stored in web.config file.
      I have tried 2 different projects to use EF and one without. I've looked at several tutorials and can't see what I'm missing or doing wrong.
      Trying to create a edmx or using a datasource adapter brings up the connection wizard or prompts to use the existing one, but no matter what I try, there are no tables, views or procedures listed.

      From Server Explorer, I can open the Data Connections and verify that the connection to the Oracle database is Open. During the Connection Wizard, there were no errors, and all the databases available were listed. Yet, connecting to and opening the connection to this specific database or anyone for that matter no tables, views or procedures are listed.

      I have little to no knowledge about Oracle, I've been thrown to the wolves. The Oracle dba for some reason is unable to help me solve this. He is able to login with my account info and view the data, but gets the same thing I get with JAVA. Clue?
      Any help is appreciated.