This discussion is archived
0 Replies Latest reply: Oct 8, 2012 8:23 PM by 966984 RSS

LDOM Issue on T2000   ldmd cannot communicate with the hypervisor as the re

966984 Newbie
Currently Being Moderated
Hi,

There were some issues with old primary LDOM at T2000 so I installed
new o/s 64 bit on SUN SPARC T2000 and reset SC on factor-default and
also installed LDOM 1.2 version. Seems like old hypervisor is not
deleted.
Now I am getting error.

#ldm list
Failed to connect to logical domain manager: Connection refused

So far I have trying the following steps. but still no luck

I installed version 1.2 LDOM. and also I updated SC. Plus I installed
below patches:

•118833-36, Kernel update patch
•124921-02, which contains updates to the Logical Domains 1.0 drivers
and utilities
•125043-01, which contains updates to the qcn (console) drivers.

SC> bootmode config="factory-default"
SC> poweroff
SC> resetsc -y
SC> poweron



Now I tried everything but still no luck

Here are some errot which I am getting

#Svcs -xv

[ Oct  5 00:07:14 Method "start" exited with status 96 ]
[ Oct  5 00:32:11 Leaving maintenance because disable requested. ]
[ Oct  5 00:32:11 Disabled. ]
[ Oct  5 00:32:21 Enabled. ]
[ Oct  5 00:32:21 Executing start method ("/opt/SUNWldm/bin/ldmd_start") ]

Service LOG file Info:

ldmd cannot communicate with the hypervisor as the required device
does not exist:
/devices/virtual-devices@100/channel-devices@200/virtual-channel@0:hvctl
Either this is not the control domain or the firmware does not support LDoms
[ Oct  5 00:32:21 Method "start" exited with status 96 ]
[ Oct  5 00:43:54 Leaving maintenance because disable requested. ]
[ Oct  5 00:43:54 Disabled. ]
[ Oct  5 00:45:19 Enabled. ]
[ Oct  5 00:45:19 Executing start method ("/opt/SUNWldm/bin/ldmd_start") ]
ldmd cannot communicate with the hypervisor as the required device
does not exist:
/devices/virtual-devices@100/channel-devices@200/virtual-channel@0:hvctl
Either this is not the control domain or the firmware does not support LDoms
[ Oct  5 00:45:19 Method "start" exited with status 96 ]
[ Oct  5 00:45:19 Rereading configuration. ]

bash-3.00# cd /opt/SUNWldm/bin/
bash-3.00# ls
ldm ldmconfig ldmd ldmd_start schemas
bash-3.00# ./ldmd_start
ldmd cannot communicate with the hypervisor as the required device
does not exist:
/devices/virtual-devices@100/channel-devices@200/virtual-channel@0:hvctl
Either this is not the control domain or the firmware does not support LDoms


bash-3.00# ldm
Failed to connect to logical domain manager: Connection refused
bash-3.00# sc>

sc> showhost
Sun-Fire-T2000 System Firmware 6.7.12 2011/07/06 20:03

Host flash versions:
OBP 4.30.4.d 2011/07/06 14:29
Hypervisor 1.7.3.c 2010/07/09 15:14
POST 4.30.4.b 2010/07/09 14:24

bash-3.00#
bash-3.00# uname -a
SunOS ldom-srv 5.10 Generic_118833-36 sun4v sparc SUNW,Sun-Fire-T200


Thanks in advance

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points