12 Replies Latest reply: Aug 22, 2008 5:08 AM by 654737 RSS

    Error oracle.forms.engine.Main not found.java.lang.ClassNotFoundException

    403863
      Hi all,
      I tried to update oracle_logo.gif in forms jar which is in f90all_jinit jar. I placed my icon in forms\oracle\forms\icons and renamed it as oracle_logo.gif while removing the existing one. Then I did jar the forms and placed that in f90all_jinit and again did jar f90all_jinit. Then, I placed this in ORACLE-HOME/forms90/java. When I tried to run the form...the form could not open and the java console shows this..
      Loading http://<MACHINE_NAME>:8888/forms90/java/f90all_jinit.jar from JAR cache

      load: class oracle.forms.engine.Main not found.java.lang.ClassNotFoundException: java.io.IOException: open HTTP connection failed.     at sun.applet.AppletClassLoader.getBytes(Unknown Source)     at sun.applet.AppletClassLoader.access$100(Unknown Source)     at sun.applet.AppletClassLoader$1.run(Unknown Source)     at java.security.AccessController.doPrivileged(Native Method)     at sun.applet.AppletClassLoader.findClass(Unknown Source)     at sun.plugin.security.PluginClassLoader.findClass(Unknown Source)     at java.lang.ClassLoader.loadClass(Unknown Source)     at sun.applet.AppletClassLoader.loadClass(Unknown Source)     at java.lang.ClassLoader.loadClass(Unknown Source)     at sun.applet.AppletClassLoader.loadCode(Unknown Source)     at sun.applet.AppletPanel.createApplet(Unknown Source)     at sun.plugin.AppletViewer.createApplet(Unknown Source)     at sun.applet.AppletPanel.runLoader(Unknown Source)     at sun.applet.AppletPanel.run(Unknown Source)     at java.lang.Thread.run(Unknown Source)

      Can anyone guide me on how to get rid of this error ? Strange thing is that I've removed that f90all_jinit.jar and placed back the existing one (I took backup). But still it's showing the same error and not opening the form. I could and can not do anything without this error corrected.
      Please suggest me as soon as possible...
      thank you
      madhu.