4 Replies Latest reply: Nov 26, 2012 10:52 AM by K- RSS

    Oracle Provider not Found

      Good afternoon Oracle Forum members,

      I'm having trouble on connecting a OraOLEDB.Oracle application to my Oracle Database 11g R2 (, I have a Windows Server 2008 Enterprise machine running it.
      Each time I try to connect it says: Oracle provider not found. It may be not properly installed.
      I've searched many site and tried many things like:

      -Registering DLLs manually using:
      REGSVR32 "C:\Program Files\Common Files\System\Ole DB\sqloledb.dll"
      REGSVR32 "C:\Program Files\Common Files\System\Ole DB\Oledb32.dll"
      REGSVR32 "C:\Program Files\Common Files\System\Ole DB\Msdasql.dll"
      REGSVR32 "C:\Program Files\Common Files\System\msadc\Msadce.dll"
      REGSVR32 "C:\oracle\product\11.2.0\dbhome_1\BIN\oraoledb11.dll"

      -Installing the client with ODAC112012 pack that comes with 32 bit features (but after it the database stops working properly.

      -Installed the client with ODTwithODAC112012 (but after it the database stops working properly)

      -Formatting and re-installing Win 2008 Server Enterprise, Oracle Database 11g R2 and all applications (did it more than 4 times)

      -Changing the provider from OraOLEDB.Oracle to MSDAORA (results in "Unknown Provider" message)

      Is there something I did wrong? Is there something else I have to do to make it work properly?

      Thank you very much!

      Edited by: K- on Oct 10, 2012 3:44 PM