This discussion is archived
3 Replies Latest reply: Nov 25, 2012 5:57 PM by 772481 RSS

Informatica Error: Repository mismatch

user4039570 Newbie
Currently Being Moderated
Hi There,
Our server has been migrated from IBM to AT&T.

So they exported our production informatica repository and imported it into new environment, So testing is going on.

I changed database connection strings of informatica session of source and target and ran the workflow.

I got the below error:
Error: Repository mismatch. Integration service is connected to repository [DII_REP_PRD] in domain [Domain_pl1us123] with repository GID [xxxxxxxx-xxxx-xxxx]. Client is trying to connect to repository[DII_REP_PRD] in domain [] with repository GID [xxxx-xxx-xxx-xxx].


Any ideas pls?

Thanks,
Raghu
  • 1. Re: Informatica Error: Repository mismatch
    Srini VEERAVALLI Guru
    Currently Being Moderated
    What is exported and imported? Informatica objects like workflow,session etc or you mean to say Informatica rep back up and restore?
    Why you are changing the connection setting at session level ?is it not supposed to be at connection on workflow manager?
    make sure ibm and att server settings are same.

    What you guys are testing?

    If helps mark for further
  • 2. Re: Informatica Error: Repository mismatch
    user4039570 Newbie
    Currently Being Moderated
    Thanks for the reply.

    1. They have exported the complete Informatica repository from IBM server to AT&T server.
    2. Yes you are right, I have changed connection info on connection tab in workflow manager.

    How we connect to informatica repository(AT&T) is:
    They have created a new domain.
    After giving username and passwd, we have to select the new domain and say connect.

    1. our informatica wkfs are scheduled through DAC. When I run a DAC plan it was running fine.
    2. When I run wkfs manually, it was giving error: How i fixed is:
    Goto Workflow tab on top, and say edit the workflow. Go to integration service, Here we have two services (IBM and AT&T),
    select AT&T service and save the changes. Now it worked.

    Thanks,
    Raghu
  • 3. Re: Informatica Error: Repository mismatch
    772481 Newbie
    Currently Being Moderated
    You will be able to re-assign the default integration service of workflow using "Assign Integration Service" tool.

    Logon to Workflow Manager --> Service--> Assign Integration Service
    (Just click on any folder before accessing Assign Integration Service)

    Pls mark if helps

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points