3 Replies Latest reply on Nov 26, 2012 1:57 AM by 772481

    Informatica Error: Repository mismatch

      Hi There,
      Our server has been migrated from IBM to AT&T.

      So they exported our production informatica repository and imported it into new environment, So testing is going on.

      I changed database connection strings of informatica session of source and target and ran the workflow.

      I got the below error:
      Error: Repository mismatch. Integration service is connected to repository [DII_REP_PRD] in domain [Domain_pl1us123] with repository GID [xxxxxxxx-xxxx-xxxx]. Client is trying to connect to repository[DII_REP_PRD] in domain [] with repository GID [xxxx-xxx-xxx-xxx].

      Any ideas pls?

        • 1. Re: Informatica Error: Repository mismatch
          What is exported and imported? Informatica objects like workflow,session etc or you mean to say Informatica rep back up and restore?
          Why you are changing the connection setting at session level ?is it not supposed to be at connection on workflow manager?
          make sure ibm and att server settings are same.

          What you guys are testing?

          If helps mark for further
          1 person found this helpful
          • 2. Re: Informatica Error: Repository mismatch
            Thanks for the reply.

            1. They have exported the complete Informatica repository from IBM server to AT&T server.
            2. Yes you are right, I have changed connection info on connection tab in workflow manager.

            How we connect to informatica repository(AT&T) is:
            They have created a new domain.
            After giving username and passwd, we have to select the new domain and say connect.

            1. our informatica wkfs are scheduled through DAC. When I run a DAC plan it was running fine.
            2. When I run wkfs manually, it was giving error: How i fixed is:
            Goto Workflow tab on top, and say edit the workflow. Go to integration service, Here we have two services (IBM and AT&T),
            select AT&T service and save the changes. Now it worked.

            • 3. Re: Informatica Error: Repository mismatch
              You will be able to re-assign the default integration service of workflow using "Assign Integration Service" tool.

              Logon to Workflow Manager --> Service--> Assign Integration Service
              (Just click on any folder before accessing Assign Integration Service)

              Pls mark if helps
              1 person found this helpful