1 2 Previous Next 24 Replies Latest reply: Oct 30, 2012 4:52 AM by 803725 Go to original post RSS
      • 15. Re: Authentication not working with LDAP
        803725
        If the Groups are visible and configured in the weblogic.xml then the users belonging to those groups should be able to authenticate.

        If somehow that is failing then I would suggest you to enable the Debug "-Dweblogic.debug.DebugSecurityAtn=true" in the Server/JVM start-up options and check what exactly is causing the authentication failure?
        • 16. Re: Authentication not working with LDAP
          803725
          If the Groups are visible and configured in the weblogic.xml then the users belonging to those groups should be able to authenticate.

          If somehow that is failing then I would suggest you to enable the Debug "-Dweblogic.debug.DebugSecurityAtn=true" in the Server/JVM start-up options and check what exactly is causing the authentication failure?
          • 17. Re: Authentication not working with LDAP
            968354
            Thanks I will do the same and update you the result.
            • 18. Re: Authentication not working with LDAP
              968354
              I have changed the setting an now error is logged in details.

              I could understand something from log that i want to share with you. Below is my user and group setting:

              Only two users are filtered: User1 and User2
              One group is filtered : Group1

              Test Case 1:
              User Filter: (&(|(cn=User1)(cn=User2)))
              Group: Group1
              Authentication Result: Only User1 is able to logged into and not User2.
              Cause: When using User2 below authentication data is used by web logic as found in logs.
              <authenticate user:domain\ User2 with DN:CN= User1,OU=GEN,OU=Users,OU=XXX,OU=XXX,OU=IND,DC=XXXX,DC=XXXX,DC=XXXX>
              see the bold letters, weblogic is trying to authenticate User2 using User1 DN. It is also happening vice-versa if a change the filter and write User2 before User1 i.e. (&(|(cn=User2)(cn=User1))) .

              This is what I could get from logs. I am looking into it. In the meantime you can also check and let me know what is happening there.
              • 19. Re: Authentication not working with LDAP
                803725
                Have you altered the Users and Groups Filters in the Provider configuratoin?

                Could you please send me the config.xml to have a look at the same?
                • 20. Re: Authentication not working with LDAP
                  968354
                  Config.xml:


                  <?xml version='1.0' encoding='UTF-8'?>
                  <domain xmlns="http://xmlns.oracle.com/weblogic/domain" xmlns:sec="http://xmlns.oracle.com/weblogic/security" xmlns:wls="http://xmlns.oracle.com/weblogic/security/wls" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://xmlns.oracle.com/weblogic/security/xacml http://xmlns.oracle.com/weblogic/security/xacml/1.0/xacml.xsd http://xmlns.oracle.com/weblogic/security/providers/passwordvalidator http://xmlns.oracle.com/weblogic/security/providers/passwordvalidator/1.0/passwordvalidator.xsd http://xmlns.oracle.com/weblogic/domain http://xmlns.oracle.com/weblogic/1.0/domain.xsd http://xmlns.oracle.com/weblogic/security http://xmlns.oracle.com/weblogic/1.0/security.xsd http://xmlns.oracle.com/weblogic/security/wls http://xmlns.oracle.com/weblogic/security/wls/1.0/wls.xsd">
                  <name>AMS</name>
                  <domain-version>10.3.6.0</domain-version>
                  <security-configuration>
                  <name>AMS</name>
                  <realm>
                  <sec:authentication-provider xsi:type="wls:active-directory-authenticatorType">
                  <sec:name>AD</sec:name>
                  <sec:control-flag>SUFFICIENT</sec:control-flag>
                  <wls:host>xxx.xx.xxx.xxx</wls:host>
                  <wls:principal>domain\User1</wls:principal>
                  <wls:user-base-dn>OU=IND,DC=xxxx,DC=xxxx,DC=xxxx</wls:user-base-dn>
                  <wls:credential-encrypted>{AES}oXoDoZi4Wue8n2pk2HOs/1DHxrWI+C2AARUgwEMTdx8=</wls:credential-encrypted>
                  <wls:user-from-name-filter>(&amp;(objectclass=user))</wls:user-from-name-filter>
                  <wls:group-base-dn>OU=IND,DC=xxxx,DC=xxxx,DC=xxxx</wls:group-base-dn>
                  <wls:group-from-name-filter>(&amp;(objectclass=group))</wls:group-from-name-filter>
                  </sec:authentication-provider>
                  <sec:authentication-provider xsi:type="wls:default-authenticatorType">
                  <sec:control-flag>SUFFICIENT</sec:control-flag>
                  </sec:authentication-provider>
                  <sec:authentication-provider xsi:type="wls:default-identity-asserterType">
                  <sec:active-type>AuthenticatedUser</sec:active-type>
                  </sec:authentication-provider>
                  <sec:role-mapper xmlns:xac="http://xmlns.oracle.com/weblogic/security/xacml" xsi:type="xac:xacml-role-mapperType"></sec:role-mapper>
                  <sec:authorizer xmlns:xac="http://xmlns.oracle.com/weblogic/security/xacml" xsi:type="xac:xacml-authorizerType"></sec:authorizer>
                  <sec:adjudicator xsi:type="wls:default-adjudicatorType"></sec:adjudicator>
                  <sec:credential-mapper xsi:type="wls:default-credential-mapperType"></sec:credential-mapper>
                  <sec:cert-path-provider xsi:type="wls:web-logic-cert-path-providerType"></sec:cert-path-provider>
                  <sec:cert-path-builder>WebLogicCertPathProvider</sec:cert-path-builder>
                  <sec:name>myrealm</sec:name>
                  <sec:password-validator xmlns:pas="http://xmlns.oracle.com/weblogic/security/providers/passwordvalidator" xsi:type="pas:system-password-validatorType">
                  <sec:name>SystemPasswordValidator</sec:name>
                  <pas:min-password-length>8</pas:min-password-length>
                  <pas:min-numeric-or-special-characters>1</pas:min-numeric-or-special-characters>
                  </sec:password-validator>
                  </realm>
                  <default-realm>myrealm</default-realm>
                  <credential-encrypted>{AES}w9PsbhV9YlONyLBWjYQ1ni1gkCADkopLKsEDpP2lmlGejB90EiWHCFyjNZ3vrFTDUmqNXeVzOgV1BB50XRNWUlhOnjisW2/6cMoob4ZhNbVP2r+MXR6fikiHWPwMNoCJ</credential-encrypted>
                  <node-manager-username>weblogic</node-manager-username>
                  <node-manager-password-encrypted>{AES}hj8YLKCNSYOixb0h7RfYNMqKyDQP3JV5LvAJ5Ac1X/o=</node-manager-password-encrypted>
                  </security-configuration>
                  <server>
                  <name>AdminServer</name>
                  <log>
                  <stdout-severity>Debug</stdout-severity>
                  <memory-buffer-severity>Debug</memory-buffer-severity>
                  </log>
                  <server-debug>
                  <debug-security-atn>true</debug-security-atn>
                  </server-debug>
                  <listen-address></listen-address>
                  </server>
                  <embedded-ldap>
                  <name>AMS</name>
                  <credential-encrypted>{AES}qkT+1//vgbLz4UBSfgHwLWIacbN2/GEuLAn/w+DXsUJ7Uop08DcWmPj7LdZv/fc7</credential-encrypted>
                  </embedded-ldap>
                  <configuration-version>10.3.6.0</configuration-version>
                  <app-deployment>
                  <name>TomcatServletExample1</name>
                  <target>AdminServer</target>
                  <module-type>war</module-type>
                  <source-path>C:\Users\ankitkumar_singh\Downloads\Test Ldap\TomcatServletExample1.war</source-path>
                  <security-dd-model>DDOnly</security-dd-model>
                  </app-deployment>
                  <app-deployment>
                  <name>gsmcs.war</name>
                  <target>AdminServer</target>
                  <module-type>war</module-type>
                  <source-path>D:\NetBeans_Workspace\26Oct2012\gsmcs\dist\gsmcs.war</source-path>
                  <security-dd-model>DDOnly</security-dd-model>
                  </app-deployment>
                  <web-app-container>
                  <x-powered-by-header-level>SHORT</x-powered-by-header-level>
                  <show-archived-real-path-enabled>true</show-archived-real-path-enabled>
                  </web-app-container>
                  <admin-server-name>AdminServer</admin-server-name>
                  <jdbc-system-resource>
                  <name>hibernate.gsmcs.datasource</name>
                  <target>AdminServer</target>
                  <descriptor-file-name>jdbc/hibernate2egsmcs2edatasource-6574-jdbc.xml</descriptor-file-name>
                  </jdbc-system-resource>
                  </domain>
                  • 21. Re: Authentication not working with LDAP
                    803725
                    Please modify the filters configured as below and let me know ifthe behavior changes:-

                    User From Name Filter:- (&(cn=%u)(objectclass=user))
                    Group From Name Filter:- (&(cn=%g)(objectclass=group))
                    • 22. Re: Authentication not working with LDAP
                      968354
                      ####<Oct 30, 2012 2:22:09 PM IST> <Debug> <SecurityAtn> <CHDSEZ298412D> <AdminServer> <[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1351587129946> <BEA-000000> <com.bea.common.security.internal.service.CallbackHandlerWrapper.handle will delegate all callbacks>
                      ####<Oct 30, 2012 2:22:09 PM IST> <Debug> <SecurityAtn> <CHDSEZ298412D> <AdminServer> <[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1351587129946> <BEA-000000> <com.bea.common.security.internal.service.CallbackHandlerWrapper.handle delegated callbacks>
                      ####<Oct 30, 2012 2:22:09 PM IST> <Debug> <SecurityAtn> <CHDSEZ298412D> <AdminServer> <[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1351587129946> <BEA-000000> <com.bea.common.security.internal.service.CallbackHandlerWrapper.handle did not get username from a callback>
                      ####<Oct 30, 2012 2:22:09 PM IST> <Debug> <SecurityAtn> <CHDSEZ298412D> <AdminServer> <[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1351587129946> <BEA-000000> <LDAP Atn Login username: domain\user1>
                      ####<Oct 30, 2012 2:22:09 PM IST> <Debug> <SecurityAtn> <CHDSEZ298412D> <AdminServer> <[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1351587129946> <BEA-000000> <authenticate user:*domain\user1*>
                      ####<Oct 30, 2012 2:22:09 PM IST> <Debug> <SecurityAtn> <CHDSEZ298412D> <AdminServer> <[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1351587129946> <BEA-000000> <getConnection return conn:LDAPConnection { ldapVersion:2 bindDN:""}>
                      ####<Oct 30, 2012 2:22:09 PM IST> <Debug> <SecurityAtn> <CHDSEZ298412D> <AdminServer> <[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1351587129962> <BEA-000000> <getDNForUser search("ou=people,ou=myrealm,dc=AMS", "(&(uid= *_domain\5cuser1_* )(objectclass=person))", base DN & below)>
                      ####<Oct 30, 2012 2:22:09 PM IST> <Debug> <SecurityAtn> <CHDSEZ298412D> <AdminServer> <[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1351587129962> <BEA-000000> <DN for user domain\user1: null>
                      ####<Oct 30, 2012 2:22:09 PM IST> <Debug> <SecurityAtn> <CHDSEZ298412D> <AdminServer> <[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1351587129962> <BEA-000000> <returnConnection conn:LDAPConnection { ldapVersion:2 bindDN:""}>
                      ####<Oct 30, 2012 2:22:09 PM IST> <Debug> <SecurityAtn> <CHDSEZ298412D> <AdminServer> <[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1351587129962> <BEA-000000> <getConnection return conn:LDAPConnection { ldapVersion:2 bindDN:""}>
                      ####<Oct 30, 2012 2:22:09 PM IST> <Debug> <SecurityAtn> <CHDSEZ298412D> <AdminServer> <[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1351587129962> <BEA-000000> <getDNForUser search("ou=people,ou=myrealm,dc=AMS", "(&(uid= *_domain\5cuser1_* )(objectclass=person))", base DN & below)>
                      ####<Oct 30, 2012 2:22:09 PM IST> <Debug> <SecurityAtn> <CHDSEZ298412D> <AdminServer> <[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1351587129962> <BEA-000000> <DN for user domain\user1: null>
                      ####<Oct 30, 2012 2:22:09 PM IST> <Debug> <SecurityAtn> <CHDSEZ298412D> <AdminServer> <[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1351587129962> <BEA-000000> <returnConnection conn:LDAPConnection { ldapVersion:2 bindDN:""}>
                      ####<Oct 30, 2012 2:22:09 PM IST> <Debug> <SecurityAtn> <CHDSEZ298412D> <AdminServer> <[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1351587129962> <BEA-000000> <javax.security.auth.login.FailedLoginException: [Security:090302]Authentication Failed: User domain\user1 denied
                           at weblogic.security.providers.authentication.LDAPAtnLoginModuleImpl.login(LDAPAtnLoginModuleImpl.java:229)
                           at com.bea.common.security.internal.service.LoginModuleWrapper$1.run(LoginModuleWrapper.java:110)
                           at java.security.AccessController.doPrivileged(Native Method)
                           at com.bea.common.security.internal.service.LoginModuleWrapper.login(LoginModuleWrapper.java:106)
                           at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                           at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                           at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                           at java.lang.reflect.Method.invoke(Method.java:597)
                           at javax.security.auth.login.LoginContext.invoke(LoginContext.java:769)
                           at javax.security.auth.login.LoginContext.access$000(LoginContext.java:186)
                           at javax.security.auth.login.LoginContext$4.run(LoginContext.java:683)
                           at java.security.AccessController.doPrivileged(Native Method)
                           at javax.security.auth.login.LoginContext.invokePriv(LoginContext.java:680)
                           at javax.security.auth.login.LoginContext.login(LoginContext.java:579)
                           at com.bea.common.security.internal.service.JAASLoginServiceImpl.login(JAASLoginServiceImpl.java:113)
                           at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                           at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                           at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                           at java.lang.reflect.Method.invoke(Method.java:597)
                           at com.bea.common.security.internal.utils.Delegator$ProxyInvocationHandler.invoke(Delegator.java:57)
                           at $Proxy16.login(Unknown Source)
                           at weblogic.security.service.internal.WLSJAASLoginServiceImpl$ServiceImpl.login(WLSJAASLoginServiceImpl.java:89)
                           at com.bea.common.security.internal.service.JAASAuthenticationServiceImpl.authenticate(JAASAuthenticationServiceImpl.java:82)
                           at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                           at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                           at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                           at java.lang.reflect.Method.invoke(Method.java:597)
                           at com.bea.common.security.internal.utils.Delegator$ProxyInvocationHandler.invoke(Delegator.java:57)
                           at $Proxy34.authenticate(Unknown Source)
                           at weblogic.security.service.WLSJAASAuthenticationServiceWrapper.authenticate(WLSJAASAuthenticationServiceWrapper.java:40)
                           at weblogic.security.service.PrincipalAuthenticator.authenticate(PrincipalAuthenticator.java:338)
                           at weblogic.servlet.security.internal.SecurityModule.checkAuthenticate(SecurityModule.java:252)
                           at weblogic.servlet.security.internal.SecurityModule.checkAuthenticate(SecurityModule.java:201)
                           at weblogic.servlet.security.internal.BasicSecurityModule.checkUserPerm(BasicSecurityModule.java:75)
                           at weblogic.servlet.security.internal.SecurityModule.checkAccess(SecurityModule.java:122)
                           at weblogic.servlet.security.internal.ServletSecurityManager.checkAccess(ServletSecurityManager.java:82)
                           at weblogic.servlet.internal.WebAppServletContext.securedExecute(WebAppServletContext.java:2209)
                           at weblogic.servlet.internal.WebAppServletContext.execute(WebAppServletContext.java:2179)
                           at weblogic.servlet.internal.ServletRequestImpl.run(ServletRequestImpl.java:1490)
                           at weblogic.work.ExecuteThread.execute(ExecuteThread.java:256)
                           at weblogic.work.ExecuteThread.run(ExecuteThread.java:221)

                      This is the error comes after using the filter given bu you also DN is null as well as domain/5cuser1 why 5c is being appended i don't know.
                      • 23. Re: Authentication not working with LDAP
                        968354
                        000000> <com.bea.common.security.internal.service.CallbackHandlerWrapper.handle got username from callbacks[0], UserName=*domain\user1*>
                        ####<Oct 30, 2012 2:22:09 PM IST> <Debug> <SecurityAtn> <CHDSEZ298412D> <AdminServer> <[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1351587129821> <BEA-000000> <LDAP Atn Login username: domain\user1>
                        ####<Oct 30, 2012 2:22:09 PM IST> <Debug> <SecurityAtn> <CHDSEZ298412D> <AdminServer> <[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1351587129821> <BEA-000000> <authenticate user:*domain\user1*>
                        ####<Oct 30, 2012 2:22:09 PM IST> <Debug> <SecurityAtn> <CHDSEZ298412D> <AdminServer> <[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1351587129821> <BEA-000000> <getConnection return conn:LDAPConnection {ldaps://1111.xxxx.xxxx.xxxx:389 ldapVersion:3 bindDN:"*domain\user1*"}>
                        ####<Oct 30, 2012 2:22:09 PM IST> <Debug> <SecurityAtn> <CHDSEZ298412D> <AdminServer> <[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1351587129821> <BEA-000000> <getDNForUser search("OU=IND,DC=xxxx,DC=xxxx,DC=xxxx", "(&(&(cn=domain\5cuser1)(objectclass=user))(!(userAccountControl:1.2.840.113556.1.4.803:=2)))", base DN & below)>
                        ####<Oct 30, 2012 2:22:09 PM IST> <Debug> <SecurityAtn> <CHDSEZ298412D> <AdminServer> <[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1351587129930> <BEA-000000> <DN for user domain\user1: null>
                        ####<Oct 30, 2012 2:22:09 PM IST> <Debug> <SecurityAtn> <CHDSEZ298412D> <AdminServer> <[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1351587129930> <BEA-000000> <returnConnection conn:LDAPConnection {ldaps://111.xxxx.xxxx.xxxx:389 ldapVersion:3 bindDN:"domain\user1"}>
                        ####<Oct 30, 2012 2:22:09 PM IST> <Debug> <SecurityAtn> <CHDSEZ298412D> <AdminServer> <[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1351587129930> <BEA-000000> <getConnection return conn:LDAPConnection {ldaps://1111.xxxx.xxxx.xxxx:389 ldapVersion:3 bindDN:"*domain\user1*"}>
                        ####<Oct 30, 2012 2:22:09 PM IST> <Debug> <SecurityAtn> <CHDSEZ298412D> <AdminServer> <[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1351587129930> <BEA-000000> <getDNForUser search("OU=IND,DC=xxxx,DC=xxxx,DC=xxxx", "(&(&(cn=*domain\user1*)(objectclass=user))(!(userAccountControl:1.2.840.113556.1.4.803:=2)))", base DN & below)>
                        ####<Oct 30, 2012 2:22:09 PM IST> <Debug> <SecurityAtn> <CHDSEZ298412D> <AdminServer> <[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1351587129930> <BEA-000000> <DN for user domain\user1: null>
                        ####<Oct 30, 2012 2:22:09 PM IST> <Debug> <SecurityAtn> <CHDSEZ298412D> <AdminServer> <[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1351587129946> <BEA-000000> <returnConnection conn:LDAPConnection {ldaps://111.xxxx.xxxx.xxxx:389 ldapVersion:3 bindDN:"*domain\user1*"}>
                        ####<Oct 30, 2012 2:22:09 PM IST> <Debug> <SecurityAtn> <CHDSEZ298412D> <AdminServer> <[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1351587129946> <BEA-000000> <javax.security.auth.login.FailedLoginException: [Security:090302]Authentication Failed: User domain\user1
                        denied
                             at weblogic.security.providers.authentication.LDAPAtnLoginModuleImpl.login(LDAPAtnLoginModuleImpl.java:229)
                             at com.bea.common.security.internal.service.LoginModuleWrapper$1.run(LoginModuleWrapper.java:110)

                        Edited by: 965351 on Oct 30, 2012 2:15 AM
                        • 24. Re: Authentication not working with LDAP
                          803725
                          Could you please correct the Principal Name for connecting to LDAP.whay is this given in this manner

                          "<wls:principal>domain\User1</wls:principal>"

                          It needs to be given either simply

                          "<wls:principal>User1</wls:principal>"


                          OR Give the complete DN for this user e.g.


                          "<wls:principal>cn=User1,OU=xxx,DC=xxx,DC=xxx</wls:principal>"

                          Could you please rectify this and test.

                          "domain\User1" neither specifies a proper username or a proper DN.

                          Edited by: V Kumar on Oct 30, 2012 3:22 PM
                          1 2 Previous Next