0 Replies Latest reply on Oct 16, 2012 10:33 AM by Ketil

    Kernel panic installing Oracle VM server 3.1.1 on HP DL380p Gen8

      I've ran into a trouble installing Oracle VM server 3.1.1 on a HP DL380p Gen8 server, it just get's a kernel panic and reboots.
      Using serial console log I've gotten an output of:
      BUG: unable to handle kernel NULL pointer dereference at 00000000000006b0
      IP: [<ffffffff810661c5>] do_sched_rt_period_timer+0xa5/0x210
      PGD 0
      Oops: 0000 [#1] SMP
      CPU 0
      Modules linked in:

      Pid: 1, comm: swapper Not tainted 2.6.39-200.1.1.el5uek #1 HP ProLiant DL380p Gen8

      The trace contains the same messages as ID 1498719.1 but for me on this hardware setting the HP Power Control to "OS Controlled Mode" or "Maximum Performance" does not help.
      What I've found out helps by fiddling with BIOS settings, is to disable "Hyperthreading" or setting the boot parameter "maxcpus=7" (This is a server with 1 Quadcore CPU) works. Setting "maxcpus=8" gives me the kernel panic again.
      Also tried both upgrading firmware on the server and downgrading BIOS ROM.

      Anyone tried Oracle VM server on this hardware, or have any ideas or tricks to try?