1 Reply Latest reply on Nov 4, 2012 10:55 AM by RavagliVirgilio

    orbd doesn't work

      Hi everybody.
      I'm trying to start orbd on Windows XP 32, JDK 1.6, Java Client VM.

      I've tried start orbd -ORBInitialPort 1050, but orbd doesn't start.
      I saw a warning message:
      BAD_PARAM could not load class standard_init

      followed by:
      GRAVE (COMM_FAILURE) Unable to create listener thread on the specified port: 1049

      I don't know what to do, it looked very simple to start orbd, non preliminary actrion, simply giving the command start orbd -ORBInitialPort 1050, but it doesn't work.
      Am I forgetting any action ?

      any help would be really appreciated

        • 1. Re: orbd doesn't work
          For everyone interested: I solved the problem, reading a similar problem posted by another fellow.
          ORBD didn't work in my environment, because there was a file named orb.properties coming from a previous JacORB installation.
          The orb.properties was located in my user home directory, and it conflicted against ORBD tool.

          I removed the file and then ORBD worked as expected.
          In other words, ORBD doesn't need an orb.properties file, but it can't work if there's an incompatible orb.properties already existing in a strategic location, as the user home directory.