9 Replies Latest reply: Dec 12, 2012 3:00 PM by user547599 - oracle RSS

    Your experience at 11.1.2.2 with IE9

    Alp Burak
      Hi All,
      We've been trying to upgrade to 11.1.2.2 from 11.1.1.3 in order to get advantage of improved 64bit support. However, we are facing issues with IE9 and I'd like to ask whether we are the only people on earth to face these issues. Our entities are moving towards upgrading their IE versions to 9 and we've looked at the supported platform matrix to see which 11.1.2.x release supports IE9. To our relief, 11.1.2.2 seemed to support it fully. However, when we installed, configured and migrated everything, we've been surprised to see that it's not really the case. Now, in our scenario, ADF interface is a no no as we have so much of customizations that we can not drop in the favor of in-built features like conditional formatting and validations. Therefore, classic interface is the way to go for us. When we open any form in this interface, forms look somewhat shrunk and scrambled. For example, there is a form that spans around a few hundred rows downwards. When we open this form in IE8 or Firefox 10+ (with xul) it looks perfectly fine, but with IE9, form takes about one fourth of the screen showing only couple of rows with a tiny scroll bar on the right... hence, it is impossible to use. We've tried all the suggested settings, configurations, done three re-installations. Nothing worked. Recently we have opened an SR to reach below suggestion:
           
      You cannot use the IE 9 as long as ORACLE_ADF_UI is set to false.
      If you set it to true; you will not be able to use your customization you did.
      so as far as you set the ORACLE_ADF_UI t false I suggest you to go for 11.1.2.1.600 in lieu of 11.1.2.2.300
      Please check: Hyperion Planning 11.1.2.1.600 Patch Set Update (Patch 14464109) (Doc ID 1487437.1)

      Please find the statement from Product issue manager:

      +• The Classic UI does not support IE9. This is documented as a known issue in the Planning 11.1.2.2 Readme. Bug 12796204 - Internet Explorer 9 users cannot choose to use Classic Planning in basic or advanced mode. Classic Planning does not support Internet Explorer 9.+

      That mean you need to use IE8 in case the ORACLE_ADF_UI is false

      What is your experience in this? Have you come across to this scenario?

      Cheers,
      Alp
        • 1. Re: Your experience at 11.1.2.2 with IE9
          JohnGoodwin
          Hi Alp,

          It is funny how you have just raised this because just recently I had set ORACLE_ADF_UI to false on an environment using IE9 and I saw exactly the same things, this was with the .300 patch applied.
          The forms rendered fine using firefox but were a complete mess in IE9, I must admit I missed the bug in the readme which I think is definitely not clear enough and this should be clearly highlighted in the support matrix.

          I don't think there are many other options around it unless using firefox or previous versions of IE

          Cheers

          John
          http://john-goodwin.blogspot.com/
          • 2. Re: Your experience at 11.1.2.2 with IE9
            Alp Burak
            Thanks John, you are right. This should've been pointed out clearly in the supported platforms matrix but it's not. We'll probably end up going back to 11.1.2.1.600. I asked in my SR whether this is to be resolved soon or not. Still waiting for a reply.

            Cheers,
            Alp
            • 3. Re: Your experience at 11.1.2.2 with IE9
              JohnGoodwin
              Let us know how you get on with the SR it will be interesting to know if they are going to address it.
              It seems that Oracle have pushed the IE9 and ADF functionality and at the same time said it is ok you can also revert to the old way but have failed to highlight the massive caveat that it doesn't work with IE9

              Cheers

              John
              http://john-goodwin.blogspot.com/
              • 4. Re: Your experience at 11.1.2.2 with IE9
                Tinotarantino-Oracle
                We are also experiancing the exact same issue. We recently upgraded to 11.1.2.2.302 of Planning. We have also logged an SR with Oracle Support. However, the response we get is that IE 9 SHOULD WORK when ORACLE_ADF_UI=TRUE. Clearly this is not the case. When I pointed the Oracle Support person to this thread and highlighted the following bug in the readme file for Hyperoin Planning 11.1.2.2.000

                +12796204 -- Internet Explorer 9 users cannot choose to use Classic Planning in basic or+
                advanced mode. Classic Planning does not support Internet Explorer 9.

                Reponse from Oracle Support.

                This bug only relates to the the classic UI feature which allows a user to switch between BASIC or ADVANCED mode.   Classic UI however is supported in
                IE 9.0.   If get a different answer from Oracle Support, Ill update this thread.
                • 5. Re: Your experience at 11.1.2.2 with IE9
                  Alp Burak
                  No luck in this really. The support person kind of confirmed there is no planned fix to this issue. It seems Oracle is preparing to bury the Classic UI six feet underground (remember law suits with Bindows-MB Technologies?).
                  At the end, we had no option but to go back to 11.1.2.1.600 just to get IE9 compatibility back as it is way too important compared to what 11.1.2.2 would bring on board as new features. Kind of disheartening considering all the customization that we have done? I am not sure as to whether ADF will provide same level of flexibility when it comes to customization. But if this is the way to go, it is the way to go.

                  Keep us up-to-date if you hear anything different.

                  Cheers,
                  Alp
                  • 6. Re: Your experience at 11.1.2.2 with IE9
                    Philippe Champleboux
                    I face the same problem : we have to keep our web form customization and have to chose between 11.1.2.1.600 and 11.1.2.2.3xx.

                    Does someone know something about customization via ADF ?

                    Regards,
                    • 7. Re: Your experience at 11.1.2.2 with IE9
                      Rowdy
                      I wonder if there would be any change accessing classic planning app directly using planning URL without going through workspace. I have had differences with different IE versions and accessing apps using workspace vs. planning URL.

                      Thanks,
                      Ram Reddy
                      • 8. Re: Your experience at 11.1.2.2 with IE9
                        JohnGoodwin
                        I think if you disable the ADF functionality it is only disabled in workspace and if you access planning directly the ADF functionality will still be present.

                        Cheers

                        John
                        http://john-goodwin.blogspot.com/
                        • 9. Re: Your experience at 11.1.2.2 with IE9
                          user547599 - oracle
                          Hi All,
                          First of all I want to thanks all you guys in this thread for sharing your concern. Just want to assure you that Oracle is aware of this issue and the work is in progress to certify 11.1.2.2 Planning Classic UI with IE9. We are shooting for End of Jan 2103 (subject to change) to get this done and release the patch on top of 11.1.2.2.

                          I also want to make a note that new features that came in 11.1.2.2 will not be available in Classic Planning UI, these new features are only available with ADF UI.

                          On your point regarding the Planning UI only switches to classic mode with ORACLE_ADF_UI = false in workspace. Oracle prefers and recommends using Planning via workspace, however in case you need to access the Planning UI directly, then in this case you need to fire a different URL to login in the planning.

                          In case you want to access Planning UI directly with ORACLE_ADF_UI set to false, you need to fire the URL like http://<servername>:port/HyperionPlanning/LogOn.jsp

                          Once again thanks for sharing your concerns and please keep doing that and we will be glad to help.