2 Replies Latest reply: Oct 18, 2012 7:41 AM by 963943 RSS

    Autologon problem with XP

    963943
      Hi,

      I am setting up a small laboratory with 16 Sun Ray DTUs and a SunFire X4170 (running Oracle Linux 5.7). User authentication is handled by OpenLDAP 2.3.43, which I have installed on the same server. I have imported my first template (WinXP with Service Pack 3) and installed the guest additions from the command line using the /with_autologon option. When I log in from the Sun Ray, the user is authenticated but I get an error message from Windows to check that the username and domain are correct. If I manually insert the administrator's username and password I can enter the XP virtual machine. Any ideas?

      Thanks,

      Jonathan
        • 1. Re: Autologon problem with XP
          805861
          Have you configured your Windows XP to authenticate against OpenLDAP or do you have all the user accounts on the XP templates before cloning them?
          • 2. Re: Autologon problem with XP
            963943
            Dear Dave, thanks for this. As you may have guessed, I had not configured XP to authenticate separately against OpenLDAP, and had not realised that this was necessary. I presume therefore that the autologon parameter merely tells Windows to take the authentication credentials from the VDI, without creating a new user? The most elegant solution would be to authenticate against OpenLDAP, using something like pgina with the ldap plugin, and perhaps samba to map the user home directories for personal desktops. lf you, or other list members, have any advice or experience in relation to this, it would be very useful and undoubtedly save me a lot of time.

            Thanks again,

            Jonathan