1 Reply Latest reply: Oct 18, 2012 7:32 AM by Michael Peel-Oracle RSS

    Not able to disable spell correction

    DevReddy
      Hi
      I am using the Dgraph flag <arg>--spl</arg> flag in in AppConfig  for auto correction. But for some of my queires i want to disable this auto correction feature.

      I am giving the opt as "mode+matchany+spell+nospell" in ERecSearch object. but its still giving me the auto corrected results.

      Does anyone has an idea how it works , should i remove the Dgraph flag permanently. But i still want the auto correction for other queries

      Thanks
      DEV
        • 1. Re: Not able to disable spell correction
          Michael Peel-Oracle
          Adding spell+nospell to the options should work - try it via the reference application, i.e.:
          http://localhost:8006/endeca_jspref/controller.jsp?eneHost={dgraph-host}&enePort={dgraph-port}&N=0&Ntk={search-interface}&Ntt={term}&Ntx=mode+matchall+spell+nospell

          If that works it may be something to do with your web application code. You can also try switching on verbose logging at the dgraph and checking the dgraph log for further information.

          Michael