This discussion is archived
5 Replies Latest reply: Nov 2, 2012 9:22 PM by Sergiusz Wolicki (Oracle) RSS

Using SQL*Loader to Load Russian and Chinese Characters

user169310 Newbie
Currently Being Moderated
We are testing our new 11.2.0.1 database using Oracle Linux 6. We created the database using the AL32UTF8 NLS Character set. We have tried using sqlldr to insert a few records that contain Russian and Chinese characters as a test. We can not seem to get them into the database in the correct format. For example, we can see the correct characters in the file we are trying to load on the Linux server, but once we load them into a table in the database, some of the characters are not displayed correctly (using SQL*Developer to select them out).

We can set the values within a column on the table by inserting them into the table and then select them out and they are correect, so it appears the problem is not in the database, but in the way sqlldr inserts them. We have tried several settings on the Linux server to set the NLS_LANG environment to AMERICAN_AMERICA.AL32UTF8, AMERICAN_AMERICA.UTF8, etc. without success.

Can someone provide us with any guidance on this? Would really appreciate any advice as to what we are not getting here.

Thanks!!

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points