2 Replies Latest reply: Oct 19, 2012 7:51 PM by 861715 RSS

    ldd command not working

      Hello all,

      I recently tried to use the ldd command and for some reason when I try it it does not return anything.
      The only time it returns anything is if I type #ldd -a all it says is the following:

      #ldd -a
      usage: ldd [-d | -r] [-c] [-D] [-e envar] [-f] [-i] [-L] [-l] [-p] [-s] [-U | -u] [-v] [-w] file(s)

      I know this is something that is normal when the command is used incorrectly, however, I was trying to simply get any response from the program. I tried using it on different packages I know are installed on the server and I recieved nothing. The path is set and when I do a pkgchk and lkginfo it looks all correct. I pasted the output below. Any help is gretaly appreciated. Thank You.

      # pkgchk -lp /usr/bin/ldd
      Pathname: /usr/bin/ldd
      Type: regular file
      Expected mode: 0555
      Expected owner: root
      Expected group: bin
      Expected file size (bytes): 29448
      Expected sum(1) of contents: 49474
      Expected last modification: Jul 06 09:54:53 2011
      Referenced by the following packages:
      Current status: installed

      # pkginfo -l SUNWtoo
      PKGINST: SUNWtoo
      NAME: Programming Tools
      CATEGORY: system
      ARCH: sparc
      VERSION: 11.10.0,REV=2005.
      BASEDIR: /
      VENDOR: Oracle Corporation
      DESC: utilities for software development, including ld, ldd, od, and truss
      PSTAMP: on10ptchfeat20110620075032
      INSTDATE: Dec 19 2011 14:42
      HOTLINE: Please contact your local service provider
      STATUS: completely installed
      FILES: 71 installed pathnames
      11 shared pathnames
      4 linked files
      15 directories
      34 executables
      2329 blocks used (approx)