13 Replies Latest reply: Oct 30, 2012 2:56 AM by 698658 RSS

    Install Oracle11gR2 Grid Infrastructure on RedHat Enterprise Linux 5.7

    user12220581
      Hi,

      I got a problem when I install Oracle11gR2 Grid Infrastructure with ASM on RedHat Enterprise Linux 5.7
      The Error is occured when I want to execute root.sh script on first node of cluster.

      2012-10-18 20:06:42: Verifying current OCR settings with user entered values
      2012-10-18 20:06:42: Setting OCR locations in /etc/oracle/ocr.loc
      2012-10-18 20:06:42: Validating OCR locations in /etc/oracle/ocr.loc
      2012-10-18 20:06:42: Checking for existence of /etc/oracle/ocr.loc
      2012-10-18 20:06:42: Backing up /etc/oracle/ocr.loc to /etc/oracle/ocr.loc.orig
      2012-10-18 20:06:42: Setting ocr location +CRS
      2012-10-18 20:06:42: Creating or upgrading Oracle Local Registry (OLR)
      2012-10-18 20:06:44: OLR successfully created or upgraded
      2012-10-18 20:06:44: /u01/app/11.2.0/grid/bin/clscfg -localadd
      2012-10-18 20:06:44: Failed to create keys in the OLR, rc = 126, 32256
      2012-10-18 20:06:44: ###### Begin DIE Stack Trace ######
      2012-10-18 20:06:44: Package File Line Calling
      2012-10-18 20:06:44: --------------- -------------------- ---- ----------
      2012-10-18 20:06:44: 1: main rootcrs.pl 300 crsconfig_lib::dietrap
      2012-10-18 20:06:44: 2: main rootcrs.pl 427 main::__ANON__
      2012-10-18 20:06:44: ####### End DIE Stack Trace #######

      Please help me to fix this problem.
      Thanks

      Regards
      Robert
        • 1. Re: Install Oracle11gR2 Grid Infrastructure on RedHat Enterprise Linux 5.7
          rajeysh
          refer:-

          https://cn.forums.oracle.com/forums/thread.jspa?threadID=2340160(answered thread)
          • 2. Re: Install Oracle11gR2 Grid Infrastructure on RedHat Enterprise Linux 5.7
            user12220581
            Hi rajeysh,

            Thank's for your reply,
            I deconfigure 11gR2 Grid Infrastructure and remove relative directory or file, then reinstall grid infrastructure.
            But still meeting the same error.

            /etc/ora*
            /var/tmp/.oracle
            /u01/app/*


            [root@rac1 crs]# */u01/app/11.2.0/grid/root.sh*
            Running Oracle 11g root.sh script...

            The following environment variables are set as:
            ORACLE_OWNER= grid
            ORACLE_HOME= /u01/app/11.2.0/grid

            Enter the full pathname of the local bin directory: [usr/local/bin]:
            The file "dbhome" already exists in /usr/local/bin. Overwrite it? (y/n)
            [n]:
            The file "oraenv" already exists in /usr/local/bin. Overwrite it? (y/n)
            [n]:
            The file "coraenv" already exists in /usr/local/bin. Overwrite it? (y/n)
            [n]:


            Creating /etc/oratab file...
            Entries will be added to the /etc/oratab file as needed by
            Database Configuration Assistant when a database is created
            Finished running generic part of root.sh script.
            Now product-specific root actions will be performed.
            2012-10-23 00:23:49: Parsing the host name
            2012-10-23 00:23:49: Checking for super user privileges
            2012-10-23 00:23:49: User has super user privileges
            Using configuration parameter file: /u01/app/11.2.0/grid/crs/install/crsconfig_params
            Creating trace directory
            /u01/app/11.2.0/grid/bin/clscfg: line 133: /u01/app/11.2.0/grid/bin/clscfg.bin: No such file or directory
            /u01/app/11.2.0/grid/bin/clscfg: line 133: exec: /u01/app/11.2.0/grid/bin/clscfg.bin: cannot execute: No such file or directory
            Failed to create keys in the OLR, rc = 126, 32256
            OLR configuration failed
            [root@rac1 crs]#

            */u01/app/11.2.0/grid/log/rac1/alertrac1.log:*
            Oracle Database 11g Clusterware Release 11.2.0.1.0 - Production Copyright 1996, 2009 Oracle. All rights reserved.
            2012-10-23 00:23:50.719
            [client(648)]CRS-2106:The OLR location /u01/app/11.2.0/grid/cdata/rac1.olr is inaccessible. Details in /u01/app/11.2.0/grid/log/rac1/client/ocrconfig_648.log.
            2012-10-23 00:23:51.999
            [client(648)]CRS-2101:The OLR was formatted using version 3.
            alertrac1.log (END)


            */u01/app/11.2.0/grid/cfgtoollogs/crsconfig/rootcrs_rac1.log:*
            ....
            2012-10-23 00:23:50: Current OCR mirror loc4=
            2012-10-23 00:23:50: Current OCR mirror loc5=
            2012-10-23 00:23:50: Verifying current OCR settings with user entered values
            2012-10-23 00:23:50: Setting OCR locations in /etc/oracle/ocr.loc
            2012-10-23 00:23:50: Validating OCR locations in /etc/oracle/ocr.loc
            2012-10-23 00:23:50: Checking for existence of /etc/oracle/ocr.loc
            2012-10-23 00:23:50: Backing up /etc/oracle/ocr.loc to /etc/oracle/ocr.loc.orig
            2012-10-23 00:23:50: Setting ocr location +CRS
            2012-10-23 00:23:50: Creating or upgrading Oracle Local Registry (OLR)
            2012-10-23 00:23:52: OLR successfully created or upgraded
            2012-10-23 00:23:52: /u01/app/11.2.0/grid/bin/clscfg -localadd
            2012-10-23 00:23:52: Failed to create keys in the OLR, rc = 126, 32256
            2012-10-23 00:23:52: ###### Begin DIE Stack Trace ######
            2012-10-23 00:23:52: Package File Line Calling
            2012-10-23 00:23:52: --------------- -------------------- ---- ----------
            2012-10-23 00:23:52: 1: main rootcrs.pl 300 crsconfig_lib::dietrap
            2012-10-23 00:23:52: 2: main rootcrs.pl 427 main::__ANON__
            2012-10-23 00:23:52: ####### End DIE Stack Trace #######

            Does any one know how to resolve this error.

            Regards,
            Robert
            • 3. Re: Install Oracle11gR2 Grid Infrastructure on RedHat Enterprise Linux 5.7
              Levi Pereira
              It can be a missing RPM package.

              Please Install least Oracle Validated (RPM) to check it:

              https://oss.oracle.com/el5/oracle-validated/
              • 4. Re: Install Oracle11gR2 Grid Infrastructure on RedHat Enterprise Linux 5.7
                doginthesun
                I had the same issue a while back and found I was missing an RPM on one node.
                • 5. Re: Install Oracle11gR2 Grid Infrastructure on RedHat Enterprise Linux 5.7
                  user12220581
                  Hi Levi,

                  I pass the RPM precheck by Grid Infrastructure UI and runclufy.sh tools.
                  runcluvfy.sh stage -pre crsinst -n rac1,rac2 -verbose

                  I will study to install oracle-validate RPM on RHEL5.7.

                  Regards,
                  Robert
                  • 6. Re: Install Oracle11gR2 Grid Infrastructure on RedHat Enterprise Linux 5.7
                    Levi Pereira
                    Forget about my previous reply:

                    Use this, since you are using 11.2:

                    http://docs.oracle.com/cd/E11882_01/install.112/e22489/prelinux.htm#CWLIN172

                    Regards,
                    Levi Pereira
                    • 7. Re: Install Oracle11gR2 Grid Infrastructure on RedHat Enterprise Linux 5.7
                      user12220581
                      I can only find oracle-validated RPM on OL5.7 DVDs or Oracle Public Yum Server.
                      But I can't find oracle pre-install RPM on anyone.

                      So, I will install oracle-validated RPM and deconfig&remove GI and reinstall GI software again.

                      Regards,
                      Robert
                      • 8. Re: Install Oracle11gR2 Grid Infrastructure on RedHat Enterprise Linux 5.7
                        user12220581
                        After install oracle-validated RPM on RHEL5.7, GRUB menu appear "Oracle Linux Server (2.6.32-300.38.1.el5uek)" new selection.

                        If booting from new kernal, the server get kernal panic error.

                        If booting from original Red Hat Enterprise Linux Server (2.6.18-274.el5), and rerun root.sh.
                        I will get the same problem.

                        Regards,
                        Robert
                        • 9. Re: Install Oracle11gR2 Grid Infrastructure on RedHat Enterprise Linux 5.7
                          Levi Pereira
                          You don't need reinstall Grid Infrastructure.

                          Try this and put output here:
                          From Enterprise Linux 5 DVD
                          cd /media/cdrom/Server
                          rpm -Uvh binutils-2.*
                          rpm -Uvh compat-libstdc++-33*
                          rpm -Uvh elfutils-libelf-0.*
                          rpm -Uvh elfutils-libelf-devel-*
                          rpm -Uvh gcc-4.*
                          rpm -Uvh gcc-c++-4.*
                          rpm -Uvh glibc-2.*
                          rpm -Uvh glibc-common-2.*
                          rpm -Uvh glibc-devel-2.*
                          rpm -Uvh glibc-headers-2.*
                          rpm -Uvh ksh-2*
                          rpm -Uvh libaio-0.*
                          rpm -Uvh libaio-devel-0.*
                          rpm -Uvh libgcc-4.*
                          rpm -Uvh libstdc++-4.*
                          rpm -Uvh libstdc++-devel-4.*
                          rpm -Uvh make-3.*
                          rpm -Uvh sysstat-7.*
                          rpm -Uvh unixODBC-2.*
                          rpm -Uvh unixODBC-devel-2.*
                          Or use the "oracle-rdbms-server-11gR2-preinstall" package to perform all your prerequisite setup, follow the instructions at http://public-yum.oracle.com to setup the yum repository for OL, then perform the following command.
                          # yum install oracle-rdbms-server-11gR2-preinstall
                          All necessary prerequisites will be performed automatically.

                          Levi Pereira
                          • 10. Re: Install Oracle11gR2 Grid Infrastructure on RedHat Enterprise Linux 5.7
                            698658
                            Levi,
                            is that supported to use yum install oracle-rdbms-server-11gR2-preinstall with Red Hat 5.x and 6.x ?
                            I was pretty sure its Oracle Linux package .
                            Regards
                            GregG
                            • 11. Re: Install Oracle11gR2 Grid Infrastructure on RedHat Enterprise Linux 5.7
                              Sebastian Solbach -Dba Community-Oracle
                              Hi GregG,

                              yes this is supported. However after installing oracle-rdbms-server-11gR2-preinstall, you won't have a RHEL 6 System anymore. It will be an Oracle Linux system.
                              Oracle Linux can run with 2 different kernels. One 100% compatible to RHEL and the other the ULK kernel, only 100% compatible in userspace, but not in kernelspace.
                              Oracle-rdbms-server-11gR2-preinstall will install the ULK kernel. (I am not sure if you can supress that, and let the package only pull all other required packages and systems setting though...)

                              Btw. For RedHat 5.x the package is called oracle-validated - and this is compatible with RHEL 5 system - since the last time I checked it, it did not have a dependency on the kernel itself.

                              Regards
                              Sebastian
                              • 12. Re: Install Oracle11gR2 Grid Infrastructure on RedHat Enterprise Linux 5.7
                                Levi Pereira
                                @Sebastian: Thanks

                                @Greg :
                                See this:
                                 cat /etc/issue
                                Red Hat Enterprise Linux Server release 5.3 (Tikanga)
                                
                                # uname -r
                                2.6.18-128.1.14.el5
                                
                                
                                Using OL repos:
                                
                                # yum install oracle-validated
                                
                                Setting up Install Process
                                Parsing package install arguments
                                Resolving Dependencies
                                --> Running transaction check
                                ---> Package oracle-validated.i386 0:1.1.0-15.el5 set to be updated
                                --> Processing Dependency: util-linux >= 2.13-0.52.0.1.el5_4.1 for package: oracle-validated
                                --> Processing Dependency: irqbalance >= 2:0.55-16 for package: oracle-validated
                                --> Processing Dependency: kernel-uek >= 2.6.32 for package: oracle-validated
                                --> Processing Dependency: oraclelinux-release for package: oracle-validated
                                --> Running transaction check
                                ---> Package oraclelinux-release.i386 0:5-8.0.2 set to be updated
                                ---> Package kernel-uek.i686 0:2.6.32-300.38.1.el5uek set to be updated
                                --> Processing Dependency: kernel-firmware = 2.6.32-300.38.1.el5uek for package: kernel-uek
                                --> Processing Dependency: kexec-tools >= 1.102pre-96.1.1.el5_5.2 for package: kernel-uek
                                --> Processing Dependency: device-mapper-multipath >= 0.4.9-23.0.1.el5 for package: kernel-uek
                                --> Processing Dependency: mkinitrd >= 5.1.19.6-75.0.5 for package: kernel-uek
                                --> Processing Dependency: ql2xxx-firmware for package: kernel-uek
                                ---> Package irqbalance.i386 2:0.55-17.el5 set to be updated
                                ---> Package util-linux.i386 0:2.13-0.59.0.1.el5 set to be updated
                                --> Running transaction check
                                ---> Package kernel-uek-firmware.noarch 0:2.6.32-300.38.1.el5uek set to be updated
                                ---> Package mkinitrd.i386 0:5.1.19.6-75.0.9.el5 set to be updated
                                --> Processing Dependency: nash = 5.1.19.6-75.0.9.el5 for package: mkinitrd
                                --> Processing Dependency: kpartx >= 0.4.9 for package: mkinitrd
                                --> Processing Dependency: iscsi-initiator-utils for package: mkinitrd
                                --> Processing Dependency: hmaccalc for package: mkinitrd
                                ---> Package device-mapper-multipath.i386 0:0.4.9-46.0.5.el5 set to be updated
                                --> Processing Dependency: device-mapper-multipath-libs = 0.4.9-46.0.5.el5 for package: device-mapper-multipath
                                --> Processing Dependency: device-mapper >= 1.02.38 for package: device-mapper-multipath
                                --> Processing Dependency: libmultipath.so for package: device-mapper-multipath
                                ---> Package ql2xxx-firmware.noarch 0:1.01.01-0.2.el5 set to be updated
                                ---> Package kexec-tools.i386 0:1.102pre-154.0.3.el5_8.1 set to be updated
                                --> Running transaction check
                                ---> Package iscsi-initiator-utils.i386 0:6.2.0.872-13.0.1.el5 set to be updated
                                ---> Package hmaccalc.i386 0:0.9.6-4.el5 set to be updated
                                ---> Package nash.i386 0:5.1.19.6-75.0.9.el5 set to be updated
                                ---> Package kpartx.i386 0:0.4.9-46.0.5.el5 set to be updated
                                --> Processing Dependency: device-mapper = 1.02.28-2.el5 for package: device-mapper-event
                                ---> Package device-mapper-multipath-libs.i386 0:0.4.9-46.0.5.el5 set to be updated
                                ---> Package device-mapper.i386 0:1.02.67-2.el5 set to be updated
                                --> Running transaction check
                                ---> Package device-mapper-event.i386 0:1.02.67-2.el5 set to be updated
                                --> Processing Conflict: kernel-uek conflicts udev < 095-14.27.0.1.el5_7.1
                                --> Restarting Dependency Resolution with new changes.
                                --> Running transaction check
                                ---> Package udev.i386 0:095-14.27.0.3.el5_7.1 set to be updated
                                --> Finished Dependency Resolution
                                
                                Dependencies Resolved
                                
                                =============================================================================================================================================================
                                 Package                                         Arch                      Version                                       Repository                     Size
                                =============================================================================================================================================================
                                Installing:
                                 oracle-validated                                i386                      1.1.0-15.el5                                  el5_latest                     23 k
                                Updating:
                                 device-mapper                                   i386                      1.02.67-2.el5                                 el5_latest                    799 k
                                 device-mapper-event                             i386                      1.02.67-2.el5                                 el5_latest                     24 k
                                 device-mapper-multipath                         i386                      0.4.9-46.0.5.el5                              el5_latest                     94 k
                                 irqbalance                                      i386                      2:0.55-17.el5                                 el5_latest                     21 k
                                 kexec-tools                                     i386                      1.102pre-154.0.3.el5_8.1                      el5_latest                    585 k
                                 kpartx                                          i386                      0.4.9-46.0.5.el5                              el5_latest                    449 k
                                 mkinitrd                                        i386                      5.1.19.6-75.0.9.el5                           el5_latest                    482 k
                                 nash                                            i386                      5.1.19.6-75.0.9.el5                           el5_latest                    1.3 M
                                 udev                                            i386                      095-14.27.0.3.el5_7.1                         el5_latest                    2.4 M
                                 util-linux                                      i386                      2.13-0.59.0.1.el5                             el5_latest                    1.9 M
                                Installing for dependencies:
                                 device-mapper-multipath-libs                    i386                      0.4.9-46.0.5.el5                              el5_latest                    152 k
                                 hmaccalc                                        i386                      0.9.6-4.el5                                   el5_latest                     22 k
                                 iscsi-initiator-utils                           i386                      6.2.0.872-13.0.1.el5                          el5_latest                    1.0 M
                                 kernel-uek                                      i686                      2.6.32-300.38.1.el5uek                        el5_latest                     24 M
                                 kernel-uek-firmware                             noarch                    2.6.32-300.38.1.el5uek                        el5_latest                    3.7 M
                                 oraclelinux-release                             i386                      5-8.0.2                                       el5_latest                    2.7 k
                                 ql2xxx-firmware                                 noarch                    1.01.01-0.2.el5                               el5_latest                    442 k
                                
                                Transaction Summary
                                =============================================================================================================================================================
                                Install      8 Package(s)
                                Update      10 Package(s)
                                Remove       0 Package(s)
                                
                                Total download size: 37 M
                                Is this ok [y/N]: Y
                                Downloading Packages:
                                (1/18): oraclelinux-release-5-8.0.2.i386.rpm                                                                                          | 2.7 kB     00:00
                                (2/18): irqbalance-0.55-17.el5.i386.rpm                                                                                               |  21 kB     00:00
                                (3/18): hmaccalc-0.9.6-4.el5.i386.rpm                                                                                                 |  22 kB     00:00
                                (4/18): oracle-validated-1.1.0-15.el5.i386.rpm                                                                                        |  23 kB     00:00
                                (5/18): device-mapper-event-1.02.67-2.el5.i386.rpm                                                                                    |  24 kB     00:00
                                (6/18): device-mapper-multipath-0.4.9-46.0.5.el5.i386.rpm                                                                             |  94 kB     00:00
                                (7/18): device-mapper-multipath-libs-0.4.9-46.0.5.el5.i386.rpm                                                                        | 152 kB     00:00
                                (8/18): ql2xxx-firmware-1.01.01-0.2.el5.noarch.rpm                                                                                    | 442 kB     00:02
                                (9/18): kpartx-0.4.9-46.0.5.el5.i386.rpm                                                                                              | 449 kB     00:01
                                (10/18): mkinitrd-5.1.19.6-75.0.9.el5.i386.rpm                                                                                        | 482 kB     00:01
                                (11/18): kexec-tools-1.102pre-154.0.3.el5_8.1.i386.rpm                                                                                | 585 kB     00:01
                                (12/18): device-mapper-1.02.67-2.el5.i386.rpm                                                                                         | 799 kB     00:03
                                (13/18): iscsi-initiator-utils-6.2.0.872-13.0.1.el5.i386.rpm                                                                          | 1.0 MB     00:02
                                (14/18): nash-5.1.19.6-75.0.9.el5.i386.rpm                                                                                            | 1.3 MB     00:03
                                (15/18): util-linux-2.13-0.59.0.1.el5.i386.rpm                                                                                        | 1.9 MB     00:04
                                (16/18): udev-095-14.27.0.3.el5_7.1.i386.rpm                                                                                          | 2.4 MB     00:06
                                (17/18): kernel-uek-firmware-2.6.32-300.38.1.el5uek.noarch.rpm                                                                        | 3.7 MB     00:09
                                (18/18): kernel-uek-2.6.32-300.38.1.el5uek.i686.rpm                                                                                   |  24 MB     01:02
                                -------------------------------------------------------------------------------------------------------------------------------------------------------------
                                Total                                                                                                                        354 kB/s |  37 MB     01:48
                                warning: rpmts_HdrFromFdno: Header V4 DSA signature: NOKEY, key ID 1e5e0159
                                Importing GPG key 0x1E5E0159 "Oracle OSS group (Open Source Software group) <build@oss.oracle.com>" from http://public-yum.oracle.com/RPM-GPG-KEY-oracle-el5
                                Is this ok [y/N]: y
                                Running rpm_check_debug
                                Running Transaction Test
                                Finished Transaction Test
                                Transaction Test Succeeded
                                Running Transaction
                                  Updating       : device-mapper                                   [ 1/28]
                                  Updating       : udev                                            [ 2/28]
                                  Updating       : util-linux                                      [ 3/28]
                                  Updating       : kpartx                                          [ 4/28]
                                  Installing     : device-mapper-multipath-libs                    [ 5/28]
                                  Updating       : device-mapper-multipath                         [ 6/28]
                                  Installing     : iscsi-initiator-utils                           [ 7/28]
                                  Updating       : kexec-tools                                     [ 8/28]
                                  Updating       : irqbalance                                      [ 9/28]
                                  Installing     : hmaccalc                                        [10/28]
                                  Updating       : device-mapper-event                             [11/28]
                                  Installing     : oraclelinux-release                             [12/28]
                                  Installing     : ql2xxx-firmware                                 [13/28]
                                  Updating       : nash                                            [14/28]
                                  Installing     : kernel-uek-firmware                             [15/28]
                                  Updating       : mkinitrd                                        [16/28]
                                  Installing     : kernel-uek                                      [17/28]
                                  Installing     : oracle-validated                                [18/28]
                                  Cleanup        : util-linux                                      [19/28]
                                  Cleanup        : device-mapper                                   [20/28]
                                  Cleanup        : irqbalance                                      [21/28]
                                  Cleanup        : device-mapper-multipath                         [22/28]
                                  Cleanup        : kexec-tools                                     [23/28]
                                  Cleanup        : kpartx                                          [24/28]
                                  Cleanup        : nash                                            [25/28]
                                  Cleanup        : device-mapper-event                             [26/28]
                                  Cleanup        : udev                                            [27/28]
                                  Cleanup        : mkinitrd                                        [28/28]
                                
                                Installed: oracle-validated.i386 0:1.1.0-15.el5
                                Dependency Installed: device-mapper-multipath-libs.i386 0:0.4.9-46.0.5.el5 hmaccalc.i386 0:0.9.6-4.el5 iscsi-initiator-utils.i386 0:6.2.0.872-13.0.1.el5 kernel-uek.i686 0:2.6.32-300.38.1.el5uek kernel-uek-firmware.noarch 0:2.6.32-300.38.1.el5uek oraclelinux-release.i386 0:5-8.0.2 ql2xxx-firmware.noarch 0:1.01.01-0.2.el5
                                Updated: device-mapper.i386 0:1.02.67-2.el5 device-mapper-event.i386 0:1.02.67-2.el5 device-mapper-multipath.i386 0:0.4.9-46.0.5.el5 irqbalance.i386 2:0.55-17.el5 kexec-tools.i386 0:1.102pre-154.0.3.el5_8.1 kpartx.i386 0:0.4.9-46.0.5.el5 mkinitrd.i386 0:5.1.19.6-75.0.9.el5 nash.i386 0:5.1.19.6-75.0.9.el5 udev.i386 0:095-14.27.0.3.el5_7.1 util-linux.i386 0:2.13-0.59.0.1.el5
                                Complete!
                                [root@rhel5 yum.repos.d]# oracle-validated-verify