2 Replies Latest reply: Feb 14, 2013 9:45 AM by maryc RSS

    diskinfo -a command not listing the newly added disk

    954225
      Hi,

      I replaced an internal disk on my T4-1 box. After the replacement, I am able to find the disk listed in:
      echo | format
      cfgadm -al
      df -hk (have mounted a file system on this new disk)

      But the issue is that I am unable to find the disk getting listed in the diskinfo -a output.
      Please suggest what needs to be done.

      # cfgadm -al
      ....
      ....
      c9::w5000cca012c4ec8d,0 disk-path connected configured unknown
      c10 scsi-sas connected configured unknown
      c10::w5000cca012b4d099,0 disk-path connected configured unknown
      c10::w5000cca012c99be5,0 disk-path connected unconfigured unknown
      c11 scsi-sas connected configured unknown
      c11::w5000cca012d20555,0 disk-path connected configured unknown
      .....


      bash-3.2# echo | format
      Searching for disks...done


      AVAILABLE DISK SELECTIONS:
      0. c0t5000CCA012B4D098d0 <LSI-MR9261-8i-2.12 cyl 65533 alt 2 hd 287 sec 31> solaris
      /scsi_vhci/disk@g5000cca012b4d098
      1. c0t5000CCA012C4EC8Cd0 <LSI-MR9261-8i-2.12 cyl 65533 alt 2 hd 287 sec 31> solaris
      /scsi_vhci/disk@g5000cca012c4ec8c
      2. c0t5000CCA012C9AA14d0 <LSI-MR9261-8i-2.12 cyl 65533 alt 2 hd 287 sec 31> solaris
      /scsi_vhci/disk@g5000cca012c9aa14
      3. c0t5000CCA012D20554d0 <LSI-MR9261-8i-2.12 cyl 65533 alt 2 hd 287 sec 31> solaris
      /scsi_vhci/disk@g5000cca012d20554
      4. c0t60080E50002499E60000039B504D627Fd0 <SUN-LCSM100_S-0780 cyl 38398 alt 2 hd 256 sec 64>
      /scsi_vhci/disk@g60080e50002499e60000039b504d627f
      5. c0t60080E50002499E60000039E504D62ABd0 <SUN-LCSM100_S-0780 cyl 38398 alt 2 hd 256 sec 64>
      /scsi_vhci/disk@g60080e50002499e60000039e504d62ab
      6. c1t50080E52499E6000d31 <SUN-UniversalXport-0777 cyl 8 alt 2 hd 64 sec 64>
      /pci@400/pci@1/pci@0/pci@8/LSI,sas@0/iport@f/disk@w50080e52499e6000,1f
      7. c3t50080E5249EC8000d31 <SUN-UniversalXport-0777 cyl 8 alt 2 hd 64 sec 64>
      /pci@400/pci@2/pci@0/pci@8/LSI,sas@0/iport@f/disk@w50080e5249ec8000,1f
      Specify disk (enter its number): Specify disk (enter its number):
      bash-3.2#




      bash-3.2# diskinfo -a


      Enclosure path: 1203BD02DA-physical-hba-1
      Chassis Serial Number: 1203BD02DA-physical-hba-1
      Chassis Model: ORCL,Netra-SPARC-T4-1

      Label Disk name Vendor Product Vers
      ---------- ---------------------- -------- ---------------- ----
      /SYS/HDD0 c0t5000CCA012C9AA14d0 HITACHI H106030SDSUN300G A2B0
      /SYS/HDD1 c0t5000CCA012C4EC8Cd0 HITACHI H106030SDSUN300G A2B0
      /SYS/HDD3 c0t5000CCA012D20554d0 HITACHI H106030SDSUN300G A2B0

      bash-3.2#




      Seems like the issue will get resolved if I can remove the old entry of the disk in the cfgadm -al output.
      But in our setup we can not use the luxadm command to make the disk unused.
      So please suggest any alternative way to remove the extra entry (old disk's):

      # cfgadm -la | grep “c10::”
      c10::w5000cca012b4d099,0 disk-path connected configured unknown
      c10::w5000cca012c99be5,0 disk-path connected unconfigured unknown
      #


      After reboot:

      Output after reboot:
      # cfgadm -al | grep “c10::”
      c10::w5000cca012b4d099,0 disk-path connected configured unknown
      #

      Edited by: 951222 on Oct 23, 2012 4:57 AM