4 Replies Latest reply: Nov 8, 2012 4:56 PM by user12163570 RSS

    Re: Solaris 11 install freeze


      I am experincing issue with solaris 11-1111. I am trying to install on an HP elitebook 8770w with intel i7 processor with dual 750gb dirves /dev/sda & /dev/sdb. the configuration is for a dual boot windows and Solaris. I Don't want to run solaris in parrallels (that will just be funky)

      The installs both LiveCD and text .iso hang after the SunOS copyright display with message probing device nodes -- remounting root r/w. I have tried several edits to Grub command lines with with -B install_media=/dev/sr0 etc. with no luck.

      Any ideas how to get past this problem.

      There is nothing wrong with the hardward. I was able to install Solaris 10 on a similarly configured hardware. I want to upgrade all the solaris 10 boxes to solaris 11

      Any suggestions will be appreciated.
        • 1. Re: Solaris 11 install freeze
          If you have ruled out the obvious problems, such as whether this system is supported on S11 (check the HCL) and
          also that this system is 64-bit. You could try a few things to debug the install session.

          See below.

          Thanks, Cindy

          1. Boot from the media or install server without the -install keyword using whatever GRUB option is appropriate.


          2. Step 1 should drop you to a menu of choices. Select 3, shell.

          3. If this is a hanging device problem, then see if the devices are recognized:

          # /usr/sbin/croinfo -h -O cAR

          However, this command is not supported on all hardware, but if it returns your device info, then that's a good sign.

          An alternative is to see if format recognizes your devices:

          # format

          4. You can run the text installer in debug mode and that should give some clues as to what is going on before the
          hang, if possible:

          # /usr/bin//usr/sbin/text-install -d

          Check the /system/volatile/install_log.
          • 2. Re: Solaris 11 install freeze
            I tried you suggestions below. Still didn't work

            It appears that Solaris !! didn't quite boot yet, as there was nothing in logs. Install_log is does not exist, Syslog is empty. Also there is no /usr/bin/croinfo, and usr/sbin/tes-install. fdisk and format non exist yet. so me thinks solaris didn't get past devece checkingg

            I tried boot grub to single user mode (-s after kernel) still no luck. Grub version is version 1.99. Solaris 10, and open suse 12.2, windows 7 all boot and installed fine. Is there anything specific to Solaris 11 that is not in Solaris 10.

            Also graphics chip is Nvidia K5000M, intel i7, 32GB memory, solaris partition on /dev/sdb1 300GB.

            Anything I can do to modify grub for force a boot? I have tried _B acpi=off, -B nouveau.modeset=0

            I tried install on elitebook 8560w works fine. :(
            • 3. Re: Solaris 11 install freeze
              Dave Miner-Oracle
              This is almost certainly a device initialization or module loading problem related to the specific system devices. There are two things you can try. First one is adding a -v option to the kernel boot line from GRUB. This will add some verbose output that may include clues. The second is to turn on module load debugging as described in the old blog post at https://blogs.oracle.com/dmick/entry/diagnosing_kernel_hangs_panics_with. Usually the last message you see will identify a device that's causing the issue and the BIOS may provide options to change that device's behavior in some way that will make it behave better with Solaris.
              • 4. Re: Solaris 11 install freeze
                I had the same problem. In the BIOS I had to disable Intel VT for Directed I/O (VT-d). If you read the 11.1 release notes, there is reference to this and how to fix it once the OS is installed.