This discussion is archived
4 Replies Latest reply: Oct 28, 2012 4:03 PM by Jan_Z RSS

missing bash utilities on OracleLinux 6.3

Jan_Z Newbie
Currently Being Moderated
Hi,
is it just me or the OracleLinux 6.3 comes with missing bash utilities : I do find basename but no dirname ?

Regards,
JanZ
  • 1. Re: missing bash utilities on OracleLinux 6.3
    Dude! Guru
    Currently Being Moderated
    /usr/bin/dirname and /bin/basename are part of the default Server installation and installed by the coreutils package. I suggest to verify the file exist and that you have a valid $PATH environment variable.
  • 2. Re: missing bash utilities on OracleLinux 6.3
    Jan_Z Newbie
    Currently Being Moderated
    Hi ,
    that's what I'd expect, but :

    $ rpm -aq | grep coreutils
    coreutils-8.4-19.el6.x86_64
    policycoreutils-2.0.83-19.24.0.1.el6.x86_64
    coreutils-libs-8.4-19.el6.x86_64
    $ echo $PATH
    +/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/jan/bin+
    $ which dirname
    /usr/bin/which: no dirname in (/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/jan/bin)
    $ which basename
    +/bin/basename+

    Edited by: user12228107 on Oct 28, 2012 7:24 AM
  • 3. Re: missing bash utilities on OracleLinux 6.3
    Avi Miller Guru
    Currently Being Moderated
    Jan_Z wrote:
    that's what I'd expect, but :
    Something is wrong with your install because it's fine on mine:
    $ rpm -qa | grep coreutils
    coreutils-8.4-19.el6.x86_64
    policycoreutils-2.0.83-19.24.0.1.el6.x86_64
    coreutils-libs-8.4-19.el6.x86_64
    
    $ echo $PATH
    /usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/amiller/bin
    
    $ which basename
    /bin/basename
    
    $ which dirname
    /usr/bin/dirname
  • 4. Re: missing bash utilities on OracleLinux 6.3
    Jan_Z Newbie
    Currently Being Moderated
    Avi Miller wrote:
    Jan_Z wrote:
    that's what I'd expect, but :
    Something is wrong with your install because it's fine on mine:
    yeap, somthing went wrong, though never saw a warning or message.
    # rpm -Uvh --allfiles coreutils-8.4-19.el6.x86_64.rpm
    Preparing... ########################################### [100%]
         package coreutils-8.4-19.el6.x86_64 is already installed
    # rpm -Uvh --force coreutils-8.4-19.el6.x86_64.rpm
    Preparing... ########################################### [100%]
    1:coreutils ########################################### [100%]
    # which dirname
    /usr/bin/dirname
    So, got back on the track , but very wierd. Hope that's the only screw up.
    Regards

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points