1 2 Previous Next 23 Replies Latest reply on Aug 13, 2013 6:23 AM by Vijay89 Go to original post
      • 15. Re: Oracle Guided Endeca Guided Search - ENEConnectionException

        Ok - when you installed Platform Services you didn't tell it which directory MDEX was installed in.

        I think you can fix this by editing your endeca\platformservices\workspace\conf\eac.properties file and set


        (but validate that the path you put there is the actual path to your MDEX install)

        Edited by: TimK on Oct 28, 2012 3:12 AM
        • 16. Re: Oracle Guided Endeca Guided Search - ENEConnectionException
          The copy/paste was bad on that last one - the entry should look like:


          Edited by: TimK on Oct 28, 2012 3:18 AM
          • 17. Re: Oracle Guided Endeca Guided Search - ENEConnectionException
            So, here is the entry which seems perfectly fine.


            Getting the below exception when running baseline_update.bat:

            [10.28.12 15:55:02] SEVERE: Error communicating with EAC agent while starting co
            Occurred while executing line 32 of valid BeanShell script:

            29| Forge.archiveLogDir();
            30| Forge.run();
            31| Dgidx.archiveLogDir();
            32| Dgidx.run();
            34| // distributed index, update Dgraphs
            35| DistributeIndexAndApply.run();


            [10.28.12 15:55:02] SEVERE: Caught an exception while invoking method 'run' on o
            bject 'BaselineUpdate'. Releasing locks.

            Caused by java.lang.reflect.InvocationTargetException
            sun.reflect.NativeMethodAccessorImpl invoke0 - null
            Caused by com.endeca.soleng.eac.toolkit.exception.AppControlException
            com.endeca.soleng.eac.toolkit.script.Script runBeanShellScript - Error executing
            valid BeanShell script.
            Caused by com.endeca.soleng.eac.toolkit.exception.EacCommunicationException
            com.endeca.soleng.eac.toolkit.component.Component start - Error communicating wi
            th EAC agent while starting component.
            Caused by com.endeca.eac.client.EACFault
            sun.reflect.NativeConstructorAccessorImpl newInstance0 - null

            [10.28.12 15:55:02] INFO: Released lock 'update_lock'.
            • 18. Re: Oracle Guided Endeca Guided Search - ENEConnectionException
              Girish V U
              Hi Sachin,

              I assume you are doing this with CRS application (as in integration of CRS with endeca) and not with the reference application (Discover).

              If this is the case ,run baseline update thru http://localhost:8080/dyn/admin/nucleus//atg/endeca/index/commerce/ProductCatalogSimpleIndexingAdmin/ component .(This should solve ur ENEException)

              Also ,Once all of your changes on guided search are done , execute promotecontent.bat

              Let me know you have any issues.

              • 19. Re: Oracle Guided Endeca Guided Search - ENEConnectionException
                Hey Girish,

                I can't use the approach suggested by you as I dont have ATG installed on my machine. Can't use admin browser or ACC.

                Sachin Kakkar
                • 20. Re: Oracle Guided Endeca Guided Search - ENEConnectionException
                  Gopinath Ramasamy

                  Hi Sachin,


                  Did you find a solution to this issue?


                  I am struck exactly with this exception. Still my ENEConnectionException in the reference application exists.


                  Please help.



                  Gopinath Ramasamy

                  • 21. Re: Oracle Guided Endeca Guided Search - ENEConnectionException



                    Can you please check if index files present in your dgraph directory under dgraph_input directory? If no then baseline is not completed. if index files not present under dgraph_input directory then dgraph never starts.



                    If baseline is failed with reference of ENDECA_MDEX_ROOT in logs then this might something to do with environment variables.


                    if so then need to set mdex root in environment variables.


                    If you are using windows machine, then add environment variables in your machine.


                    if you are using linux machine, then switch to endeca user if you have created one and try once. if not worked then before executing baseline run following commands and try once. these commands sets all environment variables required for endeca:


                    source <platform installation directory>/PlatformServices/workspace/setup/installer_sh.ini

                    source <mdex installation directory>/MDEX/<mdex version>/mdex_setup_sh.ini

                    source <workbench installation directory>/Workbench/workspace/setup/installer_sh.ini



                    But from log shared looks eac.properties pointing to invalid ENDECA_MDEX_ROOT path:


                    Please confirm if mdex is installed properly. if yes then set its path till correct version number in eac.properties file. restart endeca services and try once executing baseline. please share logs if still getting exception in execution.




                    • 22. Re: Oracle Guided Endeca Guided Search - ENEConnectionException
                      Gopinath Ramasamy

                      Hi Vijay,


                      Thanks for your reply.


                      I set up all environments variables correct.


                      I tried running the initializing data and running baseline update multiple times and it worked.


                      Now I can see the workbench. But I am not able to completely explore and play with the reference application as I am using Windows 8 Developer Preview OS and Endeca does not support it as of now.



                      Gopinath Ramasamy

                      • 23. Re: Oracle Guided Endeca Guided Search - ENEConnectionException

                        Hi Gopinath,


                        if you are able to install and run baseline successfully means, your os is supporting endeca. there should not be any problem to access ref application.


                        have you tried to connect it:


                        if same machine:



                        if remote machine:



                        for confirmation, log in into workbench--> select you application --> select eac admin console --> and check status of dgraph


                        if status is running then you are good to go.

                        if status is stop then click on start to start it.

                        if status is failed then check dgraph logs. you will see whats it is causing to fail.




                        1 2 Previous Next