This discussion is archived
5 Replies Latest reply: Oct 29, 2012 7:10 PM by Avi Miller RSS

Missing libfreebl3.so & libc.so.6

57797 Newbie
Currently Being Moderated
I'm trying to install RAC on Oracle Linux R6U3 (64bit). There are a number of missing RPMs that I'm trying to load. But I'm getting error messages saying that libfreebl3.so & libc.so.6 are missing. What package should I be loading to solve this problem?

Thanks
Jim

[root@vbox3 Packages]# rpm -Uvh glibc-2.12-1.80.el6.i686.rpm glibc-2.12-1.80.el6.x86_64.rpm glibc-common-2.12-1.80.el6.x86_64.rpm
error: Failed dependencies:
libfreebl3.so is needed by glibc-2.12-1.80.el6.i686
libfreebl3.so(NSSRAWHASH_3.12.3) is needed by glibc-2.12-1.80.el6.i686
glibc = 2.12-1.80.el6_3.5 is needed by (installed) glibc-headers-2.12-1.80.el6_3.5.x86_64
glibc = 2.12-1.80.el6_3.5 is needed by (installed) glibc-devel-2.12-1.80.el6_3.5.x86_64



[root@vbox3 Packages]# rpm -Uvh compat-libstdc++-33-3.2.3-69.el6.i686.rpm compat-libstdc++-33-3.2.3-69.el6.x86_64.rpm
error: Failed dependencies:
libc.so.6 is needed by compat-libstdc++-33-3.2.3-69.el6.i686
libc.so.6(GLIBC_2.0) is needed by compat-libstdc++-33-3.2.3-69.el6.i686
libc.so.6(GLIBC_2.1) is needed by compat-libstdc++-33-3.2.3-69.el6.i686
libc.so.6(GLIBC_2.1.3) is needed by compat-libstdc++-33-3.2.3-69.el6.i686
libc.so.6(GLIBC_2.2) is needed by compat-libstdc++-33-3.2.3-69.el6.i686
libc.so.6(GLIBC_2.3) is needed by compat-libstdc++-33-3.2.3-69.el6.i686
libm.so.6 is needed by compat-libstdc++-33-3.2.3-69.el6.i686



[root@vbox3 Packages]# rpm -Uvh unixODBC-2.2.14-11.el6.i686.rpm unixODBC-2.2.14-11.el6.x86_64.rpm unixODBC-devel-2.2.14-11.el6.i686.rpm unixODBC-devel-2.2.14-11.el6.x86_64.rpm
error: Failed dependencies:
libc.so.6 is needed by unixODBC-2.2.14-11.el6.i686
libc.so.6(GLIBC_2.0) is needed by unixODBC-2.2.14-11.el6.i686
libc.so.6(GLIBC_2.1) is needed by unixODBC-2.2.14-11.el6.i686
libc.so.6(GLIBC_2.1.3) is needed by unixODBC-2.2.14-11.el6.i686
libc.so.6(GLIBC_2.3) is needed by unixODBC-2.2.14-11.el6.i686
libc.so.6(GLIBC_2.3.4) is needed by unixODBC-2.2.14-11.el6.i686
libc.so.6(GLIBC_2.4) is needed by unixODBC-2.2.14-11.el6.i686
libc.so.6(GLIBC_2.7) is needed by unixODBC-2.2.14-11.el6.i686
libltdl.so.7 is needed by unixODBC-2.2.14-11.el6.i686
libpthread.so.0 is needed by unixODBC-2.2.14-11.el6.i686
libpthread.so.0(GLIBC_2.0) is needed by unixODBC-2.2.14-11.el6.i686
libreadline.so.6 is needed by unixODBC-2.2.14-11.el6.i686
  • 1. Re: Missing libfreebl3.so & libc.so.6
    Avi Miller Guru
    Currently Being Moderated
    jfraley wrote:
    I'm trying to install RAC on Oracle Linux R6U3 (64bit).
    Stop using RPM and use yum instead. It'll pull all the dependencies in for you. In fact, on OL6U3, if you use yum to install oracle-rdbms-server-11gR2-preinstall from http://public-yum.oracle.com it'll install everything and configure it ready for a RAC/DB instead.
  • 2. Re: Missing libfreebl3.so & libc.so.6
    57797 Newbie
    Currently Being Moderated
    Ok, I tried yum...still no success.  OUI says that I'm missing: libaio-0.3.105 compat-libstdc++-33-3.2.3 libaio-devel-0.3.105 libgcc-3.4.6 libstdc++-3.4.6 unixODBC-2.2.11 unixODBC-devel-2.2.11 pdksh-5.2.14

    First I tried to install the list packages with yum with the code below.  No luck.

    [root@vbox4 yum.repos.d]# yum install libaio-0.3.105 compat-libstdc++-33-3.2.3 libaio-devel-0.3.105 libgcc-3.4.6 libstdc++-3.4.6 unixODBC-2.2.11 unixODBC-devel-2.2.11 pdksh-5.2.14
    Loaded plugins: refresh-packagekit, security
    Setting up Install Process
    Package compat-libstdc++-33-3.2.3-69.el6.x86_64 already installed and latest version
    No package libaio-0.3.105 available.
    No package libaio-devel-0.3.105 available.
    No package libgcc-3.4.6 available.
    No package libstdc++-3.4.6 available.
    No package unixODBC-2.2.11 available.
    No package unixODBC-devel-2.2.11 available.
    No package pdksh-5.2.14 available.
    Nothing to do

    So, then I search yum for any candidates that might work and I end up with the code below.  When I run it, yum declares it has "Nothing to do".  But, OUI still says that the packages are missing.  And, yum has no knowledge of pdksh-5.2.14.

    [root@vbox3 yum.repos.d]# yum install compat-libstdc++-296.i686 compat-libstdc++-33.i686 compat-libstdc++-33.x86_64 libaio.i686 libaio.x86_64 libaio-devel.x86_64 libaio-devel.i686 libgcc.i686 libgcc.x86_64 compat-libstdc++-296.i686 compat-libstdc++-33.i686 compat-libstdc++-33.x86_64 libstdc++.x86_64 libstdc++-devel.x86_64 libstdc++.i686 libstdc++-devel.i686 libstdc++-docs.x86_64 unixODBC.i686 unixODBC.x86_64 unixODBC-devel.i686 unixODBC-devel.x86_64 freeradius-unixODBC.x86_64 unixODBC-kde.i686 unixODBC-kde.x86_64
    Loaded plugins: refresh-packagekit, security
    Setting up Install Process
    Package compat-libstdc++-296-2.96-144.el6.i686 already installed and latest version
    Package compat-libstdc++-33-3.2.3-69.el6.i686 already installed and latest version
    Package compat-libstdc++-33-3.2.3-69.el6.x86_64 already installed and latest version
    Package libaio-0.3.107-10.el6.i686 already installed and latest version
    Package libaio-0.3.107-10.el6.x86_64 already installed and latest version
    Package libaio-devel-0.3.107-10.el6.x86_64 already installed and latest version
    Package libaio-devel-0.3.107-10.el6.i686 already installed and latest version
    Package libgcc-4.4.6-4.el6.i686 already installed and latest version
    Package libgcc-4.4.6-4.el6.x86_64 already installed and latest version
    Package compat-libstdc++-296-2.96-144.el6.i686 already installed and latest version
    Package compat-libstdc++-33-3.2.3-69.el6.i686 already installed and latest version
    Package compat-libstdc++-33-3.2.3-69.el6.x86_64 already installed and latest version
    Package libstdc++-4.4.6-4.el6.x86_64 already installed and latest version
    Package libstdc++-devel-4.4.6-4.el6.x86_64 already installed and latest version
    Package libstdc++-4.4.6-4.el6.i686 already installed and latest version
    Package libstdc++-devel-4.4.6-4.el6.i686 already installed and latest version
    Package libstdc++-docs-4.4.6-4.el6.x86_64 already installed and latest version
    Package unixODBC-2.2.14-11.el6.i686 already installed and latest version
    Package unixODBC-2.2.14-11.el6.x86_64 already installed and latest version
    Package unixODBC-devel-2.2.14-11.el6.i686 already installed and latest version
    Package unixODBC-devel-2.2.14-11.el6.x86_64 already installed and latest version
    Package freeradius-unixODBC-2.1.12-4.el6_3.x86_64 already installed and latest version
    Package unixODBC-kde-2.2.14-11.el6.i686 already installed and latest version
    Package unixODBC-kde-2.2.14-11.el6.x86_64 already installed and latest version
    Nothing to do

    Any suggestions?

    Thank you
    Jim
  • 3. Re: Missing libfreebl3.so & libc.so.6
    Avi Miller Guru
    Currently Being Moderated
    jfraley wrote:
    Any suggestions?
     # yum install oracle-rdbms-server-11gR2-preinstall
  • 4. Re: Missing libfreebl3.so & libc.so.6
    57797 Newbie
    Currently Being Moderated
    In the above, I neglicted to say that I also tried to install oracle-rdbms-server-11gR2-preinstall. Same results as the other attempts:

    [root@vbox3 yum.repos.d]# yum install oracle-rdbms-server-11gR2-preinstall
    Loaded plugins: refresh-packagekit, security
    Setting up Install Process
    Package oracle-rdbms-server-11gR2-preinstall-1.0-6.el6.x86_64 already installed and latest version
    Nothing to do

    Still looking for any suggestions.

    Thanks
    Jim
  • 5. Re: Missing libfreebl3.so & libc.so.6
    Avi Miller Guru
    Currently Being Moderated
    jfraley wrote:
    In the above, I neglicted to say that I also tried to install oracle-rdbms-server-11gR2-preinstall. Same results as the other attempts:
    Then you're not installing a version of GI/RAC that is certified on OL6U3. You need to use 11.2.0.3 or higher. Anything else will not pass the pre-requisite checks.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points