This discussion is archived
2 Replies Latest reply: Oct 31, 2012 9:12 AM by 962882 RSS

non-secure OS, can't install new versions [ This version is excluded ]

user553032 Newbie
Currently Being Moderated
I had apache2 enabled in a zone and installed php52 on top of it. this worked well ast week.

Then someone needed php53, so i deinstalled php-52 and accompying products.

I tried to install php-53 but it complained about a blocked reference

Creating Plan /
pkg install: No matching version of web/php-53 can be installed:
Reject: pkg://solaris/web/php-53@5.3.14,5.11-0.175.1.0.0.24.0:20120904T174930Z
Reason: All versions matching 'require' dependency pkg:/system/linker@0.5.11,5.11-0.175.1.0.0.23.0 are rejected
Reject: pkg://solaris/system/linker@0.5.11,5.11-0.175.1.0.0.24.2:20120919T185204Z
Reason: This version is excluded by installed incorporation pkg://solaris/consolidation/osnet/osnet-incorporation@0.5.11,5.11-0.175.0.12.0.4.1:20121002T155703Z

At first i thought i needed to update the Solaris 11 core, so i updated all the OS. I rebooted and tried again, but the same error persists.

I searched for the error and found little info about it. someone mentions that you need a support contract, but WE DO HAVE A CONTRACT!

I tried to get back to php-52, but now also apache-php52 package complains about this so i'm lost completely.

Does anyone know how to solve this?

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points