1 Reply Latest reply on Oct 30, 2012 9:40 AM by Helios-GunesEROL

    Unable to connect SQLState=08004 Oracle ODBC Ora-12154

      Hi Sir/Madam,
      I am Wayne, I need your help to resolve my issue in oracle database 11g.
      1. I installed Oracle 11g Personal Edition, Release, 64bits,
      2. Test connection(oracle in oradb11g_home1) is successed in data source, odbc,
      2. Then, I tried to connect this with Visual Basic(Visual Studio 2010), data connections, add connections, .net framework data provider for oracle,
      3. but I received an error message as "Attempt to load Oracle client libraries threw BadImageFormatException."
      4. Then, I download the ODAC( for 64bits, and installed,
      5. I tried to test the connection, but failed with error message as stated above,
      "Unable to connect SQLState=08004 Oracle ODBC Ora-12154: TNS:could not resolve the connect identifier specified"

      Could you please give me a help on this, do I need to install ODAC for 11g Personal Edition ? Please advice accordingly, thanks.