This discussion is archived
5 Replies Latest reply: Oct 31, 2012 8:12 AM by Udo RSS

Blank login screen Apex 4.2

Wejohnson Newbie
Currently Being Moderated
I have installed Oracle 11gR2, Apex 4.2, Glassfish 3.1.2, and Apex Listener 2.0

I get the blank login screen now when hitting http://server:8080/apex

I have copied the images directory from $ORACLE_HOME/apex/images to /u01/app/glassfish3/glassfish/domains/domain1/docroot/i.

I have also followed the instructions in the APEX Listener 2.0 install guide to create and deploy the i.war.

However, I still get a blank login screen. The page is not blank, for if I view source, there is plenty there.

I have imported a bunch of apps from our 4.1 APEX environment, and if I hit one of those apps directly, such as http://server:8080/apex/f?=100, the app does come up. So this seems to be something specific to the login screen.

Any help getting past this would be greatly appreciated.

Bill
  • 1. Re: Blank login screen Apex 4.2
    Udo Guru
    Currently Being Moderated
    Hi Bill,
    I have copied the images directory from $ORACLE_HOME/apex/images to /u01/app/glassfish3/glassfish/domains/domain1/docroot/i.
    Are you sure these are the images that belong to APEX 4.2? If not, this would explain why you see a blank page with "hidden" content in it...
    Try to look up a file named "apex_version.txt" in +/u01/app/glassfish3/glassfish/domains/domain1/docroot/i+ or even call it through your GlassFish and see the response: http://server:8080/i/apex_version.txt
    If it's not 4.2, just copy the images from your APEX 4.2 installation package instead and everything should work as expected.

    -Udo
  • 2. Re: Blank login screen Apex 4.2
    Wejohnson Newbie
    Currently Being Moderated
    Excellent. Thanks for the quick response. Here is what I've found.

    The images directory has no apex_version.txt in it. Since I've been fairly certain my images were the problem, I've repeated the steps to copy them several times I have, therefore, and i_OLD folder, which was the first iteration of my efforts, and that folder contains an apex_version.txt that indicates 4.1.1.

    Obviously, I have the wrong images folder both under $ORACLE_HOME/apex, and also under docroot/i.

    I installed Apex 4.2 from p14777994_420_Generic.zip, if memory serves. I'm looking at the files included in that, and I can't find the images directory that I would have originally copied. Does the install automatically update the $ORACLE_HOME/apex/images directory (I was upgrading from 3.2 to 4.2) during the upgrade, or is there a step to copy them from the patch directories to $ORACLE_HOME/apex? If so, I don't see that step.

    What am I missing?
  • 3. Re: Blank login screen Apex 4.2
    Wejohnson Newbie
    Currently Being Moderated
    OK... now that I've had my coffee I'm reviewing this and realized somethings. I don't know where I got that patch p14777994_420_Generic.zip. It is not listed on the Apex downloads page, where the normal APEX_4.2.zip file is shown. I can't find that file on my server, so now I'm uncertain WHAT I installed from. I had an Evernote disaster a couple of days ago which wiped out all my notes for this project, so I'm trying to figure out what I've down from memory.

    I'm thinking I need to reinstall APEX 4.2 from the correct install media, just to be sure. Can I just reinstall overtop of whatever I've currently got installed?
  • 4. Re: Blank login screen Apex 4.2
    Wejohnson Newbie
    Currently Being Moderated
    My stupidity knows no bounds. I reinstalled correctly, and this is working now.
  • 5. Re: Blank login screen Apex 4.2
    Udo Guru
    Currently Being Moderated
    Does the install automatically update the $ORACLE_HOME/apex/images directory
    No. You need to do this manually.
    Just a side note: This location is usually used for the images that correspond to the APEX version that shipped with your database. Of course, you can reuse it to store them after an update, but unless the web server that hosts your APEX is somehow linked to that directory, you won't need these images there.
    I don't know where I got that patch p14777994_420_Generic.zip.
    Sounds like a (modified) version of what you get on support.oracle.com ("Metalink"). modified because usually the official patch packages also contain the images, at least if the patch is an upgrade package.
    I reinstalled correctly, and this is working now.
    Great to hear that! Have fun with APEX 4.2 using APEX Listener!

    -Udo

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points