1 2 3 Previous Next 40 Replies Latest reply on Jan 10, 2013 12:43 PM by rukbat Go to original post
      • 15. Re: iSCSI Broken after 11.1 Update
        issues with the comstar target not allow other systems besides solaris to read/write to it, not the solaris iscsi initiator

        Edited by: 969376 on Nov 6, 2012 5:47 PM
        • 16. Re: iSCSI Broken after 11.1 Update
          A workaround is temporary until the fix can be made available.

          Two Solaris 11.1 issues are impacting iSCSI initiator configurations:

          1. Bug 15823698 means that when data is written or accessed on
          a Linux initiator, it will hang. The workaround is to disable the
          "immediate data" parameter, like this:

          A. Disable immediate data, like this:

          # iscsiadm -m node -T ${IQN} -p ${IP}:${PORT},${TPGT} -o update -n node.session.iscsi.ImmediateData -v No

          B. Restart the iSCSI service:

          # svcadm restart svc:/network/iscsi/initiator:default

          B. Bug 15842864 impacts Solaris initiators that are upgraded to Solaris 11.1. I missed this in my testing
          because I only upgraded the Solaris iSCSI target system. My iSCSI initiator was already running S11.1.
          The symptom is that any iSCSI operation on the Solaris 11.1 initiator fails like this:

          iscsiadm: unexpected OS error
          iscsiadm: Unable to complete operation

          The workaround is to remove the iSCSI configuration files in /etc/iscsi and reboot.

          Even better is to not upgrade your iSCSI initiators to S11.1 until a fix for 15842864 is available.

          I suggest filing a support request for either of these fixes.

          Thanks, Cindy
          • 17. Re: iSCSI Broken after 11.1 Update
            Hi Cindy,

            I try your workaround on ESXi 5.1 and Windows 7 SP1 client.

            On Windows 7 SP1, modify registry, set ImmediateData to 0, reboot -> works.

            On ESXi 5.1, Disable ImmediateData (uncheck it), -> nothing change.

            Need to dig more on ESXi.


            Edited by: user6951419 on Nov 7, 2012 11:06 PM
            • 18. Re: iSCSI Broken after 11.1 Update
              HKLM\SYSTEM\CurrentControlSet\Control\Class\{4D36E97B-E325-11CE-BFC1-08002BE10318}\<Instance Number>\Parameters\ImmediateData

              changed to 0 worked for me (server 2008 r2)

              esxi 5.1 this option is greyed out on the on state

              why do we need to tweak the other initiators when only thing that has change is solaris?
              • 19. Re: iSCSI Broken after 11.1 Update
                IMHO this is because Immediate Data is broken in Solaris 11.1 currently, so you have to disable it. An update probably will fix it, so you can turn it back on after applying the patch to target.
                • 20. Re: iSCSI Broken after 11.1 Update
                  After a few days, there is not patch available. I dig more in ESXi, finally I make esxi 5.1 works.

                  Simply just disable ImmediateData. but since this options cannot uncheck directly from UI, you have to hack the vmkiscsid.db file.

                  if you want to do it, just follow the method here: (make backup first!)


                  • 21. Re: iSCSI Broken after 11.1 Update
                    which table is it?

                    i updated nodes, target and initiatornodes
                    it's still not working
                    • 22. Re: iSCSI Broken after 11.1 Update
                      I change all table that can found the ImmediateData, seems nodes tables is the one.
                      you have to take a reboot after that.
                      • 23. Re: iSCSI Broken after 11.1 Update
                        Would be nice to get a link posted here when it's available. I'm trying to use this too.
                        • 24. Re: iSCSI Broken after 11.1 Update
                          This registry modification is all I had to change to get a Windows 7 SP1 initiator to work with Solaris 11.1

                          Set the value to 0:

                          HKLM\SYSTEM\CurrentControlSet\Control\Class{4D36E97B-E325-11CE-BFC1-08002BE10318}\<Instance Number>\Parameters\ImmediateData

                          Much thanks!
                          • 25. Re: iSCSI Broken after 11.1 Update
                            winscp into the esxi5.1

                            navigate to /etc/vmwre/vmkiscsid/vmkiscsid.db

                            copy that db to your desktop

                            go download sqlite3


                            sqlite3 vmkiscsid.db
                            .mode line

                            these tables had immediatedata values (nodes, target and initiatornodes)

                            select * from nodes;

                            update nodes set '<immediatedata key>'='No'; (i cant remember the full key off the top of my head but they are all the same in 3 tables)

                            use winscp and replace the file you modified onto esxi 5.1

                            reboot your server

                            the options should now be unchecked

                            <this did not work for me reconnecting the lun, but the option for immediate data is unchecked>

                            maybe someone else can elaborate to get it working. This was all done in windows

                            iscsi is slow without immediatedata but hey it works.

                            sqlite3 http://www.sqlite.org/
                            winscp http://winscp.net/eng/download.php

                            EDIT: Please backup your vmkiscsid.db in case you make a mistake
                            • 26. Re: iSCSI Broken after 11.1 Update
                              This problem is still present in 11.1 SRU1.
                              • 27. Re: iSCSI Broken after 11.1 Update
                                Cindy, thanks for your research about this bug.

                                Since most of us probably would not be able to look up the bug database for the status of 15823698, could you update this thread with the info if there has been a patch release yet?

                                Kind regards,

                                • 28. Re: iSCSI Broken after 11.1 Update
                                  any update on this? i am a bit alarmed at the seeming nonchalance with which this /huge/ bug is being handled at oracle (even more alarmed that the only visible documentation is this thread).
                                  • 29. Re: iSCSI Broken after 11.1 Update
                                    I could not leave my iSCSI target broken so I have backed up my ZFS pool and installed OpenIndianna which in itself is not that great but at least it works. I cannot believe there is still no fix for this. If I was paying for a support contract I would be outraged especially considering storage is the only conceivable reason for using Solaris these days. That being said if and when it is fixed I will probably move back to Solaris as the OpenIndianna project looks to be going nowhere.