This discussion is archived
3 Replies Latest reply: Oct 31, 2012 12:27 PM by Dude! RSS

system-config-firewall

user11977218 Newbie
Currently Being Moderated
How to install : system-config-firewall in : Oracle Linux Server release 5.8 x86_64 ?
Because :

yum install system-config-firewall
Loaded plugins: rhnplugin, security
This system is not registered with ULN.
ULN support will be disabled.
Setting up Install Process
No package system-config-firewall available.
Nothing to do

Thank's
  • 1. Re: system-config-firewall
    845849 Newbie
    Currently Being Moderated
    user11977218 wrote:
    How to install : system-config-firewall in : Oracle Linux Server release 5.8 x86_64 ?
    Because :

    yum install system-config-firewall
    Loaded plugins: rhnplugin, security
    This system is not registered with ULN.
    ULN support will be disabled.
    Setting up Install Process
    No package system-config-firewall available.
    Nothing to do
    Did you set up the "Public Yum Server": http://public-yum.oracle.com/

    Rayson

    ============================
    http://gridscheduler.sourceforge.net/
  • 2. Re: system-config-firewall
    Veeresh.S Pro
    Currently Being Moderated
    try

    # cd /etc/yum.repos.d

    #wget http://public-yum.oracle.com/public-yum-el5.repo

    #vi /etc/yum.repos.d/etc/public-yum-el5.repo
    change enable=0 to enable=1 on both the el5_u5_base and ol5_u5_base

    [el5_u5_base]
    :
    :
    enable=1

    [ol5_u5_base]
    :
    :
    enable=1

    then save and exit
    #yum install system-config-firewall
  • 3. Re: system-config-firewall
    Dude! Guru
    Currently Being Moderated
    The wget utility does not replace any existing file unless you use the --output parameter.

    It's probably easier to simply delete the existing file:

    <pre>
    rm -rf /etc/yum.repos.d/etc/public-yum-el5.repo
    wget http://public-yum.oracle.com/public-yum-el5.repo
    </pre>

    It is not necessary to edit the file and to enable any channels to apply system updates and install additional packages. The el5_latest repository is enabled by default and that's all you need to have enabled. And eventually ol5_UEK_latest if you use the UEK 2 kernel. On March 22, 2012 Oracle included updates and errata for free.

    If the OP does not want to install any system updates and remain at the distribution level (s)he needs to enable only ol5_u8_base.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points