2 Replies Latest reply: Nov 1, 2012 9:45 AM by 971735 RSS

    [AWM] Analytic workspace object does not exist

    971735
      I am going through the tutorial here: http://st-curriculum.oracle.com/obe/db/11g/r1/olap/cube/buildicubes.htm

      For our work environment, all the source data is in the OLAPTRAIN schema, but all of the dimensions and cubes are built in the schema USER1. To accomplish this, I just changed all Mappings to the proper OLAPTRAIN schema. However, when I get to the Loading and Viewing Cube Data step and click on Maintain Cube SALES_CUBE I get the following error:

      INI: error creating a definition manager, Generic at TxsOqConnection::generic<BuildProcess>INI: XOQ-00703: error executing OLAP DML command "(STATLEN(USER1.SALESTRACK_USER1!TIME) : ORA-34492: Analytic workspace object USER1.SALESTRACK_USER1!TIME does not exist.
      )", Generic at TxsOqAWManager::evaluateExpression

      I take it that it is referring to the USER1's TIME dimension, which does exist. The TIME dimension was first created using a template, but there appeared to be something wrong with it so I recreated the dimension from scratch, recreating the mappings from the original TIME template. The old TIME dimension was deleted, and now only the manually generated TIME dimension exists.

      Any ideas?
        • 1. Re: [AWM] Analytic workspace object does not exist
          DavidGreenfield
          Run the following to list the dimension objects in the AW.
          set serverout on
          begin 
          dbms_aw.execute(q'!
           aw attach USER1.SALESTRACK_USER1
           listnames dimension
          !');
          end;
          /
          The error suggest that TIME is not a dimension in the AW. It is possible that you will find something like "TIME1" instead due to the creation mishap. To locate the name of the physical dimension associated with a logical (AWM) dimension you can do this. (11.2.0.2 or higher.)
          set serverout on
          begin 
          dbms_aw.execute(q'!
            show objorg(dim owner 'USER1' 'TIME')
          !');
          end;
          /
          • 2. Re: [AWM] Analytic workspace object does not exist
            971735
            Thanks, I already did an AWDESCRIBE in the Workbench and found TIME1, just as you say. I deleted the cube and the TIME dimension then rebuilt it, and it works fine now.