1 Reply Latest reply on Nov 6, 2012 6:05 PM by cawli2

    apex_al is not correctly configured, error: ORA-01017

      I am using ApEx Listener 2.0 EA with Glassfish 3.1.2 and ApEx 4.2. ApEx itself works fine, but I want to use the SQL Developer to administer the listener.
      I created the APEX_REST_PUBLIC_USER and APEX_LISTENER users in the database ( prior to configuring the listener. Passwords all the same.
      Administration user "adminlistener" configured as per the documentation using the same password.

      But when I try to connect to the listener from SQLDeveloper I get this error (detail logging turned on in the default.xml):

      The pool named: apex_al is not correctly configured, error: ORA-01017: invalid username/password; logon denied ConnectionPoolException [error=BAD_CONFIGURATION]

      I'm stumped. Any suggestions?

      Wayne Linton

      Edited by: cawli2 on Oct 31, 2012 11:17 PM

      I have just installed SQL Developer 3.2.2 ( and tried this again. I encounter the same error.
        • 1. Re: apex_al is not correctly configured, error: ORA-01017
          This would appear to be due to a couple of issues:
          1) I did not follow the ApEx 4.2 installation instructions regarding APEX_REST_PUBLIC_USER and APEX_LISTENER installation. Although I've installed ApEx a hundred times, lesson learned, RTFM.
          2) I was using a Glassfish installation from when it was configured for a version 1 listener, so it was set up to use security users in the server realm. I removed these and unchecked "Default Principal to Role Mapping"
          3) I removed and then redeployed apex.war and i.war
          4) for good measure I reinstalled the adminlistener user

          I can now connect to the ApEx listener via SQLDev. I am getting some error message re: UTF-8, as is another user in the forum, but it appears to be informational and is not preventing up/dowload of configuration.

          Wayne Linton