3 Replies Latest reply: Nov 4, 2012 11:07 AM by James_D RSS

    I need 1.6.34 or 1.6.37 for Mac OSX.

    971914
      Hey folks.
      I currently have java 1.7 installed on my machine.

      I need to remove this and install either 1.6.34 or 1.6.37 .

      Its for an Oracle issue.

      Can anybody advise me how i can remove the Java version and where i can download 1.6.34. I did google it but can't find a version for mac.
      http://www.oracle.com/technetwork/java/javase/downloads/jre6-downloads-1637595.html

      Also, the above link seems to have the correct version, but i don't know which version is for mac.
      Thanks for your assistance.
        • 1. Re: I need 1.6.34 or 1.6.37 for Mac OSX.
          gimbal2
          1.6 was delivered by Apple, not by Oracle. Only starting from Java 7 update 5 Oracle delivers the runtime.

          So if you want it, you'll have to look around the Apple technology website or whatever it is called.
          • 2. Re: I need 1.6.34 or 1.6.37 for Mac OSX.
            jschellSomeoneStoleMyAlias
            I guess Apple is still doing security updates.

            Basically I believe you would need to find something before 1.6.34, install it, then install patches.

            At any rate following seems to suggest it is 1.6.37.

            http://support.apple.com/downloads/#java
            • 3. Re: I need 1.6.34 or 1.6.37 for Mac OSX.
              James_D
              Are you sure some version of 1.6 isn't still there? The Apple-provided 1.6.0_xx are installed in a different location to the Oracle 1.7.0 versions. For the Apple JREs, look in /System/Library/Java/JavaVirtualMachines. For the Oracle JREs, look in /Library/Java/JavaVirtualMachines. By default, installing the Oracle VMs will not uninstall the Apple ones, they'll just point the default java command to the new version.

              You can also open the JavaPreferences app, which is (by default) under Applications/Utilities. It will list all installed JREs; you can drag to change the order in which they're accessed.