2 Replies Latest reply: Nov 1, 2012 10:47 AM by benp11 RSS

    Automated Composite build/test not work with non-default version


      I have a BPEL composite and I am trying to setup maven and soapUI to build, deploy, test, and upon successful test, set it as the default version. The difficulty I am having is testing the composite before it becomes the default version. I am able to hit the endpoint using the full URL with the randomly generated ID in it using soapUI (see below), but not by using the shortened URL.

      Full URL: http://soabpm-vm:8001/soa-infra/services/default/Project1!0.0.12-SNAPSHOT*soa_13954572-b91f-480d-88d2-037e92083d72/bpelprocess1_client_ep
      Shortened URL: http://soabpm-vm:8001/soa-infra/services/default/Project1!0.0.12-SNAPSHOT/bpelprocess1_client_ep

      I tried hitting the shortened URL outside of the maven build, just using soapUI, and the response is empty. However, if I then mark this new version as default (through EM), and then mark a previous version as default (let's say 0.0.11), then the shortened URL for 0.0.12 can be successfully hit.
      It seems to me then that before the shortened URL above can be used, that specific version must have been set as the default version at some point. This would make an automated maven/soapUI test of new version (but not default) quite difficult, as it would have to somehow retrieve the full URL.
      Is this a bug or can it be fixed with a config setting change?

      Here are the steps in the process, maven build (using the Oracle provided ant sca files):
      1. Compile
      2. Package
      3. Deploy, not as default
      4. Test the new version (using soapUI plugin)
      5. If successful tests, mark new version as default

      The problem is with step 4, can't determine what the full URL is and the shortened URL does not work.