2 Replies Latest reply: Nov 3, 2012 12:09 PM by 972127 RSS

    Archive logs are not transferred from Primary to Standby

    972127
      The standby database is occasionally missing some archive logs that are not transferred from the primary database. The following archive logs are received but not applied on the standby as there is one or more files missing in the sequence.
      I transferred the missing files manually and applied them manually on the standby using 'alter database register logfile...
      This triggered again a miss-transfer of files from primary to standby and the standby is missing again some archive logs.

      The standby is configured in the primary as:
      log_archive_dest_2 = "SERVICE=XXXXXX_S ASYNC VALID_FOR=(ONLINE_LOGFILES, PRIMARY_ROLE) REOPEN=60 DB_UNIQUE_NAME=XXXXXX_S"

      The trace logs show these errors:
      krsb_stream_send: Error 3135 sending stream IOV
      RFS network connection lost at host 'XXXXXX_S' error 3135
      Error 3135 writing standby archive log file at host 'XXXXXX_S'
      *** 2012-11-01 23:42:28.611 4132 krsh.c
      LNS: Attempting destination LOG_ARCHIVE_DEST_2 network reconnect (3135)
      *** 2012-11-01 23:42:28.611 4132 krsh.c
      LNS: Destination LOG_ARCHIVE_DEST_2 network reconnect abandoned
      ORA-03135: connection lost contact
      *** 2012-11-01 23:42:28.611 4132 krsh.c
      Error 3135 for archive log file 2 to 'XXXXXX_S'
      *** 2012-11-01 23:42:28.611 2747 krsi.c
      krsi_dst_fail: dest:2 err:3135 force:0 blast:1
      ORA-03135: connection lost contact
      Closing Redo Read Context

      And I can predict a miss-transfer when I see in the alert log the following line on the primary:
      LNS: Standby redo logfile selected for thread 1 sequence 65791 for destination LOG_ARCHIVE_DEST_2
        • 1. Re: Archive logs are not transferred from Primary to Standby
          mseberg
          Hello;

          Do you have sqlnet.ora timeout parameters set?

          If not I would consider setting. I can post an example if you want.

          Prevent Timeouts

          Add these to both servers

          To listener.ora
          INBOUND_CONNECT_TIMEOUT_ = 120

          To sqlnet.ora
          SQLNET.INBOUND_CONNECT_TIMEOUT = 120


          Then stop and start the listener.

          You can consider this too :

          SQLNET.EXPIRE_TIME=10

          These may also help :

          How to resolve MRP stuck issues on a physical standby database? [ID 1221163.1]

          Troubleshooting - Heartbeat failed to connect to standby [ID 1432367.1]

          Best Regards

          mseberg

          Edited by: mseberg on Nov 2, 2012 5:00 AM
          • 2. Re: Archive logs are not transferred from Primary to Standby
            972127
            I read about the proposed parameters but these should be tuned if there are TNS errors in the listener.log or sqlnet.log. I have none.
            I will check the IDs.

            Edited by: user13512353 on Nov 3, 2012 10:09 AM

            Edited by: user13512353 on Nov 3, 2012 10:09 AM