This discussion is archived
1 Reply Latest reply: Jan 18, 2013 3:10 PM by 985332 RSS

Question about VLAN handling for virtual switches and vnets

DamnGoodCoffee! Newbie
Currently Being Moderated
Regards,

We are encountering some problems when using VLAN tagged 10g ethernet. We assign the VLANS to the vsw like this:

ldm add-vsw net-dev=net2 mtu=9000 vid=vid1,vid2,.... mode=sc primary-vsw0 primary

the mode=sc is due to us planning for possible Solaris Cluster installation for some guests. The guest get its vnets like this:

ldm add-vnet mode=hybrid vid=vid1 vnet0 primary-vsw0 guest
.
.

we use mode=hybrid since this is a NIU 10 gig eth interface in a T4-4. My questions are:

1. Do you see any problems with this config ?
2. Do you know of any problems with using VLAN tagging in virtual switches/virtual nets for LDOMs ?
3. When adding, subtracting VLANS to the vsw does it need to recreated or does a ldm set-vsw vid=vid1,... work dynamically (this goes of course for other vsw properties as well) ?

This is VM Server for SPARC v2.2, Solaris 11 for control and service domains, solaris 10 in the guest LDOMs.
Thanks,

Edited by: DamnGoodCoffee! on Nov 2, 2012 4:59 AM
  • 1. Re: Question about VLAN handling for virtual switches and vnets
    985332 Newbie
    Currently Being Moderated
    Hi,

    1.
    - If you want that the vnet is handling the VLAN tagging for you, you need to set the pvid.
    - If you want to do the VLAN tagging in the guest LDOM (via the interface name vnetVLANID00x), it is OK.

    2. We use VLAN tagging in vnetX via setting the pvid for the vnet for guest LDOMs, and we use the interface name based VLAN tagging in the primary domain on the vsw interface.

    3. You don't need to recreate, you can set it. I'm not sure if you need to reboot to let it take effect, but IIRC it is dynamic (should be easy to test).

    Bye,
    Alexander.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points