0 Replies Latest reply on Nov 2, 2012 6:28 PM by 972232

    query result contains fewer columns than expected

      Brief version: I the Oracle.DataAccess.dll ( component to query a table with almost 600 columns (please note that I have no control over the database schema) and the amount of columns returned is considerably fewer than expected (about half). I have tried both select * and select column i, column i + 1, ... column n from ... and I get the same result. Please, offer any explanation of this behavior.

      Detailed version: Using the Oracle.DataAccess.dll ( component:
      I am running a select * on a table with ~ 575 columns, most of which are of the "Number" data type. After starting the read OracleDataReader instance's FieldCount property says 289. I tried to use the OracleDataAdapter's fill method with the same command, and the DataTable's column collection count some back with 289. Can anyone tell me how I can select all 575 columns from the table?

      I assume 289 is function of the RowSize property of the reader, which happens to be 7292, and the composition of the table column types. The Fetch size and all other properties on all instances used are defaults.

      Please, let me know if I can provide any other information as it is important to me to understand the behavior these components. Thanks.