This discussion is archived
0 Replies Latest reply: Nov 3, 2012 1:03 AM by 972305 RSS

The https URL hostname does not match the Common Name (CN) on the server.

972305 Newbie
Currently Being Moderated
Hi,

I am getting the following error while trying to use https with our self-signed certificates.

javax.xml.ws.soap.SOAPFaultException: Marshalling Error: The https URL hostname does not match the Common Name (CN) on the server certificate. To disable this check (NOT recommended for production) set the CXF client TLS configuration property "disableCNCheck" to true.

The above error is the error I get, when I try to use the Web Services using https.

I have added the following lines in cxf.xml but it still doesn't seem to work correctly.

<http-conf:conduit name="*.http-conduit">
<!-- deactivate HTTPS url hostname verification (localhost, etc)
WARNING ! disableCNcheck=true should NOT be used in production -->
<http-conf:tlsClientParameters disableCNCheck="true" />

Kindly let me know on what would be the issue here?.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points