3 Replies Latest reply: Nov 6, 2012 6:45 AM by vikrams RSS

    couldn't start the oracle asm in standalone node

    829393
      Hi experts,

      I am using an asm 11g r2 to serve the primary database however, while reboooting my machine i am unable to start the ASM.
      facing the below errors while kicking the startup...

      SQL> startup
      ORA-01078: failure in processing system parameters
      ORA-29701: unable to connect to Cluster Synchronization Service
      SQL> exit


      THanks,
      Pmon.
        • 1. Re: couldn't start the oracle asm in standalone node
          829393
          Please ignore my other thread as there was a network fluctuation due to that I the two posts got uploaded!!!! However, I have fixed the issue by performing the below steps... Diskgroup error is not issue for me as i have restart the storage services...

          [root@rac1 bin]# ./crsctl start has
          CRS-4123: Oracle High Availability Services has been started.
          [root@rac1 bin]# ps -ef |grep css
          oracle 8963 1 0 09:40 ? 00:00:00 /u01/app/oracle/11.2.0/grid/bin/cssdagent
          oracle 9003 1 0 09:40 ? 00:00:00 /u01/app/oracle/11.2.0/grid/bin/ocssd.bin
          root 9051 8589 0 09:40 pts/3 00:00:00 grep css
          [root@rac1 bin]# exit
          logout
          [rac1 +ASM] /home/oracle=>sqlplus

          SQL*Plus: Release 11.2.0.1.0 Production on Mon Nov 5 09:40:51 2012

          Copyright (c) 1982, 2009, Oracle. All rights reserved.

          Enter user-name: / as sysdba
          Connected.
          SQL> !ps -ef |grep pmon
          oracle 9109 1 0 09:40 ? 00:00:00 asm_pmon_+ASM
          oracle 9180 9066 0 09:41 pts/3 00:00:00 /bin/bash -c ps -ef |grep pmon

          SQL> select name,state from v$asm_diskgroup;
          select name,state from v$asm_diskgroup
          *
          ERROR at line 1:
          ORA-01034: ORACLE not available
          Process ID: 0
          Session ID: 0 Serial number: 0


          SQL> exit
          Disconnected
          [rac1 +ASM] /home/oracle=>sqlplus

          SQL*Plus: Release 11.2.0.1.0 Production on Mon Nov 5 09:41:35 2012

          Copyright (c) 1982, 2009, Oracle. All rights reserved.

          Enter user-name: / as sysasm

          Connected to:
          Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 - Production
          With the Automatic Storage Management option

          SQL> select name,state from v$asm_diskgroup;

          no rows selected

          SQL> startup force
          ORA-00099: warning: no parameter file specified for ASM instance
          ASM instance started

          Total System Global Area 284565504 bytes
          Fixed Size 1336036 bytes
          Variable Size 258063644 bytes
          ASM Cache 25165824 bytes
          ORA-15110: no diskgroups mounted
          • 2. Re: couldn't start the oracle asm in standalone node
            829393
            I rebooted the server again and met with the same issue, finally I got know the issue is due to the hostname conflict...

            [root@rac1 ~]# cd /u01/app/oracle/11.2.0/grid
            [root@rac1 grid]# cd bin
            [root@rac1 bin]# ./crsctl start has
            Failure at scls_scr_getval with code 1
            Internal Error Information:
            Category: -2
            Operation: opendir
            Location: scrsearch1
            Other: cant open scr home dir scls_scr_getval
            System Dependent Information: 2

            CRS-4000: Command Start failed, or completed with errors.
            [root@rac1 bin]# ps -ef |grep css
            root 6968 6892 0 10:52 pts/2 00:00:00 grep css
            [root@rac1 bin]# ps -ef |grep
            Usage: grep [OPTION]... PATTERN [FILE]...
            Try `grep --help' for more information.
            [root@rac1 bin]# hostname rac1-clone.dba.com
            [root@rac1 bin]# ./crsctl start has
            CRS-4123: Oracle High Availability Services has been started.
            [root@rac1 bin]#
            • 3. Re: couldn't start the oracle asm in standalone node
              vikrams
              You can enable auto start of the services . Run through as root
              crsctl modify resource ora.asm -attr ENABLED=0
              crsctl modify resource ora.cssd -attr AUTO_START=always