1 Reply Latest reply: Nov 28, 2012 9:13 AM by 905535 RSS

    JMS : java.security.PrivilegedActionException during order execution

    Shital
      Hi,
      I have designed automated task and it's using internal Queue as oms_ws_requests. While executing this automated task, the system is throwing following exception -

      <WSEE:105>javax.jms.JMSException: java.security.PrivilegedActionException: weblo
      gic.jms.common.JMSSecurityException: Access denied to resource: type=<jms>, appl
      ication=oms_jms_module, destinationType=queue, resource=oms_ws_requests, action=
      receive<JmsQueueListener.handleConnectionException:338>
      javax.jms.JMSException: java.security.PrivilegedActionException: weblogic.jms.co
      mmon.JMSSecurityException: Access denied to resource: type=<jms>, application=om
      s_jms_module, destinationType=queue, resource=oms_ws_requests, action=receive
      at weblogic.wsee.server.jms.JmsQueueListener.connect(JmsQueueListener.ja
      va:263)
      at weblogic.wsee.server.jms.JmsQueueListener.run(JmsQueueListener.java:3
      64)
      at java.util.TimerThread.mainLoop(Timer.java:512)
      at java.util.TimerThread.run(Timer.java:462)

      I did security settings with policies tab as "Allow Access to everyone", still not working..

      Can anybody please help me.
      Thanks in advance.

      Warm Regards,
      Shital

      Edited by: Shital on Nov 8, 2012 1:12 AM
        • 1. Re: JMS : java.security.PrivilegedActionException during order execution
          905535
          Hi Shital,

          Your automated task is posting message on 'oms_ws_requests' queue that means you want to use OSM webservice.

          OSM webservices are secure webservices and you have to mention this security infornation in JMS message header.

          Need to add below header in JMS message that you are posting on 'oms_ws_requests' queue.

          <soapenv:Header>
               <wsse:Security>
          <wsse:UsernameToken>
          <wsse:Username>{ $user }</wsse:Username>
          <wsse:Password Type="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-username-token-profile-1.0#PasswordText">{$pass}</wsse:Password>
          </wsse:UsernameToken>
          </wsse:Security>
               </soapenv:Header>

          Regards,
          UJ