This discussion is archived
1 Reply Latest reply: Nov 26, 2012 10:24 AM by 907915 RSS

After Solaris 11.1 upgrade "GPU hung" OS starts, but no graphics, GPU hung

user12163570 Newbie
Currently Being Moderated
I have an Intel DH77EB motherboard. Solaris 11 installed fine (after disabling Intel VT-d). Upgrade to 11.1 processes went fine. OS boots up. Not services in maintenance mode. But, I can't access the console because the GPU has hung. Get the following in /var/adm/messages:


Nov 8 15:18:51 media genunix: [ID 851289 kern.warning] WARNING: [drm:i915_do_wait_request:1479] wait_for: i915_do_wait_request taking EBUSY
Nov 8 15:18:51 media genunix: [ID 552796 kern.warning] WARNING: [drm:i915_do_wait_request:1490] i915_do_wait_request returns -16 (awaiting 1292 at 1291, next 1293)
Nov 8 15:18:54 media genunix: [ID 851289 kern.warning] WARNING: [drm:i915_do_wait_request:1479] wait_for: i915_do_wait_request taking EBUSY
Nov 8 15:18:54 media genunix: [ID 552796 kern.warning] WARNING: [drm:i915_do_wait_request:1490] i915_do_wait_request returns -16 (awaiting 1292 at 1291, next 1293)
Nov 8 15:18:57 media genunix: [ID 851289 kern.warning] WARNING: [drm:i915_do_wait_request:1479] wait_for: i915_do_wait_request taking EBUSY
Nov 8 15:18:57 media genunix: [ID 552796 kern.warning] WARNING: [drm:i915_do_wait_request:1490] i915_do_wait_request returns -16 (awaiting 1292 at 1291, next 1293)
Nov 8 15:19:03 media genunix: [ID 409100 kern.warning] WARNING: [drm:i915_hangcheck_elapsed:1447] Hangcheck timer elapsed... GPU hung

scanpci output:
pci bus 0x0000 cardnum 0x02 function 0x00: vendor 0x8086 device 0x0152
Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller


In the HCL, it appears that the graphics device is supported.

HCL webpage snippet:
8086,162
i915
Information
Video
Intel Corporation
Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller
8086,152
i915
Information
Video
Intel Corporation
Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller
end snippet
  • 1. Re: After Solaris 11.1 upgrade "GPU hung" OS starts, but no graphics, GPU hung
    907915 Newbie
    Currently Being Moderated
    I had trouble with Gnome desktop after upgrading from 11.0 to 11.1
    Solution was to remove pkg SUNWvboxguest.
    After suggessful remove I could re-run pkg upgrade.

    Check/paste /var/log/Xorg.0.log that might give some hints...

    I got eg. this error; but NOW its working...:)
    Nov 15 20:18:59 dagobert11 gdm-binary[1109]: [ID 702911 daemon.warning] WARNING: GdmDisplay: Display /org/gnome/DisplayManager/Display1 failed 5 times in 18.000000 seconds, no longer managing display

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points