6 Replies Latest reply on Nov 14, 2012 9:02 AM by user9212679

    Trusted database recon not working


      I am trying to run trusted database reconcilition, the trusted recon job executes fine and reconcilition events are generated for the accounts.

      But the user is not created in OIM, also there is no error.

      Following are the content of the reconciliation event :

      Event …

      Event ID 2018
      Current Status Creation Succeeded
      Entity User
      Type Incremental
      Key Fields TUser62
      Action Date Action Date not specified

      Date and Time November 9, 2012 5:56:33 PM IST
      Job ID 5281
      Resource Name TESTEMPLOYEE_GTC
      Profile Name TESTEMPLOYEE_GTC
      Modifier ID Internal User

      Linked To …

      Linked User TUSER62 - null
      Linked By Rule Based Linking

      I have checked the reconciliation action rules in resource object and for the condition "No Matches Found" the action rule associated is "Create User"

      Please let me know what could be the possible reason for this issue.

        • 1. Re: Trusted database recon not working
          Nishith Nayan
          check if Reconciliation Rule is Active . create reconciliation profile once again and run recon scheduled task.

          Share console log
          • 2. Re: Trusted database recon not working

            I can see the users got created in oim when I ran the sql query on oim DB.
            Surprisingly I am not able to search those user via UI when I try to get list of all the users. But I was able to get the user listed via advanced search.

            But now I am facing another issue. My incremental recon is not working. When I am running incremental recon it is generating reconciliation event for all the records.

            I tried adding the Timestamp Attribute in the design parameters of connector as the Trusted database table timestamp column name but it started throwing the exception as Caused By: com.thortech.xl.gc.exception.DBException: Attribute: does not exist in the specified parent table/view: User1.Comp_users

            Please let me know if I am doing something wrong.

            • 3. Re: Trusted database recon not working
              Dhananjay Neeraj2
              I am afraid it might be due to some limitation of GTC...

              It seems that the GTC does not use ignoreEvent() method for Incremental ones...

              boolean bool = localGenericAdapter.getReconType().equals("Full");

              if ((!bool) || (!localtcReconciliationOperationsIntf.ignoreEvent(str4, localMap)))

              l2 = localtcReconciliationOperationsIntf.createReconciliationEvent(str4, localMap, false);

              As the above snippet implies, if it is Incremental, i.e. bool is false, it simply goes ahead and creates event without ignoreEvent()...
              • 4. Re: Trusted database recon not working

                Thanks for the reply.

                Please let me know the way to proceed further, so that incremental trusted recon should be working.

                • 5. Re: Trusted database recon not working
                  Dhananjay Neeraj2
                  Use Full Recon instead of Incremental...

                  Actually, in the Incremental recon, it assumes that ONLY Changed records are provided to it... So, it does not bother to call ignoreEvent() method...

                  If you rather use Full recon, it will itself figure out which records are changed, which are not by calling ignoreEvent() method...

                  And since it is Database recon, if you have provided any flag, say UPDATE_DATE flag or something in the database side, use this one to narrow down your search criteria at the filter level itself... rather than having to go through each record in 10k records to figure out that these 5 records were changed... I worked only on Flat File GTC connector... So, I am not sure whether there is any such facility to provide query for narrowing down the search result... However, if there is any such facility, use it fully... It will be 1000 times better than making GTC incremental...
                  • 6. Re: Trusted database recon not working
                    Thanks I got this working.

                    Look like in OIM the attribute name is case sensitive so I have matched the cases of the attribure and it worked fine.

                    Also the suggestion given by you is good and I will keep in mind so that may be in fiture it would be helpful.

                    Thanks again.